• Hi people of the FOG forum,

    I have a problem with the deployment of some windows images and I can’t seem to figure out what the problem is, so I come here to seek some advice.

    My problem lies with the fact that FOG won’t properly deploy an image to the selected host.

    For example: I have a windows 8 PC that I want to upgrade to windows 10. I do this by deploying a Windows 10 image via UEFI pxe and selecting it in the FOG menu. It will now start to deploy untill the process is complete. I get no errors or warning messages.

    The PC auto reboots from its disk, but then boots up into windows 8 again. If I look at the storage capacity it is still the same as before deploying the Windows 10 image. This tells me that no data has been written in the deployment proces. If I boot into the boot menu I now have two different Windows boot manager options, but only the one that boots to Windows 8 works.

    It does, however, work in reverse. I can succesfully deploy a windows 8 image on to a former Windows 10 PC. This is all very confusing to me, as I have no idea where to look for the problem and can’t find anything conclusive about the subject online.

    My image settings are as follows:
    Image type - Single disk - Resizable
    Partition - Everything
    Protected -
    image enabled - ☑
    Replicate - ☑
    image manager - Partclone Zstd

    The image size is around 34 GB due to some Addobe applications being installed on it.

    Host settings are default, although I have tried changing the Primary disk setting to different variations of /dev/sda, which gave me the same result as described earlier.

    I have tried this with multiple PC’s, same result all round. I have also tried deploying Ubuntu on the Windows 8 machine, but sadly no dice.

    Any help would be greatly appriciated. If you require more information I will be happy to provide. I have a beginner/moderate understanding of FOG and Linux.

    Kind regards,

    VlanFlex

  • Senior Developer

    @VlanFlex said in FOG won't deploy properly.:

    https://ibb.co/D1wd4cs
    Any idea why it would show up as an SATA device?

    Can’t see enough information on the picture as it’s not clear enough. M.2 does not mean the disk is NVMe in general! So I can imagine this to be a M.2 SSD drive showing up as sdX in Linux. You can run hdparm -i /dev/sdX (put in a and b instead of the X) to get some more information about the disk drives.

  • Moderator

    @VlanFlex Ok what I’m speculating is that FOG IS working as its being instructed. It is deploying the image to what it sees as /dev/sdb. Ubuntu also see the 250GB as /dev/sdb. I think what is missing is the uefi firmware doesn’t either see the disk as bootable or the legacy windows 8 menu entry points to a location that doesn’t exist any more. I’m trying to isolate is it fog doing something wrong, or what you are asking FOG to do is causing it to fail.

    If you look at that /dev/sdb with a utility like gparted does it appear to be an intact uefi disk? If your disk structure is MBR that brings in a new issue since the 250 GB disk is being reported as the second hard drive.


  • @george1421 I cannot boot into Windows 8 anymore. All I get is the reFIND screen.

    To verify the contents of the two drives I’ve launched live ubuntu via USB on the target PC.

    There are two drives present, both called D with the same contents.

    https://ibb.co/ZXSHwP3
    https://ibb.co/rpHmgfv

  • Moderator

    @VlanFlex Ok so if you go through the windows boot manager can you still boot into the windows 8? If so lets check the content of that 250GB drive. Does it appear to be a windows 10 disk?


  • @george1421 I have started a deployment proces in debug mode. Here are the photo’s.

    1 - https://ibb.co/pRTFXct
    2 - https://ibb.co/f4K593S
    3 - https://ibb.co/z7qgBVd
    4 - https://ibb.co/sqJBzzB

    After this proces I booted from harddisk via the FOG menu and get booted straight into reFIND. There are still two Windows boot loader options in the boot menu, but none work.

    If I try to add a UEFI boot option I get file system not found.

    EDIT: if necessary I can also make a video of the whole imaging process, but thats gonna take me some time.

  • Moderator

    @VlanFlex Ok you are currently sitting (at the target computer) at the FOS Linux command prompt? If so lets go ahead and try to image this computer. Have a mobile phone handy to see if we can catch the actual error. I might expect something to be displayed on the blue partclone screen. So to start imaging in debug mode key in fog and press enter. You will need to press enter at each breakpoint to continue on to the next step. These breakpoints hopefully will give you a chance to catch any errors.

    I can see (in my mind) that FOG is working as intended, but the system will not boot because you are deploying to the second drive, and your windows 8 image is actually on your 450GB drive. That 480 GB drive is listed as /dev/sda (first disk found) and then the disk you are deploying to is /deb/sdb (second disk found). The problem may be the uefi boot manager is still pointing to the 450GB drive.


  • @george1421 @Sebastian-Roth Also pointed out that /dev/sdb is SATA annotation. This is quite confusing to me since I can physically see the SATA SSD and M.2 here.

    https://ibb.co/D1wd4cs

    Any idea why it would show up as an SATA device?

    As to awnser your question, I would like the operating system to be installed on the ‘‘m.2’’, which is 256 GB.

  • Moderator

    @VlanFlex So it looks like you have 2 sata disks installed. Do you know based on the size which one you want to deploy to?


  • @george1421 I have updated to kernel version 5.16.18 and ran the command that you asked

    I keep getting an error when I try to upload an picture here, so here is a link.
    Apologies for it being sideways

    https://ibb.co/55xt6zH

    Also turns out that the Samsung SSD is actually a KINGSTON 480GB SSD.

  • Moderator

    @VlanFlex said in FOG won't deploy properly.:

    /dev/sdb

    Just be aware that nvme disks are labeled differently. /dev/sdX is for sata disks.


  • @Sebastian-Roth Hi Sebastian,

    Thank you for replying.

    The blue partclone screen indeed shows up untill the red progressbar is full and the deployment proces is complete. There is one M.2 module and one Sata SSD present. I have tried deploying with only the M.2 connected with the same result.

    To verify what I said about no data being written, I have just tried it again. This time I only get the reFIND screen. It looks like what I said about data not being written was indeed false.

    The only thing that I changed between making this post and now is changing the Primary host disk to /dev/sdb

  • Moderator

    @VlanFlex OK lets first start by updating the FOS Linux kernel to 5.6.18. You may not need it for this hardware, but you will.

    Its interesting that its not throwing an error during the install.

    Once you update the kernel then schedule a new deployment but tick the debug checkbox before scheduling the task. Then pxe boot the target computer. After a few screens of text that you need to clear with the enter key, you will be dropped to a linux command prompt. At the linux command prompt key in lsblk this will show us the disk structure. It sounds from your instructions there are 2 drives in the system. If you want to put the image on the nvme drive you will need to add that value to the host configuration.


  • @george1421 Hi George,

    Thank you for replying.

    The target computer is a Dell OptiPlex 5060.
    CPU: I5 8500 3GHz
    RAM: 8x2 2666 MHz DDR4
    Storage: 1x M.2 256GB module and 1x 256GB Samsung Sata SSD
    Motherboard: Custom Dell motherboard with 1G ethernet port

    I have ran the hardware compatibility checker again just to be sure. It passed.

    I am using FOG version 1.5.9
    Kernal version 4.19.143 TomElliott 64


  • This post is deleted!
  • Senior Developer

    @VlanFlex said in FOG won't deploy properly.:

    It will now start to deploy untill the process is complete. I get no errors or warning messages.

    Do you actually see the blue partclone screens? If that is the case I cannot imagine it doesn’t write anything to the disk. Kind if impossible.

    Possibly you have two NVMe disks in this system?

  • Moderator

    What hardware is the target computer?

    Does this hardware pass the hardware compatibility checker via the fog iPXE menu? (one might guess yes because your install did not error out)

    What version of FOG are you using?

    What version of the FOS Linux kernel are you using? (FOG Configuration -> Kernel)

383
Online

8.1k
Users

15.0k
Topics

141.3k
Posts