Unable to locate image store



  • Hello team I am suddenly having an issue deploying a standard image. “…Unable to locate image store” yet I am imaging another machine right now of a different type. I am scratching my head on this one. Can anyone help? The image exists in the /images folder.


  • Senior Developer

    @Jim-Holcomb I still don’t fully understand. The database is just a point to store and pull the data from. Nothing more.

    If you manually rename the folder in Linux, would you expect the database to automatically update when now it has no reference point? It’s the same reason in reverse. Why allow the folder to be renamed in the terminal if it won’t update the database that may be referencing it?

    The folder doesn’t get automatically created when you define a new image. This only happens after the image is defined and captured. The pieces handling it are all after the database information is pulled. The GUI is not creating the folder. FTP is.

    If you manually change the folder name in the terminal, you will still need to change the folder in the GUI. It’s the same for updating the path in the GUI. While you could temporarily store the change, but what about you are changing the path when the image hasn’t been captured yet?



  • @Tom-Elliott Thanks Tom. If this is the case, then why have the rename feature at all?


  • Senior Developer

    @Jim-Holcomb said in Unable to locate image store:

    Yet in the /images folder it was still called the original filename of m78win10r3 and was never renamed. I went into terminal and renamed it manually, and that worked.

    @Tom-Elliott This sentence below the picture might explain it a but more.

    But why does the FoG GUI have the option to rename an image file, but doesn’t actually perform that option and rename the file as requested?

    Exactly the situation you describe is enough of explanation to show that it’s very hard to get this right. We never know if people mess with the image folders manually. Trying to rename things can only end in a mess.


  • Senior Developer

    @Jim-Holcomb I don’t follow?

    The name of the image is just that, a name.

    The path to the image is a never changing thing, in theory.

    So when you first create an image within the GUI, it sets up a path based on the image name, but it’s not a hard set rule. When updating an image in the GUI, maybe you want to rename it something simpler. Say instead of r4 you just want it called golden master. But when you first captured it it was stored to /images/win10gi

    Just renaming the image shouldn’t change the path to reach it. Make sense?

    Also the items in the GUI are stored in a database. I highly doubt you’d want a web based utility capable of renaming entire folder structures. Imagine the security issues such a thing would cause? The GUI and database are reflections of one another. We use the database info to get and populate data we need to use later on. The path is just saying where to look for data. Actually changing an old path to your new path? Yeah I wouldn’t want to imagine the security implications. If not done properly you lose control of fog server. Not gonna try to add that.



  • @Sebastian-Roth @Tom-Elliott Well guys, that was the issue. I updated my image, and because I updated it, I wanted to change the version number (from …r3 to …r4) I went into the fog gui, found the image and chose to rename the image using the menu option in the fog gui.
    20201008_101753_resized.jpg

    Yet in the /images folder it was still called the original filename of m78win10r3 and was never renamed. I went into terminal and renamed it manually, and that worked. But why does the FoG GUI have the option to rename an image file, but doesn’t actually perform that option and rename the file as requested?

    As always guys, thanks for what you do. You al make my life so much easier.


  • Senior Developer

    @Jim-Holcomb Also make sure the case of the image path/name does match to the point! While Windows doesn’t care on Linux /images/M78Win10r4 and /images/m78win10r4 are two different paths!


  • Senior Developer

    @Jim-Holcomb the image name isn’t the problem, what is the image path? Both according to the UI and the actual image location?



  • @Tom-Elliott Hi Tom., Thanks for your response. In this case I did not do anything but change the image name, but I used the FoG interface to do it. I can see in the /images folder that the correct image folder exists and the files inside are proper. So when I go to do a “deploy image” I see the image I want and it is named properly. I select it, and that is when I get that error. 20201007_114147_resized.jpg Any thoughts?


  • Senior Developer

    The “Unable to locate image store” message comes from not finding the image in the location it’s expected.

    Meaning: The path you have set for the image is not the true path expected for the image.

    Look at the host that’s giving this error, what image is associated. Look at that image, and find out the path it’s expected to exist at.

    I have seen this with you setup in the past. I know you move images off and on from the datastore to a backup, and then put them back when needed. My guess is there’s a typo on the path that you restored.


Log in to reply
 

259
Online

7.5k
Users

14.6k
Topics

137.6k
Posts