Host and Mac Passthrough with USB C Dock


  • I have been using dell WD19 USB C dock and Dell Latitude 3500s. With the default option to use system unique passthough, I was able to register the MAC of the dock, and when booting a laptop connected to that dock FOG showed up as the static host of the dock and I would be able to schedule a task.

    However, now with the next generation Latitude 3510, when I boot into FOG like this, it will say HOST UNREGISTERED because MAC pass-through is working differently once into FOG. If I try to even a quick host reg here, nothing happens. It is not using the dock mac address like the 3500 firmware did, but trying to use its system unique MAC…

    Is there anything I can do with those 3510 instead of disabling Mac Passthrought completely in the bios, then turned it back on after it images?

    Using IPXE.EFI and latest Dev FOG 1.5.9.28

    bzImage Version: 4.19.143
    bzImage32 Version: 4.19.143


  • @Sebastian-Roth Just replaced a mobo on a failed 3500, and it came with latest bios, which now acts the same as the 3510 😞

    So it seems my work flow with imaging 3500 only worked due a bug in the firmware on the 3500s.

    Going to either set the bios to pass-through disabled on unboxing or put together a new imaging work flow.

  • Senior Developer

    @oceanfish Ok, got that.


  • @Sebastian-Roth the iPXE DHCP screen will always show the mac passthrough on these 3510s, on the 3500s, the iPXE screen always showed the mac address on the WD19 dock (which I wanted, to utilize being able to task the dock and have anything attached to it auto-deploy).

    So booting into FOG with 3500 would say HOST REGISTERED (of the Dock), I can schedule tasks using dock mac. I can unbox a laptop throw it on a pre-assigned dock and have it auto image via scheduled task. (and the name will be the dock host name once windows boots).

    Booting into fog with 3510 would say HOST UNREGISTERED when connected to the dock (I think this is really how it SHOULD be, but would love if the 3510 would act like the 3500s)

  • Senior Developer

    @oceanfish said in Host and Mac Passthrough with USB C Dock:

    Just these new 3510 act different with iPXE

    Is the MAC address you see in the screen when iPXE loads every time a different one?


  • @MikeBC Don’t have any WD15 to test, only WD19

    Its funny because I created a workflow that works flawless on the latitude 3500 with them, it really shouldn’t work like it does because of MAC passthrough, but working in my favor.

    Just these new 3510 act different with iPXE


  • @oceanfish I had issues using a Dell WD19 dock as well especially via network boot to FOG. I did change to Dell WD15 dock and they seem to work much better with far fewer issues relating to network boot to FOG. Maybe try that as course of action.

  • Moderator

    @oceanfish said in Host and Mac Passthrough with USB C Dock:

    iPXE tries to use the passthru MAC instead

    I’m not sure what this passthru MAC is. Is this a unique mac address to that specific computer? If so that is something I would think you want. Now if iPXE is seeing mac X and FOS Linux (kernel) is seeing macY then that is a different story.


  • I tried both snp.efi and snp.efi, same thing iPXE tries to use the passthru MAC instead 😞
    It did boot much quicker into FOG menu since it skipped the part where it tries to use onboard ethernet first and times out after 30 sec though…
    Is there any other boot option to try besides SNP?

    I’ll look into the kernel update

  • Moderator

    @oceanfish The FOG iPXE menu is managed by the ipxe boot loader so the registered/nonregistered message is coming from iPXE. FOS Linux (kernel) is not in the picture at the moment. But I can say you will probably want to upgrade your kernel to 5.6.18 to support the latest hardware.

    Now with iPXE our hands are a bit tied. But instead of ipxe.efi, try snponly.efi and then snp.efi The snpxxxx versions use the snp driver built into the network adapter instead of using the iPXE built in drivers.

308
Online

8.2k
Users

15.0k
Topics

141.5k
Posts