new setup in vitual box Node Offline Node is unavailable


  • I can log in the url fine.
    but it tells me my Node Offline
    Node is unavailable

    I reran the install scrip it told me the nod was made.
    I read on other forums this may be a mysl error or something.

    Server information
    Invalid Server Information!

    Thanks

  • Moderator

    @Sebastian-Roth I chatted with the OP last night and got things worked out. There was a number of things wrong with the setup. We got them worked out one by one.

    1. The IP address for the fog server was incorrect in dhcp
    2. In the end FOG wasn’t installed completely on the FOG server. Something happened during the install because the .fogsettings file was missing (not very common so it took us a bit to narrow down).
  • Senior Developer

    @raven-warsong What do you mean by progress? Is the node being shown as offline now solved?

    Yes for PXE booting you need to set next-server and bootfile in your DHCP server (whichever that is) or use a DHCP proxy server. May I ask you to open a new topic on this issue. We try to keep things sorted so other people find help more easily as well. Let us know which kind of DHCP server you use.


  • I just re did the VM and set the ip adress before
    it looks like I need to set the ip adress and the boot file in my router

    so I did make a little progress de5574db293f72093282ca8d1f11fe06190abf49-14.jpg

  • Senior Developer

    @raven-warsong Please read through the whole wiki page and make sure you have all the places in the FOG web UI set to the correct IP.


  • it all looks right to me

    ## Start of FOG Settings
    ## Created by the FOG Installer
    ## Find more information about this file in the FOG Project wiki:
    ##     https://wiki.fogproject.org/wiki/index.php?title=.fogsettings
    ## Version: 1.5.9
    ## Install time: Mon 05 Oct 2020 08:34:48 PM CDT
    ipaddress='192.168.1.16'
    copybackold='0'
    interface='enp0s3'
    submask='255.255.255.0'
    hostname='Fogserver'
    routeraddress='192.168.1.1'
    plainrouter='192.168.1.1'
    dnsaddress='8.8.8.8'
    username='fogproject'
    password='HIu1eccodeAHYiGkv:kg'
    osid='2'
    osname='Debian'
    dodhcp='N'
    bldhcp='0'
    dhcpd=''
    blexports='1'
    installtype='N'
    
  • Senior Developer

    @raven-warsong said in new setup in vitual box Node Offline Node is unavailable:

    Yes from DHCP to a static address.

    I suppose the IP changed as well?!

    Seems like I grabbed the wrong document (resync account). Take a look at this one: https://wiki.fogproject.org/wiki/index.php?title=Change_FOG_Server_IP_Address


  • @Sebastian-Roth said in new setup in vitual box Node Offline Node is unavailable:

    Which version of FOG do you use?
    The latest

    https://fogproject.org/download
    The latest release of FOG Project is 1.5.9, released September 13th 2020.

    The latest can mean different things. The latest official release is 1.5.9 but the latest development version is 1.5.9.28 (as of today).

    What Linux OS and version is installed?
    Im useing VB with Ubuntu 20.04.1 LTS

    Is the Ubuntu firewall enabled or disabled?
    I guess the default would be enabled as I did not change it

    I did rerun the install scrip It confirmed the statis ip address I was running, and It was set up as master storage and not an add on Node.

    Did you change the FOG server IP address at some point??

    Yes from DHCP to a static address.

    Is there a log file of some kind that Fog generates I can post here I looked but did see any thing.

    Installer log files are in the same directory where you ran the installer script from, so fogproject/bin/error_logs/…

    I have included those files thanks so much

    fog_error_1.5.9.log

    foginstall.log

  • Senior Developer

    @raven-warsong said in new setup in vitual box Node Offline Node is unavailable:

    Which version of FOG do you use?
    The latest

    The latest can mean different things. The latest official release is 1.5.9 but the latest development version is 1.5.9.28 (as of today).

    What Linux OS and version is installed?
    Im useing VB with Ubuntu 20.04.1 LTS

    Is the Ubuntu firewall enabled or disabled?

    I did rerun the install scrip It confirmed the statis ip address I was running, and It was set up as master storage and not an add on Node.

    Did you change the FOG server IP address at some point??

    Is there a log file of some kind that Fog generates I can post here I looked but did see any thing.

    Installer log files are in the same directory where you ran the installer script from, so fogproject/bin/error_logs/…


  • Which version of FOG do you use?
    The latest

    What Linux OS and version is installed?
    Im useing VB with Ubuntu 20.04.1 LTS

    Do you have a single FOG node or a master/storage setup? Which one is shown as offline?
    I think I set up a master/storage I dont have other nods for storage.

    change of IP address that has not been altered in all neccesary places I did change the ip address from DCHP to static.

    I did rerun the install scrip It confirmed the statis ip address I was running, and It was set up as master storage and not an add on Node.

    Is there a log file of some kind that Fog generates I can post here I looked but did see any thing.

  • Senior Developer

    @raven-warsong Let’s start with the basics. Which version of FOG do you use? What Linux OS and version is installed? Do you have a single FOG node or a master/storage setup? Which one is shown as offline?

    The FOG web UI dashboard tries to send a HTTP request to the node in question and if that fails it is shown as offline. Now this can have a number of reasons, e.g. firewall enabled on loopback or HTTPS related issue or change of IP address that has not been altered in all neccesary places: https://forums.fogproject.org/topic/11203/resyncing-fog-s-service-account-password

408
Online

8.8k
Users

15.5k
Topics

144.5k
Posts