Client does not want to update from 11.6 to 12.0



  • I recently updated my Fog server from 11.6 to 12.0.

    After the update, the fog client on all Windows machines does not want to update from 11.6 to 12.0.

    This is what the log says:

    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
    01/10/2020 15:57 Client-Info Client Version: 0.11.16
    01/10/2020 15:57 Client-Info Client OS:      Windows
    01/10/2020 15:57 Client-Info Server Version: 1.5.9
    01/10/2020 15:57 Middleware::Response Success
    01/10/2020 15:57 Middleware::Communication Download: http://fog.domain.com/fog/client/SmartInstaller.exe
    01/10/2020 15:57 ClientUpdater ERROR: Unable to parse versions
    01/10/2020 15:57 ClientUpdater ERROR: Value cannot be null.
    Parameter name: authority
    ------------------------------------------------------------------------------
    

    the domain fog.domain.com is obfuscated for security reasons.
    I see the smartinstaller.exe being downloaded in the /tmp folder.

    All our clients are Windows 10, the machine on which I tested has all updates installed.
    Windows Defender is turned on. I also tried it with Windows Defender turned off, but that gives the same result.

    Where can I look for additional clues?

    Thanks,
    Jurgen.


  • Senior Developer

    @Jurgen-Goedbloed I had a look through the code and I am fairly sure this is caused by the old code signing cert has lost validity on the 7th of September 2020. This cert is only used to ensure the binaries are certified by the FOG project team. We updated the code signing cert in January 2020 and released FOG 1.5.8 together with fog-client 0.11.19.

    Unfortunately I kind of lost sight of this “major” change that would affect auto-updating after 7th of September 2020 and never officially announced that people should update earlier for the auto-update to work.

    So from the version number we see in your log file I am sure you updated from FOG 1.5.7 to 1.5.9 - skipping the fog-client update that introduced the new code signing cert. This would have worked perfectly fine while the old code signing cert was still valid but fails now.

    You’ll need to update all your fog-client installations to 0.11.19 (auto-update to 0.12.0 will work from there) or 0.12.0 through some other kind of software deployment mechanism I am afraid.

    For now you should manually edit /var/www/html/fog/lib/fog/system.class.php and set FOG_CLIENT_VERSION back to 0.11.16 or clients will keep downloading the SmartInstaller.exe binary over and over again and put load on your FOG server for no reason. The code is smart enough to handle a situation where you have FOG_CLIENT_VERSION set to 0.11.16 version but the fog-client on some or all of your machines is on 0.12.0 already. So don’t worry about this.


Log in to reply
 

336
Online

7.5k
Users

14.6k
Topics

137.4k
Posts