[SOLVED] Lenovo M75s w/ Ryzen 3000 series

  • Hello,

    I think the issue here may lay more with iPXE than FOG but anyway, here goes. We made the decision to try a few AMD machines in our organization but I’m having issues getting them imaged, they are of course UEFI only, no legacy option at all. When I boot them from the network they are given the correct ipxe.efi file from the DHCP server and boot into iPXE. iPXE however cannot connect get an address from DHCP and gives this error:

    “No configuration methods succeeded (http://ipxe.org/040ee186)”

    My google-fu has failed me on this one, my only thought is perhaps these machines are so new that iPXE doesn’t have drivers or something. From the iPXE shell when I run “ifconf” there is a connection timeout error and “ifstat” shows TXE errors but nothing under RX or RXE which indicates to me the packets are never leaving the NIC.

    Has anyone ran into this before and maybe have a suggestion of something else I can try?


  • @george1421

    For those wondering who came across this thread like me: If you are using the built in DHCP server in ubuntu fog you need to edit the dhcp.conf file by opening a terminal and typing: sudo nano /etc/dhcp/dhcpd.conf and replacing “ipxe.efi” with “snponly.efi”. Worked fine with the M75s after making those changes.

  • @george1421 Understood, we have some older Dells floating around and anything purchased in the last 4+ years has been Lenovo so it sounds like the snp driver will probably work fine.

    Thanks for your help, you saved me from spending a lot of time manually setting up these machines!

  • Moderator

    @andrewhancock91 said in Lenovo M75s w/ Ryzen 3000 series:

    Is there any reason to not leave it set to snponly.efi going forward?

    Well I would say leave it at snponly.efi (which is akin to undionly.kpxe) but we’ve found many uefi nic drivers being broken so snponly.efi doesn’t work well. We find ipxe.efi supports more hardware. If you are using mainstream hardware hp, lenovo, dell the snp driver should work well.

    So my recommendation would be to leave it for now until you run into hardware that won’t pxe boot. If that happens we have some things we can do to add a bit of dynamic support. But lets not go there until you find you really need it.

  • @george1421 yes I was sending ipxe.efi to the target computer. I changed the DHCP server to snponly.efi and rebooted the target which instantly got an address and started the deployment as expected.

    Is there any reason to not leave it set to snponly.efi going forward?

    Not sure that it matters at this point since we’re up and running but we just updated to FOG 1.5.9 this afternoon on the off chance that would solve this problem.

  • Moderator

    I take it you are sending ipxe.efi to the target computer? If yes, then try snponly.efi to see if that works. That driver will use the built in snp driver in the network cards. The ipxe.efi comes with all of the known network cards so it is of course bigger, and could not stay up with current hardware.

    If that doesn’t work (iPXE) then we can get you setup to boot from a usb drive into FOS Linux to image.

    Also what version of FOG??