could not install PciConfig hanler


  • Hello,
    not sure why Im not able to capture this image
    latop is Lenovo T580 your help is much appreciated
    fog error 2.JPG

  • Moderator

    @cicero ok two things.

    The PciConfig handlers is just a spurious warning message. You can safely ignore this warning. If FOS Linux hits a critical warning it will stop booting.

    What is more interesting is what I can’t read in the picture. It looks like /images are being redirected somewhere. What is going on with that link? I think I can make out you have the virtual raid adapter md127 is mounted on /raid/fog/images and then you have a symlink mapping /images to that sub directory. NFS doesn’t follow symlinks.

    There is a few ways to fix this, but I would have to ask why the logic of /raid/fog/images? A quick way to fix is to mount /dev/md127 over /images (directly) and then rerun the fog installer to fix the reset of the bits.


  • I also notice when I try to do a full host registration it cant install PciConfig handlerfog 4.JPG


  • Here is what Im getting
    fog 3.JPG

  • Senior Developer

    @cicero Please run the commands as requested by George! The error looks much like an issue in the file structure on your server and we need to see what it looks like to be able to help you.

    I have not made any changes it works with older lenovo laptops up to T480

    What do you mean by that? Deploying to those machines does work or can you also capture with those older devices? I can’t believe this issue is related to the hardware you capture from!

  • Moderator

    @cicero said in could not install PciConfig hanler:

    Yes its standard fog server v8913/SVN6054

    This might indicate an old version because svn numbers are not used any more. Is there a number like 1.3 1.4.4 or similar? If you have an old version of FOG its possible that it doesn’t support this hardware or nvme drives.

    We will need to know the version of FOG AND the version of the FOS Linux kernel (Fog Settings->Kernel). Note, no where in the FOG Web GUI does it mention FOS Linux only “kernel”. This is not related to the host OS of the FOG server either.


  • Yes its standard fog server v8913/SVN6054
    images are local with lots of room
    Im trying to capture new windows10/1903 image to upload to fog server
    I have not made any changes it works with older lenovo laptops up to T480
    I’m new to the Linux environment

  • Moderator

    Is this just a standard FOG server? No storage nodes involved?

    Your /images directory is local to the FOG server?

    Do you have sufficient space on your FOG server’s images directory df -h

    Did you make changes to the /images/dev directory ls -la /images and ls -la /images/dev

334
Online

8.1k
Users

15.0k
Topics

141.3k
Posts