Storage node error when adding to management UI



  • Hello
    We recently setup a new fog master node and storage node. when I add the storage node to the management I get the following error

    We can connect to the fog database from the storage node to the master node using the fogstorage user and password found in the /opt/fog/.fogsettings.

    Both nodes are running 1.5.9-RC2 which is what the default fogproject.git pulled down. They are running Centos 8.

    fc1c29df-362f-41f2-83f4-3e13354a2bea-image.png


  • Senior Developer

    @mwolfe60 @wambat10 Thanks for the quick response! I just pushed a fix to the dev-branch. So we have that right in the final release as well.



  • @Sebastian-Roth

    That fixed it thanks!


  • Senior Developer

    @mwolfe60 said in Storage node error when adding to management UI:

    also can i ask why we are pulling down 1.5.9-RC2 instead of 1.5.8? It seems odd that the git command is pulling a release candidate instead of the latest stable.

    We were hoping to bring out the new release (1.5.9) quickly after the release candidates and to have a few more people test the RC version to get some feedback we decided to push out RC in the git master branch - as it’s more stable and has less issues than 1.5.8 by the way. Then an unexpected wall of work hit and we didn’t get to do as we had planned. But we are back on course and will release 1.5.9 in a few days.

    Ok, now I think I got what’s going on. You installed the master node with HTTPS enabled but not the storage node?! Good we pushed out the RC version on git master because there is a minor bug in the installer: We added the question on enabling HTTS/SSL for master node setups but not for storage nodes. So you still need to manually add the command line parameter to have a HTTPS enabled storage node setup. Please re-run the installer on your storage node like this: ./installfog.sh --force-https



  • @Sebastian-Roth so when we go to the http://10.1.26.88/fog/management/ we get this response
    7c97aac1-9acf-4a3b-8208-b30c3d6e340a-image.png

    but https://10.1.26.88/fog/management/ we get:

    5cfe34ba-6bb0-4b5d-9634-7c915abaaca6-image.png

    do i have a setting wrong in the master node?



  • @Sebastian-Roth so I ran the tail -f on the access.log and i saw 1 request come in but none after that.

    21f1a989-5e82-4499-b298-e2b9b2169fbc-image.png

    I have Verified the IP address and DNS it is all correct. I use the IP address to ssh into the storage node.

    Would re-running the fog setup in the storage node or the master node help here. also can i ask why we are pulling down 1.5.9-RC2 instead of 1.5.8? It seems odd that the git command is pulling a release candidate instead of the latest stable.


  • Senior Developer

    @wambat10 Thanks for the update. That really sounds as if it’s not a network issue as I assumed.

    The weird thing from my point of view is that I have never seen those messages before “The server is temporarily unable to service your request due to …” is not part of the FOG code but a typical HTTP 503 “Service (Temporarily) Unavailable” error generated by the web server.

    To make sure you get this answer from the storage node I may ask you to double check the IP you have set for this storage node in the FOG web UI plus run tail -f /var/log/httpd/access_log (assuming you use CentOS) on the storage node console while you open the FOG settings page. You should see the request come in. If you don’t see it in the access log I am somewhat sure the request is going to a different system. Possibly your DNS setup is pointing to different IPs in the network segments you have.



  • @Sebastian-Roth

    1.5.9-RC2
    bzImage Version: 4.19.123
    bzImage32 Version: 4.19.123

    is the result. the storage node is located at a different site than the master node. with a private connection between the sites. the funny thing is we rebuilt our server after we had a problem with our previous fog server. prior to its problem on the old server the node’s graph and kernel version was listed in the web ui. nothing in the network has been changed. there is no proxy server in the network


  • Senior Developer

    @wambat10 Try this command as well: curl http://x.x.x.x/fog/status/kernelvers.php

    My guess is this is working just fine as well. So I can only imagine you have some kind of proxy server in your network that is interfering here.



  • @Sebastian-Roth

    This is what I’m seeing

    a88351a4-4dda-4d6b-87c7-456a0f097f5b-image.png

    and this

    d060cac1-96d2-4375-b8a7-0680cefc1861-image.png


  • Senior Developer

    @wambat10 said in Storage node error when adding to management UI:

    It’s just not showing in the web UI.

    What do you mean by “not showing”?? Please provide a screenshot.



  • @Sebastian-Roth this is the response for the storage node.

    @@general
    4.18.0-193.14.2.el8_2.x86_64
    GTIGFogServer.gtioh.com
    Up: 5 days 0 hrs 22 mins Load: 0.00, 0.00, 0.00
    GenuineIntel
    4
    Intel® Xeon® CPU E5-2670 v3 @ 2.30GHz
    2297.339
    30720 KB
    7.63 GiB
    0.43 GiB
    0.23 GiB
    @@fs
    703.79 GiB
    303.69 GiB
    400.11 GiB
    @@nic
    lo$$14448$$14448$$0$$0
    ens192$$212545560632$$5067789639$$0$$2945
    @@end

    the storage node is working as we can capture and deploy from it. It’s just not showing in the web UI.


  • Senior Developer

    @wambat10 The master node needs to send a HTTP request to the storage node to get that information. Try running curl http://x.x.x.x/fog/status/hw.php from your master node and put in the correct IP address of your storage node instead of x.x.x.x to see if this is working in your network setup.


Log in to reply
 

307
Online

7.4k
Users

14.5k
Topics

136.7k
Posts