FOGSnapinReplicator.service failing on fresh install



  • I’ve tried a number of fresh installations of 1.5.8 on a dual-homed server (with the second NIC connected to an isolated network to be used for imaging). On completion of the installation, syslog immediately starts filling with the following block of messages - about one per second:

    Aug  7 09:05:00 node2 systemd[1]: Started FOGSnapinReplicator.
    Aug  7 09:05:00 node2 php[9501]: Could not open input file: env
    Aug  7 09:05:00 node2 systemd[1]: FOGSnapinReplicator.service: Main process exited, code=exited, status=1/FAILURE
    Aug  7 09:05:00 node2 systemd[1]: FOGSnapinReplicator.service: Failed with result 'exit-code'.
    Aug  7 09:05:01 node2 systemd[1]: FOGSnapinReplicator.service: Service hold-off time over, scheduling restart.
    Aug  7 09:05:01 node2 systemd[1]: FOGSnapinReplicator.service: Scheduled restart job, restart counter is at 1.
    Aug  7 09:05:01 node2 systemd[1]: Stopped FOGSnapinReplicator.
    
    

    I’m installing on a fresh installation of Ubuntu Server 18.04, fully patched using the following process:

    sudo -i
    wget https://github.com/FOGProject/fogproject/archive/1.5.8.tar.gz
    tar -xzvf 1.5.8.tar.gz
    cd fogproject-1.5.8/bin
    ./installfog.sh
    

    .fogsettings:

    ## Start of FOG Settings
    ## Created by the FOG Installer
    ## Find more information about this file in the FOG Project wiki:
    ##     https://wiki.fogproject.org/wiki/index.php?title=.fogsettings
    ## Version: 1.5.8
    ## Install time: Fri 07 Aug 2020 09:05:30 AM UTC
    ipaddress='192.168.170.1'
    copybackold='0'
    interface='enp2s0'
    submask='255.255.255.0'
    hostname='node2'
    routeraddress=''
    plainrouter=''
    dnsaddress='192.168.170.1'
    username='fogproject'
    password='****'
    osid='2'
    osname='Debian'
    dodhcp='y'
    bldhcp='1'
    dhcpd='isc-dhcp-server'
    blexports='1'
    installtype='N'
    snmysqluser='fogmaster'
    snmysqlpass='****'
    snmysqlhost='localhost'
    mysqldbname='fog'
    installlang='0'
    storageLocation='/images'
    fogupdateloaded=1
    docroot='/var/www/'
    webroot='/fog/'
    caCreated='yes'
    httpproto='http'
    startrange='192.168.170.10'
    endrange='192.168.170.254'
    bootfilename='undionly.kpxe'
    packages='apache2 bc build-essential cpp curl g++ gawk gcc genisoimage git gzip htmldoc isc-dhcp-server isolinux lftp libapache2-mod-php7.2 libc6 libcurl4 liblzma-dev m4 mariadb-client mariadb-server net-tools nfs-kernel-server openssh-server php7.2 php7.2-bcmath php7.2-cli php7.2-curl php7.2-fpm php7.2-gd php7.2-json php7.2-ldap php7.2-mbstring php7.2-mysql php-gettext tar tftpd-hpa tftp-hpa unzip vsftpd wget xinetd zlib1g '
    noTftpBuild=''
    sslpath='/opt/fog/snapins/ssl/'
    backupPath='/home/'
    armsupport='0'
    php_ver='7.2'
    php_verAdds='-7.2'
    sslprivkey='/opt/fog/snapins/ssl//.srvprivate.key'
    ## End of FOG Settings
    

    enp2s0 is the built-in NIC and is on the isolated network with a static IP (192.168.170.1/24). This build has a second USB NIC connected to the main network (10.0.0.0/24), which has Internet access.


  • Senior Developer

    @3mu said in FOGSnapinReplicator.service failing on fresh install:

    php[9501]: Could not open input file: env

    I totally missed this part in the log when looking through this some time ago. Have been way too busy with other things at that time and obviously missed this. This issue has been fixed a while ago and I cannot imagine this to be the case in the release candidate versions or dev-branch anymore. I just did a test install using dev-branch on Ubuntu 18.04 and I don’t see the messages as stated above.

    From my point of view this has nothing to do with specifying a router or not!


  • Senior Developer

    @3mu Thanks for the update. I will take a look at this when I have more time.



  • @Sebastian-Roth - It is the FOG installer option that I am referring to. The only customisation of the Ubuntu 18.04 server that I am installing on is setting a static IP address on the FOG interface during installation. I’ve had the same result on 1.5.8 (installed by downloading the tar) and 1.5.9-RC2 (using Git).


  • Senior Developer

    @3mu said in FOGSnapinReplicator.service failing on fresh install:

    Install FOG with no router, DNS server = the FOG server IP (with no DNS server running)

    Thanks for the details. Though I still need to clarify this point. Maybe I am able to figure out the root cause of this and even prevent from it in our setup.

    So when you say DNS server, do you mean the FOG installer option/question that is asking for DNS server or just standard Linux DNS server setup though /etc/resolv.conf?



  • I really don’t know why this breaks it, sorry @Sebastian-Roth - I had run out of ideas and starting changing one setting at a time. It is easy to replicate, though:

    • Fresh Ubuntu server 18.04 install

    • Patch it

    • Install FOG with no router, DNS server = the FOG server IP (with no DNS server running)

    The log events start immediately on completion of the FOG installation, and don’t stop when I disable SNAPINREPLICATORGLOBALENABLED.

    To avoid the issue, I reinstalled from scratch with no router or DNS server, then installed BIND9 and edited the DHCP config to add it. I haven’t tried installing BIND before the FOG installation.


  • Senior Developer

    @3mu Thanks for letting us know you solved this and DNS server was the issue. Can you please be more specific on how this conflicted and why?

    Really sounds like other people could have run into this as well and would embrace your helpful information on this.



  • I had specified the DNS server to be the FOG server, as I had intended to install DNS on the FOG server as the next step. It appears that this was causing the issue. Installing with no DNS server does not produce the error messages. Given the amount of time that I’ve spent trying to work this out, I thought that it was still worth posting.


Log in to reply
 

363
Online

7.4k
Users

14.5k
Topics

136.6k
Posts