• Hi All,

    Long time user, first time poster!

    I’ve recently added a new FOG server into one of our sites, I’m using Ubuntu 16:04LTS and FOG 1.5.8 - have tested installation on both physical box and VMWare environment.

    I have done a clean install and integrated into the sites existing DHCP setup using options 66/67 with the appropriate settings, its a flat network and firewall etc appear to be configured correctly.

    After the install I attempt to PXE boot machines which have been fogged on one of my legacy standalone/offline setups (Ubuntu 16:04 LTS FOG 1.4.X with FOG handling DHCP) and this fail with TFTP, If I connect these to legacy fog server they boot fine.

    If I try and TFTP from another win/lin or osx machine to fog, I get either error cannot connect or no file found.

    I’ve worked through this and done a fair bit of googling as well as double checking DHCP etc.

    If I browse to /var/lib/tftpboot on the new fog instance the folder is empty?

    Any pointers or advice much appreciated 🙂

  • @george1421

    Great thankyou, will do as you’ve suggested and report back!

  • Moderator

    @shaynes Ok if you have a flat network lets go get a pcap (packet capture) of the pxe booting process. If the FOG server and the pxe booting computer are on the same subnet then you can use the FOG server to collect this pcap. https://forums.fogproject.org/topic/9673/when-dhcp-pxe-booting-process-goes-bad-and-you-have-no-clue

    This pcap will tell us who the actors are in this pxe booting process. Upload it to the fog forum or upload the pcap to a file share site (like google drive) and either post the link here or IM me the link via forum chat.

    Now the files the tftp server uses on the fog server should be /tftpboot. You should be able to request these files from another linux server or OSX server with get <fogserverip> -c get ipxe.efi That should transfer the file to the local computer.

  • @george1421


    DHCP is set to

    66 - ip of fog server
    67 - undionly.kpxe (ive tried ipxe etc etc too)

    Ive tried legacy mode and UEFI boot but no joy - to confirm old standalone fog server works fine 🙂

  • This post is deleted!
  • Moderator

    well I’m a bit confused where to start debugging here, but lets start with DHCP.

    On your main dhcp server what exactly do you have configured for dhcp options 66 and 67?

    The target computer you are attempting to PXE boot, is it a bios based or uefi based computer?