• Hi,
    I’m using a fogserver in some schools for more than 3 years. Works perfectly sometimes a few hiccups but always been able to solve this. At the moment I encounter a strange problem with some computers. They are all the same (BIOS, Motherboard,…) but some can connect to FOG (BOOT) others not I receive an error “PXE-E78 Cannot locate boot server”.
    I notice that the computer connects to the FOG server and it is showing the message “Booting FOG Client via DNSMASQ-1” (from the DNAMSQ.D file). Content:

    port=0
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    #dhcp-option=66,"192.168.0.23"
    #dhcp-option=150,"192.168.0.23"
    #dhcp-option=128,"192.168.0.23"
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,192.168.0.23,192.168.0.23
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    # inspect the vendor class string and match the text to set the tag
    dhcp-vendorclass=BIOS,PXEClient:Arch:00000
    dhcp-vendorclass=UEFI32,PXEClient:Arch:00006
    dhcp-vendorclass=UEFI,PXEClient:Arch:00007
    dhcp-vendorclass=UEFI64,PXEClient:Arch:00009
    
    # Set the boot file name based on the matching tag from the vendor class (above)
    dhcp-boot=net:UEFI32,i386-efi/ipxe.efi,,192.168.0.23
    dhcp-boot=net:UEFI,ipxe.efi,,192.168.0.23
    dhcp-boot=net:UEFI64,ipxe.efi,,192.168.0.23
    
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client via DNSMASQ-1", 10
    
    
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe, 192.168.0.23
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi, 192.168.0.23
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi, 192.168.0.23
    
    dhcp-range=192.168.0.23,proxy
    
    
    

    We are using a Windows DHCP with no options configured and the DNSMASQ on the fog 192.168.0.23. One subnet same computers with same motherboard and network card Realtek 8111F, 1 x Gigabit LAN Controller(s) with Realtek PCIe GBE Family Controller Series v2.46 (03/23/12).
    What I don’t really understand is why does it work for the same model of computer with the same BIOS settings etc and for some not…

    Thank you!


  • @Sebastian-Roth Thank you for your feedback! I found the solution the dnsmasq file had just the ip of the server in dhcp-range without the subnet. So I adjusted the line dhcp-range=192.168.0.23,proxy to dhcp-range=192.168.0.23,proxy,255.255.254

    Thanks for the feedback, sorry for my late response.

  • Senior Developer

    @Jeffson said in PXE-E78 some computers:

    What I don’t really understand is why does it work for the same model of computer with the same BIOS settings etc and for some not…

    Do those that work, reliably PXE boot every time? If you answer this with yes I am sure there must be a difference between those that work and those that don’t! Or it’s some specialty within your network setup (different subnets, VLANs or firewall settings).

    • Double check the BIOS settings! Are they all in legacy BIOS mode or UEFI?
    • Tell us more about your network architecture. Are the hosts all connected to the very same switch, same subnet??

389
Online

7.6k
Users

14.7k
Topics

138.3k
Posts