Kernel is missing the correct driver



  • Hello again,
    i have a Problem with some Lenovo Thinkpad T14s that we are forced to image with the included Dockingstations because these Notebooks dont have an own Networkport.

    The Notebook tries to boot into FOG but Fails at the Networkinterface as in the image i will link below:
    https://imgur.com/gUmlUK0

    DHCP: Win Server 2012R2
    Bootfile: ipxe.efi
    FOG: CentOS 7.2

    It boots with an USB to Ethernet Adpater without Problems but with that Dockingstation it doesn’t want to do it.

    Tanks in Advanced for Help!



  • @george1421 So now it finaly Works ! I am so Thankfull 🙂
    I am now running some Deploys and Captures as a Test but so far it has the 5.6.18 Kernel and gets no Nic errors.

    Just as an fyi the -o in your Command should be a Captial -O otherwise it creats just a .txt file and runs in an Format error at pxe boot.

    But Again Thank you for the Support 🙂


  • Moderator

    @Nick Ok something is going wrong because that uname command is still saying 4.19.123 so the kernel is not updating for some reason. 4.19.123 is not new enough to support the newest hardware. The linux kernel developers are no longer back porting new hardware drivers to the 4.19.x series of linux kernels so you NEED to have 5.5.x or later.

    Lets go the manual route download these kernels by hand.

    Run these commands on your FOG server

    cd /var/www/html/fog/service/ipxe
    mv bzImage bzImage.sav
    mv bzImage32 bzImage32.sav
    
    wget https://fogproject.org/kernels/Kernel.TomElliott.5.6.18.64 -o bzImage
    wget https://fogproject.org/kernels/Kernel.TomElliott.5.6.18.32 -o bzImage32
    

    Now pxe boot again and see if it sees the nic. If not again run the debug mode and uname -a



  • @george1421 We Updatet PHP to Version 7.3 and FOG to the Version 1.5.8 and the Kernel again to the newes Version.
    It went all well and we have the same Problem. The Outut from that Command is:
    Linux fogclient.localdomain 4.19.123 #1 SMP Sun May 17 01:04:09 CDT 2020 x86_64 GNU/Linux


  • Moderator

    @Nick said in Kernel is missing the correct driver:

    Also is it possible to update the FOG with PHP 5 or do you need for the new Update PHP 7

    I personally can’t answer that question.

    As for the nics

    8086:02f0 Intel wireless (wireless is not in FOS Linux)

    8086:0d4f “Ethernet Connection (10) I219-V” first available in linux kernel 5.5

    It should work with the current 5.6.8 linux kernel. What is the output of the uname -a command?



  • @Nick Also is it possible to update the FOG with PHP 5 or do you need for the new Update PHP 7?



  • @george1421 So i did an Upsie and with Legacy i can get into the Command Prompt. I still get the error for the nic but at least i can eecute the commands:
    https://imgur.com/pwwxfyV
    I belive i should still do the thinks you suggestet?


  • Moderator

    @Nick Well I think the right answer here is to update to the latest release 1.5.9RC2, but before you do that lets “patch” 1.5.5 FOS linux environment with the inits from 1.5.8. Its possible that the latest kernel is too new for 1.5.5 version of the inits. So on the FOG server

    cd /var/www/html/fog/service/ipxe
    mv init.xz init.xz.1.5.5
    wget https://fogproject.org/inits/init.xz .
    

    So this will rename the existing init.xz (FOS Linux virtual hard drive) and download 1.5.8’s version. See if that version of the virtual hard drive is happier with the latest kernel. If that doesn’t work then go ahead and update using the dev branch to 1.5.9RC2. You will need to redownload the 5.6.8 kernel after you update.



  • @george1421 said in Kernel is missing the correct driver:

    Where does “nothing happens” begin? Do you get the iPXE menu in uefi mode? Does it even try to pxe boot? Is it after FOS Linux begin (like after where the kernel panic would stop it)?

    We can boot in the FOG Menue over iPXE we hit deploy and the black nothing happens, after we restart and boot again over IPXE we get this Screen:
    https://imgur.com/jxhPBTu

    You install version 5.6.x of the FOS Linux kernel? If so then we need to debug this a bit more. Manually register this compute if it has not been so far. Then schedule a capture/deployment (doesn’t matter) but before you hit the Schedule task button, tick the debug checkbox. Now pxe boot the target computer, after a few screens of text that you need to clear with the enter key, you should be dropped to the FOS linux command prompt. Key in the following at the FOS Linux command prompt.

    uname -a
    lspci -nn |grep -i net

    Post the results here.

    I also have to ask about the network adapter in this device is it usb attached or is it built in? What hardware are you trying to pxe boot (manufacturer and model)?

    We updatet these Kernels:
    FOG Kernel Updates.png

    Also if i try to deploy an image to the Lenovo T14 Notebook with an internal Nic (Intel Gigabit)it stops like the other above, it wont get over the init.xz even if i start with the debug mode checkt. Somehow it was starting so we got the error but now it doesn’t wants to.


  • Moderator

    @Nick said in Kernel is missing the correct driver:

    UEFI Deploy a Black Screen and nothing happens

    Where does “nothing happens” begin? Do you get the iPXE menu in uefi mode? Does it even try to pxe boot? Is it after FOS Linux begin (like after where the kernel panic would stop it)?

    we boot over Legacy we can Deplay and still get an error for missing driver for the Nic

    You install version 5.6.x of the FOS Linux kernel? If so then we need to debug this a bit more. Manually register this compute if it has not been so far. Then schedule a capture/deployment (doesn’t matter) but before you hit the Schedule task button, tick the debug checkbox. Now pxe boot the target computer, after a few screens of text that you need to clear with the enter key, you should be dropped to the FOS linux command prompt. Key in the following at the FOS Linux command prompt.

    uname -a
    lspci -nn |grep -i net

    Post the results here.

    I also have to ask about the network adapter in this device is it usb attached or is it built in? What hardware are you trying to pxe boot (manufacturer and model)?



  • @george1421 So thanks for the Response.

    It solved the Probelm with the Kernel Panic but we still get at UEFI Deploy a Black Screen and nothing happens. Schould we Upgrade to a newer Version of FOG maybe we are currently running versio 1.5.5. Also if we boot over Legacy we can Deplay and still get an error for missing driver for the Nic.


  • Moderator

    @Nick I guess I should have ask what version of FOG are you running? It sounds like you are running (from the error) that you have an older version of FOG. Under FOG Configuration->FOG Settings->(Expand All). Somewhere in that list there is a value similar to “ram disk size” (sorry I can’t remember the exact name this early in the AM here). The older versions of FOG had 127000 as a value. Change that value to 275000 and that will correct the error you see.



  • @Nick So we Updatet the Kernel to the newest Verion (without ARM because we dont use ARM) and we have now the Problem that nothin Works.

    If you want to Deploy an Image you get a Black Screen and nothing happens, the Task is in FOG but at the CLient nothing happens.
    Also if i want to Capture an Image i get an Kernel Panic (Link to the Screenshot i tokk with an VM Kernel_Panic_FOG.png )

    Any Ideas shoud we also Update the FOG to the newest Version?

    Thanks for help!



  • @george1421 Thanks for the Quick response.

    I will Update the Kernel and we will see i think i will be able to do it tomorrow, so i will report when i have donw it.

    But again thanks for the quick Response 🙂


  • Moderator

    OK now this issue is beyond the ipxe menu so this is FOS Linux that doesn’t have the driver for the adapter. The first and easilest fix is to go to Web UI -> FOG Configuration -> Kernel and install the 64 and 32 bit kernel 5.6.8 or later.


Log in to reply
 

322
Online

7.2k
Users

14.4k
Topics

135.6k
Posts