Best practice regarding AD accounts and FOG imaging



  • Good morning, I’d like to know what the preferred best practice is regarding new and pre-existing AD computer accounts when using FOG. Should pre-existing accounts (devices being reimaged) be deleted, deleted and recreated, reset, or just left alone to be overwritten? Same question applies to new computer accounts - should we create computer accounts prior to imaging or should we leave FOG to do that? I’m asking this because we continue to have problems with FOG naming PC’s and joining them to the domain - works only about 50% of the time and I’m trying to eliminate this as a potential cause. Thanks in advance!



  • @JYost are you registering all of the hosts? How are you setting the preferred names? The way I did it was I set names as I registered, and then did an image deploy right there during registration from FOG’s boot menu, typically. I don’t know how much experience you have with FOG but Tom is right, naming and domain joining should work 100% of the time. If it’s not, something isn’t right and we need those logs to help.



  • @Tom-Elliott
    Correct…I understand the image should not be joined to the domain, and its not…I’m referring to devices which I’m either imaging for the first time or re-imaging. I will attach the fog.logs for devices which failed and which succeeded in being renamed and joined to the domain. Sometimes it renames them fine but doesn’t join it to the domain. Other times it doesn’t do either, or does both fine. It’s been hit or miss.


  • Senior Developer

    The image should not be joined to the domain.

    Other than that, if you want to create the objects and put them in their respective OUs have at it.

    Renaming a PC and joining the domain should work without issue. If you have a machine that fails to do this after imaging, can you get the machines client log so we can try and troubleshoot it with you? This isn’t normal.


Log in to reply
 

356
Online

7.4k
Users

14.5k
Topics

136.6k
Posts