Failed to start php-fpm.service



  • Hi All, not sure if this is a FOG problem or Linux problem so forgive me if I’m posting in the wrong category. Since last week I’ve been trying to get FOG going on a Linux Mint VM on my laptop and never had so many issues getting the installer to work. Tried the latest stable version and that bombed at the end. Did a lot of searching in your forums and found a thread saying to install the latest development version for issues with php7 on Ubuntu. I did that but keep getting:

    Failed to start php-fpm.service: Unit php-fpm.service not found.

    …at the end and in the fog_error_1.5.9-RC2.10.log You guys are probably super tired of problems running on Ubuntu-based distros like Mint and I’m open to switching if that’s what it takes to get FOG working. It’s just that Mint is the distro I’m most familiar with.

    I guess it’s not as simple as a tweak to the install script to have it refer to php-fpm as php7.4-fpm because that’s what’s showing in /etc/init.d and is what’s currently needed to start/stop the associated service.

    Any help would be appreciated.

    Thanks,

    -LOF



  • @Wayne-Workman Thanks Wayne, that’s good to know! LM is my favorite distro and what I’m most familiar with. They do have a version based on Debian called ‘LMDE’ https://www.linuxmint.com/download_lmde.php Being a long-time FOG user/fan it seems maybe a distro designed more for a server than a desktop role would be better. Up until now I’ve never had any issues at all running FOG on Linux Mint but I’m not averse to switching to something else that works better and is more stable. One of the things I’ve learned since becoming involved with Open Source projects way back in 1997 is “The right tool for the job.” 🙂



  • I know @george1421 loves CentOS, but Debian is also very stable for fog too 🙂



  • @george1421 Ok great and VERY helpful! Thanks! 🙂


  • Moderator

    @LOF said in Failed to start php-fpm.service:

    What’s the recommended/most-tested distro for running FOG? Is that still CentOS?

    Most of the common distros are tested every night against the current release of FOG. That testing system is managed by @Wayne-Workman
    Daily Clean Installation Results: http://fogtesting.theworkmans.us/

    The most stable OS to date is Centos 7 and 8 (caveat I just saw that centos 8 has an issue today). Now understand that may change tomorrow, but for today Centos.



  • @Sebastian-Roth Great, thanks for helping to get this working on Linux Mint! One last question: What’s the recommended/most-tested distro for running FOG? Is that still CentOS?


  • Senior Developer

    @LOF Staying on dev-branch is currently not very “dangerous” at the moment because we don’t have the time to push out much changes. So it’s save to stay there for now. I recommend you to update to 1.5.9 when it’s finally out.



  • @Sebastian-Roth Good news! I did a git-pull this morning from dev-branch, ran the installer and it worked! I’ve created an image and will test capture/deploy but I expect it will work fine. Question: Any risk staying on the dev version or should I plan on switching to the next stable version when it’s GA?



  • @Sebastian-Roth Thanks for pointing that out, I didn’t do a git pull initially, just downloaded the .tar.gz I’ll grab that version and see how the install goes. I’ll let you know.


  • Senior Developer

    @LOF Seems like your git pull has not gone to the latest version, which is 1.5.9-RC2.11



  • @Sebastian-Roth Hi Sebastian, thanks for the response and sorry for the delay. The version showing in the current installer script I have is: Version: 1.5.9-RC2.10 As for /opt/fog/.fogsettings I’ve confirmed again it isn’t there and the /opt directory is empty.

    I ran the installer again to get the version number and it failed:

    fog/fogproject-dev-branch/bin/error_logs/fog_error_1.5.9-RC2.10.log !!
    !!!

    ii wget 1.20.3-1ubuntu1 amd64 retrieves files from the web
    ii xinetd 1:2.3.15.3-1 amd64 replacement for inetd with many enhancements
    ii zlib1g:amd64 1:1.2.11.dfsg-2ubuntu1 amd64 compression library - runtime
    New password: Retype new password: passwd: password updated successfully
    Failed to stop php-fpm.service: Unit php-fpm.service not loaded.

    Thanks and let me know if I should download/try a different version.


  • Senior Developer

    @LOF said in Failed to start php-fpm.service:

    Also, I’ve already pulled down the dev-branch and got the error before my initial post

    Which version number is shown by the installer script? Just want to make sure we are on the right track here.

    As well make sure this is still in a kind of fresh state and /opt/fog/.fogettings is not created yet. Because if it is then things will behave differently in this particular situation.

    Should I delete the previous dev-branch install and download/run it again?

    No need to delete. You can re-run the FOG installer as often as you like if it is the same or a later version of what you have installed/run before. Should not cause any trouble.



  • @Sebastian-Roth Thanks Sebastian, I already know the answer and it’s Yes. Also, I’ve already pulled down the dev-branch and got the error before my initial post. So what’s next? Should I delete the previous dev-branch install and download/run it again?


  • Senior Developer

    @LOF Thanks for offering to help. Let’s give it a try. Though turnaround times might be very long to get to the final conclusion.

    First I would ask you to start the FOG installer as usual. One of the first questions is your Linux OS, which is usually being detected properly. Should be 2) Debian Based Linux (Debian, Ubuntu, Kubuntu, Edubuntu) in your case. Is this the case?

    Looking through the script code I might have figured out what was causing this. So if you answer yes the the first question you might wanna try the latest from dev-branch.



  • @george1421 / @Sebastian-Roth Sorry for the delayed response, it’s been a busy work-week. Since I have a fresh install of LM 20 I’d be happy to pitch in to help determine the cause of the issue if you can send me some instructions. This isn’t an urgent issue for me but I’m definitely willing to help out if I can. I also have a presence over at https://forums.linuxmint.com/ so I can request help there if needed. My ability might be delayed a bit during the work week but I’d have more time during weekends. I appreciate all the time/effort you both put into making FOG such a great imaging solution! 🙂


  • Moderator

    @Sebastian-Roth If we look at what @LOF has posted could this be the issue?

    From the install fail error:

    Failed to stop php-fpm.service: Unit php-fpm.service not loaded

    and from the systemctl list services.

    php7.4-fpm.service loaded active running The PHP 7.4 FastCGI Process Manager

    So could there be a discrepancy between what the FOG installer is trying to stop/start php-fpm.service and the LM installed service of php7.4-fpm.service ??


  • Senior Developer

    @LOF I’d need to do a MINT install myself to see why exactly it fails. From what we have in the scripts I would say it shouldn’t.



  • @Sebastian-Roth It’s a fresh install, /opt/fog/ hasn’t been created yet.


  • Senior Developer

    @LOF Is this a fresh install or do you have a settings file in /opt/fog/.fogettings already?



  • Sebastian/George, thanks for your responses. Let me know if you also need to see all or part of the fog_error_1.5.9-RC2.10.log file. I didn’t include it initially because the only error seemed to be at the bottom, i.e., Failed to stop php-fpm.service: Unit php-fpm.service not loaded. Then again, perhaps I missed something?


Log in to reply
 

207
Online

7.2k
Users

14.4k
Topics

135.6k
Posts