Not able to capture Image



  • I have Fog running as a VM on a Dell server. It has 20G of ram, 3.5T of storage. I have a client machine setup and ready for the image capture. Changed the boot process to PXE on the host machine. I’ve added the MAC address under ‘Host Management.’ I’ve created the image under ‘Image Management.’ Yet, when I reboot the host, it fails to capture the image for whatever reason. This has been plaguing me since last week. I did find an article on SpiceWorks that states I need to install the Fog service on the host machine. That article was written several years ago back in 2014, so I was unsure of the accuracy of that article today. Our DHCP is handled through a SonicWall, that’s what I’m afraid is our issue, at least having the appropriate settings configured correctly anyway. Has anyone successfully implemented Fog with a SonicWall handling the DHCP?


  • Moderator

    @Chad said in Not able to capture Image:

    My biggest pain point was letting my Check Point firewall handle DHCP. All options were set properly, however the TFTP file name was never passed to the host, so it got an IP, but didn’t know what to do next.

    This is what I’m thinking about the sonicwall, or its not configured correctly for dhcp options 66 and 67. Also what we find in most firewalls is that they only support static dhcp options. So with static dhcp options you have to pick either bios or uefi support.

    I solved this by creating a separate subnet and then letting FOG handle DHCP on that network.

    This is not necessary if you install dnsmasq on your FOG server. DNSMASQ only supplies pxe boot info overriding anything the dhcp server tells the client. We find most soho routers will always send the lan interface as the boot server instead of the FOG server. DNSMASQ will fix this broken behavior.

    If the OP has the sonicwall configured correctly and the target computer still isn’t pxe booting we have a tutorial on configuring the FOG server to capture the pxe booting process so we can see what is going wrong.

    Sonicwall help shows how to configure the sonicwall for pxe booting: http://help.sonicwall.com/help/sw/eng/published/1334883822_5.8.1/PANEL_dhcpStatProps.html Relevant steps are 18 == ipxe.efi and 19 == fog server IP (I know it says dns name, use the ip address here). Note you may also need to configure the generic options in step 20 for dhcp options 66 and 67. Some dhcp implementation steps 18 and 19 are configuration for bootp and step 20 is for dhcp booting. They are two different protocols.



  • This seems like network issues between your host and your server. Try looking at some articles for SonicWalls, also, try getting a Wireshark pcap of your network.

    My biggest pain point was letting my Check Point firewall handle DHCP. All options were set properly, however the TFTP file name was never passed to the host, so it got an IP, but didn’t know what to do next. I solved this by creating a separate subnet and then letting FOG handle DHCP on that network.

    EDIT: Not saying anyone here would willingly gid through your pcap. Take a look at this first video I found on this, could be of some help.



  • @Chad Ah… Thanks Chad. I was looking for an autocomplete field to populate as in my prior uses with this search bar.



  • @george1421 It’s a Lenovo M720s, UEFI based



  • @Vrogers Press enter. I’m showing posts from 2016 once you scroll down…
    d34d745d-962e-4253-9680-2d2a3e5cce70-image.png



  • @Sebastian-Roth I don’t know what I’m doing differently then.

    Screenshot (117).png


  • Moderator

    @Vrogers OK so you are having issues pxe booting. From your description it tries ipv4, ipv6 and then just boots into windows.

    So the first important bit of info is what type of computer is this? Is it uefi based or bios based? The reason why I ask is because each type takes its own pxe boot loader.

    I’m going to guess that the computer is uefi because it tries ipv4 then ipv6, but you need to confirm. Once you know what the computer is you need to go into your dhcp server, in your case the firewall. For DHCP you can send custom values to the target computer those custom values will be how to find your FOG server and what file to load initially (boot loader). These values are passed through dhcp options 66 which needs to be set to the IP address of the FOG server. DHCP option 67 which is the name of the boot file. For bios based computers this value should be undionly.kpxe for uefi computers the file is ipxe.efi. Once those values are set, when you pxe boot your computer you should see a screen with FOG iPXE Menu at the top. When you see this screen you know that your dhcp/netboot options have been set correctly.

    While I don’t want to go too deep in this next part, but we have seen where many router implementations of dhcp are somewhat lacking in pxe boot settings. No worries if your router doesn’t support dhcp boot settings we have other options to provide this information to the pxe booting computers. Its less configuration if your router supports it, but we can make do with lacking router dhcp settings.


  • Senior Developer

    @Vrogers said in Not able to capture Image:

    Yes, I searched for ‘SonicWall’ and also ‘Sonic Wall’ just to cover my bases and both returned with no hits.

    Returns several results for me.



  • @george1421 I’m sorry George, to say that I’m new to Fog would be an understatement. To answer your question about what part of the process is not working, I can’t say exactly, unfortunately. I followed the steps from a community spiceworks post found here, https://community.spiceworks.com/how_to/373-fog-server-install-free-opensource-ghost, in addition to a video I found on YouTube. But I have the MAC address of the host entered on the FogServer under the ‘Host’ tab, I have created an Image under the ‘Image’ tab. Moving further right along the tabs under ‘Tasks’, I have the active task ‘forced to start.’ I have the PC set to boot from PXE, only it doesn’t seem like it’s communicating with the fog server. I say that because it’ll go from IPv4, then IPv6, and then boot up to the Windows login screen without any indication of being registered. I am able to ping the fog server from the host, however, I am not able to ping the host from the fog server, which is why I think it’s something in the settings for the SonicWall that’s blocking the communication, which are a nightmare of complexities, at least to me. We’re running the Fog Server on Ubuntu Server 20.04.

    The screenshot, technically a picture from my phone, is the only thing that is displaying after I manually reboot the host PC. It sits on that screen for a minute, then continues to IPv6, and then boots to the Windows login screen.



  • @borg I’m not able to confirm if the host is registered with the server. Upon booting up it gives me the message in the bottom image for both IPv4 and IPv6. In the top image from the fog server, the ‘Warning’ icon previously was the Windows logo, until I attempted to capture the image, that’s when it changed to the warning.

    Screenshot (115)_LI.jpg

    InkedIMG_2372_LI.jpg


  • Moderator

    @Vrogers said in Not able to capture Image:

    when I reboot the host, it fails to capture the image for whatever reason.

    What does this really mean? What part of the process is not working? Are you getting to the FOG iPXE menu where you can pick to register a host? Is it failing to actually load the iPXE menu? Are you getting an PXE-XXX error or something stating a NBF download failure? A clear screen shot of the error will help us understand where the process is failing.



  • @Sebastian-Roth Yes, I searched for ‘SonicWall’ and also ‘Sonic Wall’ just to cover my bases and both returned with no hits.


  • Senior Developer

    @Vrogers Have you searched the forum for “SonicWall” yet? I am sure this will bring up valuable information. If not you can still come back.



  • may I inquire,
    Have you confirmed that the host has been registered with the server? on PXE boot there should be a screen telling you that the host is registered as [hostname]
    Have you set DHCP option 60 and 67 (i hope I remember correctly, please correct if I am wrong)?


Log in to reply
 

212
Online

7.2k
Users

14.4k
Topics

135.6k
Posts