Lenovo ThinkPad not working with FOG 1.5.8

  • I recently got a Lenovo ThinkPad L15 (Gen 1) that needed to be imaged. I could not get it to go with 1.5.8, so I updated to 1.5.9-RC2.9 and still no go. I then changed the Kernel to 5.6.18 (64) and it finally loaded up partclone. It was giving an error of no network interfaces found.

    Possible FOG 1.5.8 would have worked if I had changed the Kernel then.
    Using: ipxe.efi

  • Moderator

    Mod Note: I forked your topic off from the hardware working with FOG because your situation needs a bit more explaining.

    The newest hardware does not work with the FOS Linux kernels shipped with FOG 1.5.8. The issue is the linux kernel developers are no longer back porting the newest drivers to the Linux 4.19.x series of linux kernels. They are only writing new drivers for 5.x series of linux kernels. (if you want to equate this to the windows world, hardware manufacturers are no longer creating drivers for Windows 7, but now they only release drivers for Windows 10). The linux developers are doing the same, leaving the older ones behind and only writing for the new OS.

    Because of this the FOG developers have released 5.6.18 version of the FOG Linux kernel. Understand this kernel has NOT been widely tested with FOG at this time. The deverlopers released this as an option for those FOG admins that have very new hardware that is not supported by linux 4.19.x. Since FOG 1.5.9 is on the edge of final release, 1.5.9 will continue to ship with linux 4.19.x with the option of the FOG admin to upgrade to 5.6.18. Once more people test this new kernel and it proves to be stable then the 5.x line of linux will become default for FOG.

    I know its a lot of words to explain, yes I see 5.6.18 addressed your problem, well done.