• My client is a HP EliteDesk 800 G5 TWR with a Fujitsu P19-1S monitor (1280x1024; 63,9 kHz / 60 Hz). After selecting a boot image (*.iso) the screen appears multiple times on the display with not all lines of pixels displayed. This fills the upper part of the dislay, the rest is black (”Screenshot“ of the client). The reactions on the screen suggest that it’s a graphical issue only. The screen where to select the installation method (with a CD image as *.iso) seems printed without any error.
    May the drivers be a possible source of this issue?

    Booting the same image from a USB stick and from a Fujitsu with an ASUS as monitor works fine.
    Some other images don’t make it to that stage and enter the interactive prompt, e. g. the image which’s name is manjaro-xfce-20.0.1-200511-linux56.iso:

    ERROR: '/dev/disk/by-label/MANJARO_XFCE_2001' device did not show up after 30 seconds...
        Falling back to interactive prompt
        You can try to fix the problem manually, log out when you are finished
    sh: can't access tty: job control turned off
    [rootfs ]# _

    Do you need also information like the Advanced Boot Menu entry/entries?

  • Moderator

    @frit As I mentioned previously this is not a FOG Imaging issue. You are using FOG in a way it wasn’t designed. That is OK because FOG is an opensource project you can use it in any way you can imagine. The FOG developers do have limited resources to provide support beyond the scope of FOG imaging.

    With that said, I feel you are going about netbooting in the wrong direction. Right away I see two issues with your setup.

    1. using memdisk will restrict you to only being able to boot in bios mode. memdisk doeesn’t support uefi booting.
    2. If you use memdisk you need to have enough ram to hold the iso image and boot from it.

    I have a tutorial on how to use FOG as a netboot server (again not as the FOG developers has designed) here: https://forums.fogproject.org/topic/10944/using-fog-to-pxe-boot-into-your-favorite-installer-images

    While I haven’t worked with manjaro its based on Arch linux (which also I haven’t tried to netboot) but you should be able to follow the ubuntu workflow to get it to netboot. There is a tutorial on getting windows pe to netboot and that does work.

  • @george1421 Which forum in your opinion would be most related to this issue (e. g. HP, Manjaro, (i)PXE, the Linux kernel)? I also tried another machine with the same monitor and the problem didn’t show up, btw.
    @Sebastian-Roth Right, I was booting an *.iso image of MS Win 10.
    I was trying out vga=785 and acpi=off/noacpi after “raw” and at the end of the line(s) containing “sanboot” in my FOG Configuration > iPXE General Configuration > Advanced Menu settings > Advanced menu command, but the following is the version used when I took the above image.

    item --gap – ---------------- iPXE boot menu ----------------
    item W10LTSC1909 Windows 10 LTSC 1909
    item manjaro-xfce Manjaro GNU/Linux (Xfce) 20.0.1
    item SHELL iPXE Shell
    item RETURN Return to previous menu
    choose --default RETURN --timeout 10000 target && goto ${target}
    sanboot http://${fog-ip}/w10/Win10_Ent_LTSC_2019-x64-de.iso
    chain memdisk iso raw || goto MENU
    :manjaro-xfce sanboot http://${fog-ip}/isos/manjaro-xfce-20.0.1-200511-linux56.iso
    chain memdisk iso raw || goto MENU
    shell ||
    goto MENU
    chain http://${fog-ip}/${fog-webroot}/service/ipxe/boot.php?mac=${net0/mac} ||
    goto MENU

    In case it helps, I’m “running the latest dev-branch version: 1.5.9-RC2.9”.

    I also “freshly downloaded” (again, just to be sure everything is as expected) the Manjaro iso to a separate computer and burnt it onto a USB stick, from which I booted the client PC, which worked fine.
    Booting the same image from FOG works to the point of selecting the language and so on on the “Welcome to Manjaro” greeter screen, so I hit “return”.
    After some seconds of a black screen, the initially posted text of the interactive prompt appears.

    Choosing then my locale’s keymap and language, nonfree drivers and replacing “quiet” with “verbose” in the boot params after the greeter screen appeared gives me the following.

    [    0.431132] ACPI BIOS Error (bug): AE_AML_BUFFER_LIMIT, Field [CAP1] at bit o
    ffset/length 64/32 exceeds size of target Buffer (64 bits) (20200110/dsopcode-19
    [    0.431147] ACPI Error: Aborting method \_SB._OSC due to previous error (AE_A
    ML_BUFFER_LIMIT) (20200110/psparse-529)
    :: running early hook [udev]
    Starting version 245.5-2-manjaro
    :: running early hook [miso_pxe_nbd]
    :: running hook [udev]
    :: Triggering uevents...
    :: running hook [miso]
    :: running hook [miso_loop_mnt]
    :: running hook [miso_pxe_common]
    :: running hook [miso_pxe_http]
    :: running hook [miso_pxe_nbd]
    :: running hook [miso_pxe_nfs]
    :: running hook [keymap]
    :: Loading keypam...done.
    :: Mounting '/dev/disk/by-label/MANJARO_XFCE_2001' to '/run/miso/bootmnt'
    Waiting 30 seconds for device /dev/disk/by-label/MANJARO_XFCE_2001 ...
    ERROR: '/dev/disk/by-label/MANJARO_XFCE_2001' device did not show up after 30 seconds...
        Falling back to interactive prompt
        You can try to fix the problem manually, log out when you are finished
    sh: can't access tty: job control turned off
    [rootfs ]# _
  • Moderator

    @frit While George is right that this is beyond our scope I might still add that it seems interesting to see this on screen. While I am not sure it seems to be a Windows ISO boot screen, right?

    You might want to post the menu commands nevertheless. Possibly there is something obvious we see.

  • Moderator

    This issue is beyond of the scope of this support forum since your issue is not related to imaging with FOG. It appears you are trying to boot something other than FOS Linux on the target computer.

    But as a guess the kernel being used to netboot is not the same as the one that comes from the iso image. The kernel you are booting might have the driver needed for that graphics card. But that is only a very bad guess to your issue.