FOG_DISABLE_CHKDSK setting



  • Seems like the “FOG_DISABLE_CHKDSK” setting in .32 is not set correctly. It is set to 1 by default, and according to the information, that should mean that chkdsk will not run. However the behavior is opposite, at least in some limited testing. When you run a Quick Image, and this value is set to 1, chkdsk runs. Chkdsk does not run if you change the value to 0.

    There are several short-hand php if-then logic statements in /var/www/fog/management/includes/tasks.confirm.include.php that deal with this.
    [CODE]$other .= (" chkdsk=" . ($core->getGlobalSetting(“FOG_DISABLE_CHKDSK”) == “1” ? ‘0’ : ‘1’));[/CODE]

    And I noticed it in the fog script when I was looking at the init image file:
    [CODE]if [ “$chkdsk” == “0” ]
    then
    RUN_CHKDSK="-x";
    fi[/CODE]


  • Senior Developer

    Now I see, this is just a copy&paste from an old topic… https://forums.fogproject.org/topic/988/fog_disable_chkdsk-setting

    @Bienxanh Why do you waste our time I wonder?


  • Senior Developer

    @Bienxanh said:

    Seems like the “FOG_DISABLE_CHKDSK” setting in .32 is not set correctly…

    Do you really mean FOG 0.32 or is this a joke? That version is roughly a decade old and we surely can’t backport any fixes to such an old version.


Log in to reply
 

262
Online

7.1k
Users

14.3k
Topics

135.1k
Posts