• Hi,
    I have a problem/issue to resolve.
    I configure Fog with this config

    Network in VLAN: 10.0.x.x Netmask: 255.255.248.0 
    Server IP: 10.0.0.68
    

    Configured DHCP with:

    subnet 10.0.0.0 netmask 255.255.248.0 {
            range 10.0.5.1 10.0.5.254;
            option routers 10.0.0.100;
            option subnet-mask 255.255.248.0;
            option broadcast-address 10.0.7.255;
            next-server 10.0.0.68;
    

    Config for my WDS:

    if exists user-class and option user-class = "iPXE" {
            filename "http://10.0.0.68/boot.php";
        } else {
    
            if option arch = 00:00 {
    
                filename "undionly-mj2.kpxe";
            } else {
    #UEFI Bootujemy z WDS UEFI
            next-server 10.249.4.20;
            filename "boot\\x64\\wdsmgfw.efi"
            }
        }
    

    Everything is working ok client systems boot from pxe with WDS and servers also boot corectly.
    When i change my new server vlan from 10.0.x.x to 10.249.x.x booting with servers not working,
    but when i change adress server address to 10.249.0.68 and mask 255.25.240.0 servers boot coreclty in new vlan 10.249.x.x but clients fail.

    My problem i change address change of pxe server.
    I need to change adress beacuse i need to remove network 10.0.x.x in future but i still neeed to use it.

    My new config will be:

    Network in VLAN: 10.249.x.x Netmask: 255.255.240.0 
    Server IP: 10.249.0.68
    

    How to config this to work with both vlans 10.0 and 10.249.
    On old adress 10.0.0.68 client can boot from WDS with address : 10.249.4.20.

  • Moderator

    @ZrytyADHD said in Booting accros networks:

    You have a number of problems here.

    1. FOG doesn’t like it when you change the fog server’s IP address after FOG is installed. There are several steps that you must do if you decide to change the FOG server IP address after fog is installed.

    2. Why are you mixing WDS and FOG in your booting process? You can do manage it but I would go about it a bit differently.

    3. Your section of the isc dhcp server is just wrong in my opinion.

    if exists user-class and option user-class = "iPXE" {
            filename "http://10.0.0.68/boot.php";
        } else {
    
            if option arch = 00:00 {
    
                filename "undionly-mj2.kpxe";
            } else {
    #UEFI Bootujemy z WDS UEFI
            next-server 10.249.4.20;
            filename "boot\\x64\\wdsmgfw.efi"
            }
        }
    

    a. I’m not aware of a user class in the dhcp discover packet. There is a vendor class
    Vendor class identifier: PXEClient:Arch:00007:UNDI:003016

    b. The following line is wrong for several reasons

    filename "http://10.0.0.68/boot.php";
    

    b.1 you are telling the PXE rom to load a http protocol. Almost all PXE roms use tftp not http.
    b.2 The path to the boot.php is wrong if you are trying to call the boot.php on the fog server the path is <fog_server_ip>/fog/service/ipxe/boot.php

    For this I would just use filename "default.ipxe"; but that still will not work because you don’t mention the boot loader (undionly.kpxe or ipxe.efu)

    c. You are saying if the option is bios then load undionly-mj2.kpxe (not a fog supplied boot loader) but if everything else call WDS. But only do this if user-class == “iPXE”

    d. uefi pxe booting into FOG is not supported

    There are ways to fix this, dhcp booting, but please explain why you are mixing FOG and WDS. What is your goal of doing this? Will it be a for ever solution?

298
Online

7.6k
Users

14.7k
Topics

138.3k
Posts