Unable Boot to Hard Drive after loading an image



  • New to Fog… So far its really cool and I think I can use it to help img boxes. All our installs are UEFI, linux or windows.

    I am struggling to find the working config combo that will allow my system to boot after I add a HOST > create image > copy image to new server.

    I can create images and load images, but when it does the default boot hard drive option, i just get a blinking _ _ _.

    If I hit F11 for the boot menu and skip to the image I loaded, it boots fine. But booting from the FOG menu/default option I cant get working. Strange.

    I have changed “Exit to Hard Drive Type” and “Exit to Hard Drive Type(EFI)” and have searched for this issue here trying to use others suggestions, but not having luck.

    I am using PFSENSE for DHCP. Fog is installed on Centos8.

    I have tried using in pfsense dhcp “Default BIOS file name”
    ipxe.kpxe
    undionly.kkpxe
    undionly.kpxe

    The only things that really change my results are changing the exit methods. The Supermicro Intel PXE boot is not a UEFI so its trying to boot my OS which is UEFI. I hope I am just missing some setting.

    THanks


  • Moderator

    @mhx Ok then lets extend a bit on what Sebastian suggested. Right now the main issue is PXE booting into FOG, and your firmware’s absence of a uefi network stack. So what we are going to attempt is to supplement your firmware by booting the iPXE boot loader directly from a uefi bootable memory stick using this process: https://forums.fogproject.org/topic/6350/usb-boot-uefi-client-into-fog-menu-easy-way

    typically the PXE rom in your network adapter reaches out via bootp and downloads the iPXE boot loader from the network, in this case we are going to load it directly from the USB flash drive. That flash drive can be tiny in todays standards. The iPXE boot loader can easily fit on a 512MB flash device. There is no need for anything bigger since it will be just a waste of empty space.



  • @george1421 said in Unable Boot to Hard Drive after loading an image:

    @mhx How many of these systems do you need to image?

    About 30…


  • Senior Developer

    @mhx said in Unable Boot to Hard Drive after loading an image:

    So that could be a work around is just to change the boot order manually.

    Sad to say but that’s probably your best option. I have read through the manuals and can’t find anything about UEFI PXE booting. The other option I can think of is booting iPXE from a USB key (set BIOS to UEFI and default boot from USB). That way you can chainload to FOG’s PXE menu or back to boot from local disk without changing BIOS settings. Though I have to say that with some of those boards also USB booting is a nightmare and I have no idea if this would really work out in your case.


  • Moderator

    @mhx How many of these systems do you need to image?



  • @george1421 said in Unable Boot to Hard Drive after loading an image:

    You should be able to image a uefi system using FOG in bios mode. After fog imaging is done you will need to switch to uefi mode before the first boot of windows.

    Yah, it will work if i go back to bios and change the boot order and turn off network pxe boot. The server can boot UEFI windows/linux, but dont see UEFI Intel Pxe boot option on this older unit like I do the other server. Sadly there is no bios updates for this board.

    So that could be a work around is just to change the boot order manually.


  • Moderator

    @mhx I find it interesting that the mobo doesn’t support uefi booting. Some firmware require you to enable the uefi network stack before pxe booting in uefi mode is enabled.

    You should be able to image a uefi system using FOG in bios mode. After fog imaging is done you will need to switch to uefi mode before the first boot of windows.

    If all else fails you can boot into FOG off usb in uefi mode. This isn’t ideal because you loose some features but if all you have is a small number of these it will work.



  • @Sebastian-Roth

    Motherboard:
    https://www.supermicro.com/products/motherboard/Xeon/C202_C204/X9SCL-F.cfm
    This has to be left in Legacy + UEFI mode if I dont the INTEL PXE boot option goes away from the boot order.
    https://www.dropbox.com/s/rhhufmawq6j5m4p/jp2launcher_8U7gOO1LRD.jpg?dl=0
    https://www.dropbox.com/s/vk7kpgq4l9o0oe1/mstsc_ZHtVpn78Bw.jpg?dl=0
    Is there any way to get these older boards to boot to Legacy PXE > chainboot EFI image?

    I ended up trying another server with this board w/ x10SLH
    https://www.supermicro.com/en/products/motherboard/x10slh-f
    I can get this one to give m the UEFI pxe Intel boot. Going to play with this.
    https://www.dropbox.com/s/s3m1v350uo2a0oz/mstsc_JrAhK3xBCg.jpg?dl=0

    Should I be using undionly.kpxe as def boot?
    and what should these be set to?
    Exit to Hard Drive Type
    Exit to Hard Drive Type(EFI)


  • Senior Developer

    @mhx Hi and welcome to the forums!

    The Supermicro Intel PXE boot is not a UEFI so its trying to boot my OS which is UEFI.

    From what I read between the lines this seems to be the culprit to me. While there is no issue in deploying an UEFI install (GPT partition layout and such) in PXE BIOS mode I think it’s causing an issue if you PXE boot in BIOS mode and want it to chainload an OS from disk in UEFI mode.

    How do you see the Supermicro is not PXE in UEFI? Are you sure this is the case? Can you take a video or picture of the screen and post here? As well you might post some more details about this board and we can try to help you figure out if it’s possible to switch to PXE boot in UEFI mode.


Log in to reply
 

277
Online

7.4k
Users

14.5k
Topics

136.7k
Posts