Exit PXE Boot to Hard Drive



  • Hello, I know this topic has probably been brought up before, but I am still not able to resolve this issue. Currently I have PXE as the default boot option in my BIOS. This works great for easily capturing and deploying images (especially with the Wake-On-LAN feature), but when I do not have an image to capture or deploy Fog will not exit to my SSD. I tried adjusting all the Boot Exit options in the Fog Configuration Settings, but no luck. I have over 100 computers on a LAN and I would like to boot all of them at the click of a button and have them complete a Fog task or skip to the internal drive of the computer if no task is present. These computers are fairly new (2018). Can anyone point me in the right direction?



  • @george1421 so far it’s only 2 out of the 12 I’ve done. If I hit boot from hard disk it will go to the drive, but otherwise nothing happens. Tried it multiple times.


  • Moderator

    @nerdstburns https://wiki.fogproject.org/wiki/index.php/BIOS_and_UEFI_Co-Existence

    Just sitting at the FOG menu is hard to believe (possible but hard to believe) it would be random. There is a default menu item created and there is a timer set to count down and pick that default menu item. They should all work or not work as far as I know.



  • @george1421 if you can post a link that would be great.

    Also, I noticed some of the PCs don’t time out, they just sit at the fog screen until you hit “boot from hard disk.” Any idea how to fix that?


  • Moderator

    @nerdstburns So now you are good? PXE boots into fog menu then times out and boots hard drive?

    IF so and IF you need to support both uefi and bios systems AND you have either a linux or windows 2012 or later dhcp server there are some settings you can make to support dynamic pxe booting where the dhcp server will dynamically send the right boot loader based on the target computer. If you need that configuration I can post a link.



  • @george1421 changing the boot loader on the DHCP server to ipxe.efi fixed it. Thank you so much!


  • Moderator

    @nerdstburns Ok now we are moving forward.

    You are now booting in uefi mode and it skips to the ssd and boots. While this isn’t what you want to happen we know a bit more than we did when starting.

    1. We know that the disk image on the target computer is uefi, otherwise the system would not boot in uefi mode.

    2. Within FOG we can just focus on the UEFI Exit Mode. We can just leave the bios exit mode in SANBOOT and not touch it.

    Now in uefi mode do you have the network interface configured as first in the boot order or did the hard drive slip in there as first in the order?

    Second thing is now that you are booting pure uefi mode your dhcp server needs to send ipxe.efi to the target computer in dhcp option 67 and not undionly.kpxe. The undionly.kpxe boot loader is for bios mode.

    Third, does your mobo have a boot menu. On the dells we access it via F12 during post.



  • @george1421 ok so I changed to UEFI boot and enabled network stack. Now the network boot option appears in the boot menu and it looks like it’s gonna happen but I don’t see a fog screen and it skips directly to the SSD even though an image is scheduled.


  • Moderator

    @nerdstburns said in Exit PXE Boot to Hard Drive:

    Boot mode select = LEGACY+UEFI

    Well this one seems to allow legacy or uefi mode depending on the format on the hard drive.

    alternate option for UEFI only

    Typically in uefi mode you need to enable the network stack to allow pxe booting. On the Dells you switch to uefi mode then you need to go to the LOM (lan on motherboard) page to enable uefi network stack. I can’t say for your but its possible that fog is getting confused because of the dynamic booting.



  • @george1421 it’s a custom build with an MSI motherboard. Looking at the BIOS settings it says “Boot mode select = LEGACY+UEFI” but there is an alternate option for UEFI only. The only thing is that when I select that my PXE boot option disappears.


  • Moderator

    @nerdstburns What mode uefi or bios? What model of computer?



  • I have played around with both (went through each one and powered on the computer, but it still brings me to a black screen)


  • Moderator

    Are these target computer uefi or bios based. Because there is a different exit mode for uefi vs bios. For bios we find that Sanboot works the best, for uefi we find rEFInd works the best. You can set these on a per host basis or using the global settings under the fog configuration page.


Log in to reply
 

304
Online

7.0k
Users

14.2k
Topics

134.3k
Posts