message "Could not verify mount point, check if .mntcheck exists (/bin/fog.upload)



  • after booting the Debian 10, and EXP booting a device. I get the message "Could not verify mount point, check if .mntcheck exists (/bin/fog.upload. i can’s see of .mntcheck is located in /images/dev. What can i do to fix this problem? i have tried to add .mntcheck with "touch"command but nothing works.


  • Senior Developer

    @DennisRentAll Let’s take one step back here. Is this a fresh clean install of FOG showing this issue or has this worked before and the problem turned up just now?

    What Linux OS is this running on? Firewall disabled? SELinux disabled?



  • Here are my screenshots:
    ls -la /images/dev to validate .mntcheck exists in the upload location:
    2020-05-19_14h45_43.png
    ls -la /images to validate the permissions of the files and directories of the image store:
    2020-05-19_14h49_04.png
    Can you also ensure NFS is actually running? systemctl status nfs-kernel-server (I think that’s it for debian):
    d90b55a6-4d94-4042-a478-551d2c11ecbe-image.png

    showmount -e 192.168.201.48:
    59bbcba5-1c32-4753-a659-57d5a82783dc-image.png


  • Senior Developer

    @DennisRentAll What about ls -la /images/dev as originally requested? The l in the la is needed too, as it will list the directory so we can see the permissions.

    So we need 2 things:

    ls -la /images/dev to validate .mntcheck exists in the upload location
    ls -la /images to validate the permissions of the files and directories of the image store.

    Can you also ensure NFS is actually running? systemctl status nfs-kernel-server (I think that’s it for debian)

    Also let’s see the nfs shares just to be on the safe side:
    showmount -e 192.168.201.48
    showmount -e eth0



  • Hello Tom,

    Thanks for answer my question!

    I’m trying to clarify my issue.
    i’m running FOG projects 1.5.8.
    I’m dropping a screenshot of my Storage node settings, and the screenshot of the error:
    2020-05-19_08h51_42.png

    WhatsApp Image 2020-05-19 at 08.10.56.jpeg

    I have mounted the /image folder to my Netgear NAS.

    Screenshot of the “ls -a”:
    2020-05-19_08h54_07.png


  • Senior Developer

    Can you please clarify a bit?

    You say:

    @DennisRentAll said in message "Could not verify mount point, check if .mntcheck exists (/bin/fog.upload):

    i have tried to add .mntcheck with "touch"command but nothing works.

    What do you mean by this? What makes you think “nothing works”

    We also need details:

    What version of FOG are you running?
    Is your images directory truly /images
    What’s output of ls -la /images/dev

    Files beginning with a period (.) in linux are “hidden” by normal views, but the ls -la will display all files (regardless of hidden or not)

    Can you post a picture of the exact error? Context matters sometimes.


Log in to reply
 

263
Online

7.1k
Users

14.3k
Topics

135.1k
Posts