FOG Server cannot connect to storage node


  • Hey everybody,

    I used to have this working but I had to reinstall my storage node instance and I can’t get the main server to see the storage node for some reason. I’m running the latest 1.5.8.28 on both servers. I am able to connect to MySQL from the remote host no problem with the username and password that are entered in .fogsettings. Also, the fogproject user has the proper password as defined in .fogsettings.

    I see the following when I go to FOG Configuration:

    Main Server FOG Version: 1.5.8.28
    Storage Node FOG Version: 503 Service Unavailable

    Any idea what this means? I don’t think it’s a mysql issue.

    thanks
    88

  • Senior Developer

    @88fingerslukee said in FOG Server cannot connect to storage node:

    I have put the correct mysql connections into the fogsettings file.

    The fogsettings file is only used by the installer. Did you re-run the FOG installer after adjusting fogsettings? Or you can manually edit /var/www/html/fog/lib/fog/config.class.php for the DB settings.

    The URL called is http://fog.server.ip/fog/status/kernelvers.php - be aware that this URL is called from your FOG master node. So if you can open this URL from your browser it doesn’t necessarily mean that it does work when called from the master node as well.


  • Thanks for the reply!

    Apache is definitely running. When I go to http://x.x.x.x/fog I get the following message:

    This is a storage node, please do not access the web ui here!

    I have another website on this server, what URL does the master node look to when determining the storage node info?

    I have put the correct mysql connections into the fogsettings file.

    Anything else I can look at?

  • Moderator

    On the storage node, did you disable the firewall?
    The 503 error message kind of indicates the apache server is not running on the storage node. Confirm that apache is running by executing these commands on the storage node

    ps aux|grep apache

    and

    netstat -an | grep :80

    Now the storage nodes need to connect to the database on the master node. The correct values should be in the fog configuration settings on the master node. Those login settings should go into the config file on the storage node.

334
Online

7.7k
Users

14.7k
Topics

138.5k
Posts