Can't have a partition outside of disk error

  • Hi there,
    I’m running into a few issues using Fog .32 but one of the most annoying problems that I see consistantly is the “can’t have a [I]partition outside of disk” [/I]error.

    For some reason if I try to use Single Disk Resizable, Fog will finish verifying resizing the disk but will freeze after that step. Because of this we have been using Multiple Disk Single Disk Nonresizable, which works most of the time. To work around this partition issue I reduced the OS partition on my image to 30GB because I was worried that this message was appearing because I was trying to take an image from a PC with a 80GB OS partition to a hard drive that only had a max size of 60GB. This, however, has not resolved my problem.

    So I guess my two questions are, what steps can I take to get Single Disk Resizable working (Ive tried different Kernels) and why does a 30GB OS partition cause this error to show up on 60GB hard drive (granted the imaged was taken from a drive that has a max size of 80GB but the OS partition was shrunk to 30GB)? Any input or advice would be appreciated on this.

    Actually I may have resolved this issue by using GParted to shrink the HDD partition down to 20GB. I will have to do further testing.

  • Moderator

    Please start a new thread and link back to this one if it’s related. Based on your thread, I don’t know if you are having issues or just adding items to the wish-list.

  • What I’d love to see here is someone posting an actually working solution for uploading a pre-sysprep’d image. I have tried several times here (single partition…) to upload a pre-sysprep’d image, having it only fail. Is there anyone doing this and if so, how? Thanks

  • Moderator

    For my Windows 7 images, because I do NOT do a sysprep /generalize right before imaging, I find the Single-Disk, Multiple Partitions works best. I generally image onto same size or bigger drives though, so I’m lucky.

    Maybe incorporating sysprep /generalize into your last steps before imaging will help your single-parition, resizable problems.

  • It looks like I may have worked around this now. I was resizing the partition in Windows before I imaged with fog but after booting into Gparted live I noticed that the NTFS partition was still the max size of the disk even though Windows was reporting that the disk size was smaller. What I ended up doing was shrinking the partition in GParted and that worked.

    On a side note, I noticed that shrinking the partition in GParted causes windows 7 to do a check disk right before the OS boots. To make a cleaner image I let the system go through with the check disk and then after it rebooted it bounced it up to Fog. I still haven’t had any luck getting Single Disk Resizable working…

  • I always get this when the image was created on and uploaded from a drive larger than the target drive you are now using. Maybe there’s a fix, but our workaround is to always build our images on drives we know will be smaller than the target.