No configuration methods succeeded: DHCP failed



  • On my windows 10 PC, I installed Virtualbox with two machines:

    1. ubuntu 18:04
    2. minimal distribution (SLAX)

    My goal is to deploy SLAX image and manage the machine.

    I’m not able to shutdown my local DHCP so, what I did is to set two different interfaces on ubuntu: one via NAT and the second using internal network. In UBUNTU I also assigned a static ip to internal network (192.168.1.1). Now, I install FOG server with DHCP, this are the option that I’ve choosen:
    Should the installer try to disable the local firewall for you now? (y/N) N
    What type of installation would you like to do? [N/s (Normal/Storage)] N
    We found the following interfaces on your system:
    * enp0s3 - 10.0.2.15/24
    * enp0s8 - 192.168.1.1/24

    Would you like to change the default network interface from enp0s3?
    If you are not sure, select No. [y/N] Y
    What network interface would you like to use? enp0s8

    Would you like to setup a router address for the DHCP server? [Y/n] Y
    What is the IP address to be used for the router on
    the DHCP server? [10.0.2.2]192.168.1.1

    Would you like DHCP to handle DNS? [Y/n] N

    Would you like to use the FOG server for DHCP service? [y/N] Y

    This version of FOG has internationalization support, would
    you like to install the additional language packs? [y/N] n

    Would you like to enable secure HTTPS on your FOG server? [y/N] n

    Would you like to change it? If you are not sure, select No. [y/N] n

    Here are the settings FOG will use:

    • Base Linux: Debian
    • Detected Linux Distribution: Ubuntu
    • Interface: enp0s8
    • Server IP Address: 192.168.1.1
    • Server Subnet Mask: 255.255.255.0
    • Server Hostname: davide-VirtualBox
    • Installation Type: Normal Server
    • Internationalization: 0
    • Image Storage Location: /images
    • Using FOG DHCP: Yes
    • DHCP router Address: 192.168.1.1

    Now, the installation works and I’m able to connect to FOG dashboard via http://192.168.1.1/fog/management

    Now, I manage the SLAX virtual machine configuration through Virtualbox. I set in the network section internal network as I defined before and in the System part I set Network as the unique starting point. It’s time to start the machine. The DHCP works, in fact it gets an IP andress and then in the FOG project panel. I choose perform full host registration and inventory
    I’ve choosen the hostname and no image. No groups, No snapins, No product key, No domain, set a username, first tag=1, second tag=2, deploy image now Y, insert credential and then automatically reboot.
    It seems everything works, but after reboot:

    Immagine_iPXE.png

    I tried to be as precise as possible.
    Maybe a DHCP problem? I’m not sure about that.
    Thanks to everyone!


  • Senior Developer

    @davide1611 said in No configuration methods succeeded: DHCP failed:

    Thanks Sebastian and sorry for asking something already resolved

    You are welcome. No trouble at all. It might not be too easy to find the answer to this in the forums if you don’t know what is causing this.



  • @Sebastian-Roth Yes, it was that! Thanks Sebastian and sorry for asking something already resolved


  • Senior Developer

    @davide1611 This is a known issue. Edit the DHCP server config in your FOG server and swap out undionly.kkpxe with ipxe.pxe. That binary doesn’t have the reboot (warm boot) issue in VirtualBox.


  • Moderator

    Ok reading a bit more details into your post you are getting through the fog registration process so your setup is about perfect. Where its failing is on the reboot of the virtual box client computer, on a warm restart iPXE is not initializing the network interface correctly.

    As a test power OFF the vm then boot it. See if a cold start gets you back into the FOG iPXE menu. I believe what you are experiencing is an artifact of VirtualBox and not anything else. My bet is a physical machine will operate correctly in the same situation.


  • Moderator

    Ok from your picture we can rule out problems with your setup by about 95%.

    iPXE is getting to the target computer. So that tells us you have dhcp setup correctly, you have the fog server setup correctly (probably), where its failing is that iPXE boot loader can’t either initialize the network adapter on the target computer, or for some reason iPXE is not receiving a dhcp response from your dhcp server.


Log in to reply
 

348
Online

7.4k
Users

14.5k
Topics

136.7k
Posts