SOLVED Access denied for user 'root'@'localhost' (using password: NO)


  • Does fog install set a mysql root password (as a few threads says it doesn’t)?

    The installer currently errors (trying to get it to run in a proxmox container) so doesn’t output /opt/fog/.fogsettings

    When I try to run the installer again

    * Setting up and starting MySQL...............................OK
    
       To improve the overall security the installer will create an
       unpriviledged database user account for FOG's database access.
       Please provide the database *root* user password. Be asured
       that this password will only be used while the FOG installer
       is running and won't be stored anywhere:
    
       Unable to connect to the database using the given password!
       Try again:
    
     * Setting up MySQL user and database..........................Skipped```
    
    from bash
    

    root@rmlfog:/images# mysql -u root
    ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)

    root@rmlfog:/images# mysql -u root -pfog
    ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)
    root@rmlfog:/images# mysql -u root -ppassword```

  • Senior Developer

    @beardedfool Which Linux OS and version do you use? Older versions of FOG before 1.5.8 did run with an empty DB root password. So you find a lot of dated information on this. We were adding more security in 1.5.8 but it hat minor issues on some Linux OSes. Will provide detailed information for you when we know what you use.

344
Online

7.7k
Users

14.7k
Topics

138.5k
Posts