Can't get FOG option to show in boot options



  • Hi! I’m very new to this, so it’s probably a simple mistake but I’m not sure what I’m doing wrong. I’ve previously imaged laptops using Clonezilla Lite Server, which does not require any DHCP configuration, but does less than FOG. I purchased a server for hosting FOG, which arrived today. I am using a Raspberry Pi running Pi-Hole (which uses dnsmasq) as my DHCP server. I have created a file in /etc/dnsmasq.d/10-TFTP.conf (FOG server IP is 69.69.69.151, DHCP is 69.69.69.36, gateway is 69.69.69.69):

    dhcp-boot=undionly.kpxe,,69.69.69.151
    

    I have also (unsuccessfully) tried to do this with ProxyDHCP but that did not work either. Since I am completely new to this, it is probably something dumb I’m doing wrong. Thanks for your help.


  • Moderator

    You have a couple of options here. I guess the first thing to ask is why are you running a pi server as your dhcp server? Don’t you have an existing dhcp server on your subnet? If this is a home lab setup you can use your existing soho router to provide the dhcp services. If you go the soho router route, then you would load dnsmasq on your fog server in so called dhcpproxy mode to only provide the pxe boot information. You can install dnsmasq and get it up and running on your fog server in about 10 minutes using this tutorial: https://forums.fogproject.org/topic/12796/installing-dnsmasq-on-your-fog-server If you use my configuration exactly and just replace the <fog_server_IP> completely with your fog server’s IP dnsmasq will be configured to only provide the dynamic dhcp boot information. Your main dhcp server will issue the rest of the stuff.

    Now if you are ingenious you could reverse engineer dnsmasq on your pi-hole server to provide both. I can only give you guidance on what I’ve done personally.



  • @george1421 Hi! I’ve received a shipment of the laptops I am using this for, and for whatever reason those ones are booting from FOG properly. The computers I was testing on (which have the same BIOS software) did not boot from it. I am guessing that this was due to some BIOS configuration error on my part, as the computers have the same BIOS. Thanks for your help, though!



  • Both computers that are connected via Ethernet have ASUS motherboards which have the PXE option for both IPv4 and IPv6 enabled. When I spam F8 while booting, no PXE boot option displays.

    When I’ve previously done this with Clonezilla, the laptops I was using only showed the actual option when Clonezilla server was running on a device on the network. So I’m assuming the computers I’m testing with work similarly to this.


  • Moderator

    @evantig said in Can't get FOG option to show in boot options:

    I also tried switching to the router’s DHCP server, but that did not work.

    If we are questioning if you have things setup properly I have a tutorial on using tcpdump on the fog server to capture the pxe booting process when it goes sideways. We can go that route, but I want to make sure you have the target computer configured to pxe boot first.


  • Moderator

    @evantig said in Can't get FOG option to show in boot options:

    FOG server but there is still no option showing up in the BIOS

    Ok lets make sure we are on the same page. What you configured is for the network to supply network boot information. Now on the client you need to enable pxe booting in the firmware or (depending on the pc manufacturer) press F12 to get the boot manager when the PC boots. From there you should be able to pick tcpip v4, network boot, or what ever your hardware manufacturer calls it. From there your PC will send out a message and request the network boot info.

    Network booting is a concert between the pc, dhcp server and the dhcp proxy server. I can give you instructions on setting up Dells to network boot, but no other hardware.



  • @george1421 I also tried switching to the router’s DHCP server, but that did not work.



  • @george1421 I’ve followed that exactly and rebooted the FOG server but there is still no option showing up in the BIOS. I do have the Network Boot option enabled in the BIOS of the devices I’m trying this with.


  • Moderator

    @evantig Yes, that will work too. Just leave your Pi setup as a normal dhcp server. Then install dnsmasq on the fog server according to the tutorial.



  • Yes, this is at home. I have been using the Pi for DHCP because it gives extra statistics and has more options than the router’s DHCP server. If possible it would be preferable to keep using that. Would it be possible to use the Pi’s DHCP and still use FOG in DHCP proxy mode?


  • Moderator

    You have a couple of options here. I guess the first thing to ask is why are you running a pi server as your dhcp server? Don’t you have an existing dhcp server on your subnet? If this is a home lab setup you can use your existing soho router to provide the dhcp services. If you go the soho router route, then you would load dnsmasq on your fog server in so called dhcpproxy mode to only provide the pxe boot information. You can install dnsmasq and get it up and running on your fog server in about 10 minutes using this tutorial: https://forums.fogproject.org/topic/12796/installing-dnsmasq-on-your-fog-server If you use my configuration exactly and just replace the <fog_server_IP> completely with your fog server’s IP dnsmasq will be configured to only provide the dynamic dhcp boot information. Your main dhcp server will issue the rest of the stuff.

    Now if you are ingenious you could reverse engineer dnsmasq on your pi-hole server to provide both. I can only give you guidance on what I’ve done personally.


Log in to reply
 

306
Online

7.0k
Users

14.2k
Topics

134.2k
Posts