New computers- no configuration methods succedeed



  • fog issue.jpg

    Met with this issue on new computers with AMD processors and wifi cards
    AMD Ryzen5 PRO 3400G 4C 65W APU
    Intel Wi-Fi 6 AX200 ax 2x2 non-vPro +Bluetooth 5 WW

    fog version is 1.4.4

    I did read few cases here with same error, is this other way that switching to UEFI from legacy ?
    Need some tips, thank you!


  • Senior Developer

    @Mightmar said in New computers- no configuration methods succedeed:

    I got a new problem now

    May I ask you to open a new topic for this? We try to keep things sorted here so others can find solutions to same or similar issues better.



  • I got a new problem now after solving the issue from the subject, previous models now cannot join the domain while imaging with previously working images. I am not sure it could be because of the new bootloader ipxe.kpxe ? Updated kernels or tftboot files (undionly.kpxe, undionly.kkpxe, ipxe.kpxe, ipxe.efi?
    Computer is not receiving designed name in registration, still have random Desktop-xxxxx . I copied some of fog. log below:

    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:02 Client-Info Client Version: 0.11.12
     17.04.2042 15:02 Client-Info Client OS:      Windows
     17.04.2042 15:02 Client-Info Server Version: 1.4.4
     17.04.2042 15:02 Middleware::Response ERROR: Unable to get subsection
     17.04.2042 15:02 Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:02 Client-Info Client Version: 0.11.12
     17.04.2042 15:02 Client-Info Client OS:      Windows
     17.04.2042 15:02 Client-Info Server Version: 1.4.4
     17.04.2042 15:02 Middleware::Response ERROR: Unable to get subsection
     17.04.2042 15:02 Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:02 Client-Info Client Version: 0.11.12
     17.04.2042 15:02 Client-Info Client OS:      Windows
     17.04.2042 15:02 Client-Info Server Version: 1.4.4
     17.04.2042 15:02 Middleware::Response ERROR: Unable to get subsection
     17.04.2042 15:02 Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PowerManagement-------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:02 Client-Info Client Version: 0.11.12
     17.04.2042 15:02 Client-Info Client OS:      Windows
     17.04.2042 15:02 Client-Info Server Version: 1.4.4
     17.04.2042 15:02 Middleware::Response ERROR: Unable to get subsection
     17.04.2042 15:02 Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:02 Client-Info Client Version: 0.11.12
     17.04.2042 15:02 Client-Info Client OS:      Windows
     17.04.2042 15:02 Client-Info Server Version: 1.4.4
     17.04.2042 15:02 Middleware::Response ERROR: Unable to get subsection
     17.04.2042 15:02 Middleware::Response ERROR: Object reference not set to an instance of an object.
     17.04.2042 15:02 Service Sleeping for 151 seconds
     17.04.2042 15:05 Middleware::Communication URL: http://172.19.180.130/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     17.04.2042 15:05 Middleware::Response Success
     17.04.2042 15:05 Middleware::Communication URL: http://172.19.180.130/fog/management/index.php?sub=requestClientInfo&mac=F4:39:09:05:5D:F9&newService&json
     17.04.2042 15:05 Middleware::Authentication Waiting for authentication timeout to pass
     17.04.2042 15:05 Middleware::Communication Download: http://172.19.180.130/fog/management/other/ssl/srvpublic.crt
     17.04.2042 15:05 Middleware::Authentication ERROR: Could not authenticate
     17.04.2042 15:05 Middleware::Authentication ERROR: Value cannot be null.
    Parameter name: authority
     17.04.2042 15:05 Middleware::Response Success
     17.04.2042 15:05 Middleware::Communication URL: http://172.19.180.130/fog/service/getversion.php?clientver&newService&json
     17.04.2042 15:05 Middleware::Communication URL: http://172.19.180.130/fog/service/getversion.php?newService&json
    
     17.04.2042 15:05 Service Creating user agent cache
     17.04.2042 15:05 Middleware::Response ERROR: Unable to get subsection
     17.04.2042 15:05 Middleware::Response ERROR: Object reference not set to an instance of an object.
     17.04.2042 15:05 Middleware::Response ERROR: Unable to get subsection
     17.04.2042 15:05 Middleware::Response ERROR: Object reference not set to an instance of an object.
     17.04.2042 15:05 Middleware::Response ERROR: Unable to get subsection
     17.04.2042 15:05 Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:05 Client-Info Client Version: 0.11.12
     17.04.2042 15:05 Client-Info Client OS:      Windows
     17.04.2042 15:05 Client-Info Server Version: 1.4.4
     17.04.2042 15:05 Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:05 Client-Info Client Version: 0.11.12
     17.04.2042 15:05 Client-Info Client OS:      Windows
     17.04.2042 15:05 Client-Info Server Version: 1.4.4
     17.04.2042 15:05 Middleware::Response ERROR: Unable to get subsection
     17.04.2042 15:05 Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:05 Client-Info Client Version: 0.11.12
     17.04.2042 15:05 Client-Info Client OS:      Windows
     17.04.2042 15:05 Client-Info Server Version: 1.4.4
     17.04.2042 15:05 Middleware::Response ERROR: Unable to get subsection
     17.04.2042 15:05 Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:05 Client-Info Client Version: 0.11.12
     17.04.2042 15:05 Client-Info Client OS:      Windows
     17.04.2042 15:05 Client-Info Server Version: 1.4.4
     17.04.2042 15:05 Middleware::Response ERROR: Unable to get subsection
     17.04.2042 15:05 Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:05 Client-Info Client Version: 0.11.12
     17.04.2042 15:05 Client-Info Client OS:      Windows
     17.04.2042 15:05 Client-Info Server Version: 1.4.4
     17.04.2042 15:05 Middleware::Response ERROR: Unable to get subsection
     17.04.2042 15:05 Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PowerManagement-------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:05 Client-Info Client Version: 0.11.12
     17.04.2042 15:05 Client-Info Client OS:      Windows
     17.04.2042 15:05 Client-Info Server Version: 1.4.4
     17.04.2042 15:05 Middleware::Response ERROR: Unable to get subsection
     17.04.2042 15:05 Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:05 Client-Info Client Version: 0.11.12
     17.04.2042 15:05 Client-Info Client OS:      Windows
     17.04.2042 15:05 Client-Info Server Version: 1.4.4
     17.04.2042 15:05 Middleware::Response ERROR: Unable to get subsection
     17.04.2042 15:05 Middleware::Response ERROR: Object reference not set to an instance of an object.
     17.04.2042 15:05 Service Sleeping for 73 seconds
     17.04.2042 15:06 Main Overriding exception handling
     17.04.2042 15:06 Main Bootstrapping Zazzles
     17.04.2042 15:06 Controller Initialize
     17.04.2042 15:06 Controller Start
    
     17.04.2042 15:06 Service Starting service
     17.04.2042 15:07 Bus Became bus server
     17.04.2042 15:07 Bus Emmiting message on channel: Status
     17.04.2042 15:07 Service Invoking early JIT compilation on needed binaries
    
    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:07 Client-Info Version: 0.11.12
     17.04.2042 15:07 Client-Info OS:      Windows
     17.04.2042 15:07 Middleware::Authentication Waiting for authentication timeout to pass
     17.04.2042 15:07 Middleware::Communication Download: http://172.19.180.130/fog/management/other/ssl/srvpublic.crt
     17.04.2042 15:07 Middleware::Communication ERROR: Could not download file
     17.04.2042 15:07 Middleware::Communication ERROR: Unable to connect to the remote server
     17.04.2042 15:07 Middleware::Authentication ERROR: Could not authenticate
     17.04.2042 15:07 Middleware::Authentication ERROR: The system cannot find the file specified.
    
    
    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:07 Client-Info Version: 0.11.12
     17.04.2042 15:07 Client-Info OS:      Windows
     17.04.2042 15:07 Middleware::Authentication Waiting for authentication timeout to pass
     17.04.2042 15:09 Middleware::Communication Download: http://172.19.180.130/fog/management/other/ssl/srvpublic.crt
     17.04.2042 15:09 Middleware::Authentication ERROR: Could not authenticate
     17.04.2042 15:09 Middleware::Authentication ERROR: Value cannot be null.
    Parameter name: authority
    
    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:09 Client-Info Version: 0.11.12
     17.04.2042 15:09 Client-Info OS:      Windows
     17.04.2042 15:09 Middleware::Authentication Waiting for authentication timeout to pass
     17.04.2042 15:11 Middleware::Communication Download: http://172.19.180.130/fog/management/other/ssl/srvpublic.crt
     17.04.2042 15:11 Middleware::Authentication ERROR: Could not authenticate
     17.04.2042 15:11 Middleware::Authentication ERROR: Value cannot be null.
    Parameter name: authority
    
    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:11 Client-Info Version: 0.11.12
     17.04.2042 15:11 Client-Info OS:      Windows
     17.04.2042 15:11 Middleware::Authentication Waiting for authentication timeout to pass
     17.04.2042 15:13 Middleware::Communication Download: http://172.19.180.130/fog/management/other/ssl/srvpublic.crt
     17.04.2042 15:13 Middleware::Authentication ERROR: Could not authenticate
     17.04.2042 15:13 Middleware::Authentication ERROR: Value cannot be null.
    Parameter name: authority
    
    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     17.04.2042 15:13 Client-Info Version: 0.11.12
     17.04.2042 15:13 Client-Info OS:      Windows
     17.04.2042 15:13 Middleware::Authentication Waiting for authentication timeout to pass
     17.04.2042 15:15 Middleware::Communication Download: http://172.19.180.130/fog/management/other/ssl/srvpublic.crt
     17.04.2042 15:15 Middleware::Authentication ERROR: Could not authenticate
     17.04.2042 15:15 Middleware::Authentication ERROR: Value cannot be null.
    Parameter name: authority
    
    
     17.04.2042 15:15 Middleware::Communication URL: http://172.19.180.130/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     17.04.2042 15:15 Middleware::Response Success
     17.04.2042 15:15 Middleware::Communication URL: http://172.19.180.130/fog/management/index.php?sub=requestClientInfo&mac=F4:39:09:05:5D:F9&newService&json
     17.04.2042 15:15 Middleware::Authentication Waiting for authentication timeout to pass
    


  • @george1421 Issue is solved by editing option 67 on dhcp server, works with ipxe.kpxe! thank you very much for the help!


  • Moderator

    @Mightmar OK good, we are at a point of eliminating the obvious to find the root. Another option might be to find an add on nic adapter that has the pxe boot code on it too. Ideally an intel network adapter.

    Another random thought is if the current ethernet adapter is on the motherboard (LOM), make sure the bios (firmware) on the motherboard is up to date.



  • @george1421 Dumb switch didn’t help, I will try with changing dhcp boot loader, but need to do it with the network team, I will come back with the result, Thank you!


  • Moderator

    @Mightmar Do you have an unmanaged (read: cheap) network switch you can place between this computer and your building network switch?

    From your first post it looks like iPXE can see the network card because it references the mac address but it appears its not seeing the dhcp response from your dhcp server. I have seen conditions like this before related to having normal spanning tree enabled and not using one of the fast spanning tree protocols. Inserting a cheap unmanaged switch between the pxe booting computer and the building switch is a simple test to see if its a spanning tree issue or not.

    The other thing I see is that your network adapter is a realtek nic. Instead if using undionly.kpxe boot loader you can try ipxe.kpxe and see if it boots into the iPXE menu. You will need to change your dhcp option 67 to make this happen. To explain it simply the undionly.kpxe boot loader uses the undi driver built into the network card this boot loader works 95 % of the time. With some cards the undi built in network driver has a conflict with iPXE. The ipxe.kpxe and the ipxe.efi have all of the network card drivers built in. Lastly there is a realtek specific boot loader, you will have to look in the /tftpboot directory, I think its called realtek.kpxe.

    If everything else fails we can see if we can boot directly into FOS linux from a flash drive bypassing ipxe all together. There are some caveats using this method but as long as FOS Linux supports that network card it will work.



  • @Sebastian-Roth


  • Senior Developer

    @Mightmar said in New computers- no configuration methods succedeed:

    it is old, but it was working fine till now.

    Well, it’s expected behavior. You buy new hardware and it doesn’t play nicely with old software. What do you expect?

    Yes, it is connected to ethernet, just added wifi card to ticket because is one of the new things from previous computers specs, I thought might be helpful.

    Ok, nevermind.

    Lately I upgraded Kernel, which file I should upgrade now? All of them?

    Kernel (bzImage) is not the same as iPXE! To update the iPXE binaries run the following commands on your FOG server:

    sudo -i
    cd /tftpboot
    wget -O undionly.kkpxe https://github.com/FOGProject/fogproject/blob/master/packages/tftp/undionly.kkpxe?raw=true
    wget -O undionly.kpxe https://github.com/FOGProject/fogproject/blob/master/packages/tftp/undionly.kpxe?raw=true
    wget -O ipxe.pxe https://github.com/FOGProject/fogproject/blob/master/packages/tftp/ipxe.pxe?raw=true
    

    That’s just the three most commonly used iPXE binaries. You can update all of them but I would guess those three should be enough for now.

    where do I do that?

    If you want to change to use a different iPXE binary we need more information on what system is serving DHCP in you network. If it’s the FOG server itself then you want to take a look at the config file in /etc/dhcp/dhcpd.conf (or similar depending on the Linux OS you use).


  • Moderator

    @Mightmar said in New computers- no configuration methods succedeed:

    @Sebastian-Roth

    • it is old, but it was working fine till now.

    • Yes, it is connected to ethernet, just added wifi card to ticket because is one of the new things from previous computers specs, I thought might be helpful.

    • Lately I upgraded Kernel, which file I should upgrade now? All of them?

    • where do I do that?

    The first step is to update the iPXE boot loaders at the link Sebastian provided. You will need the two files I mentioned.

    FOG doesn’t image over wifi so that card will (should be) ignored.

    Old FOG with new hardware is not a good combination. Once you can get iPXE to boot then the next step is to run the hardware compatibility check from the iPXE menu. If the hardware is detected well then you are done, you can image. If some of the hardware is not detected then you will need to update the FOS Linux kernel from here: https://fogproject.org/kernels/ you will need to manually upgrade the FOS Linux kernel because of a bug in FOG 1.4.4. You will need both the 64 bit and 32 bit versions and rename them to bzImage and bzImage32 respectively, move them to /var/www/html/fog/service/ipxe directory


  • Moderator

    @Mightmar The mac address shown in the OP would indicate an HP ethernet adapter.

    I would firstly start by updating your undionly.kpxe and ipxe.efi files from the github site as Sebastian mentioned.



  • @Sebastian-Roth

    • it is old, but it was working fine till now.

    • Yes, it is connected to ethernet, just added wifi card to ticket because is one of the new things from previous computers specs, I thought might be helpful.

    • Lately I upgraded Kernel, which file I should upgrade now? All of them?

    • where do I do that?

    thank you very much for help!


  • Senior Developer

    @Mightmar There are a few things that come to my mind:

    • FOG 1.4.4 is really old! Maybe update can do the trick but check out the following hints first.
    • You said: “Intel Wi-Fi 6 AX200 ax 2x2 non-vPro +Bluetooth 5 WW” -> does this mahcine have ethernet as well?
    • You can try downloading the latest iPXE files and see if one of those work: https://github.com/FOGProject/fogproject/tree/master/packages/tftp
    • If you use undionly.kkpxe (FOGs default) you might try other binaries to see if one of those works with your new hardware

Log in to reply
 

297
Online

7.4k
Users

14.5k
Topics

136.5k
Posts