SOLVED No such file or directory (http: //

  • Hello, I’m very new to using FOG. I am trying to image computers using FOG but am running into an issue. I’ve set up a virtualbox with FOG 1.5.8 and Pfsense 2.5.0 but when I go to capture the Windows 10 image it’s unable to capture and is saying “No such file or directory (”.

    The FOG server, Pfsense server and Windows 10 image are all on a Bridge Network Adapter. I did as much research as I can on this issue before I made this post so any help would be appreciated. Thank you!

    I created the FOG server and Windows 10 image using these two guides:

    Untitled picture4.png
    Untitled picture.png Untitled picture2.png
    FOG server
    Untitled picture3.png
    TFTP server is running
    Untitled picture5.png

  • Moderator

    @anon01013 Yes I agree, tell us what your dhcp servers are and .9 . What is the manufacturer and version? Do you have access to change the configuration on these devices? Also please identify what is device

    Lets start with there, then we can chart the next steps.

    BTW: your packet capture really tells us the story of what is going on with your network. Without the pcap it would be impossible to help you with FOG on your network.

  • Moderator

    @anon01013 said in No such file or directory (http: //

    Where do I start on untwisting the network infrastructure?

    Well you might start by telling us more about the existing DHCP servers in your network.

  • @george1421

    I see, yeah that sounds like a mess and a lot of hair pulling but the goal is to push out a Windows 10 image to desktops. The business that I work at bought 200 desktops with no OS and they want me to create an imaging lab where I can image these desktops with a Windows 10 OS. Unfortunately, I’m the only technician with the business so I have to figure this out. 😕

    Where do I start on untwisting the network infrastructure? Thanks for all the help btw!

  • Moderator

    @anon01013 Oh my, there is a lot of funny business going on with that pcap.

    You have 2 dhcp server and with a subnet mask of you also have a dhcp relay agent at that goes somewhere is giving the client an IP address of: is giving the client an IP address of: is defining a default route of isn’t assigning a default route is providing itself as the bootp server but not providing a boot file name is providing itself as the bootp server but not providing a boot file name

    We are seeing so many offers because the dhcp-relay service on is reflecting the dhcp discovers back to both the and dhcp servers. These servers also might be windows AD servers too, I can’t tell because we did not capture that traffic by design.

    So now with that said, your FOG server is on a totally different subnet than what your pcap says the dhcp servers are telling the clients to pxe boot to. The fog server is on /24 and your main network (according to the dhcp servers are /16) There is no way the clients issued an IP address from the dhcp servers can reach the fog server unless they go through a router.

    I know for someone just starting out I just threw up a bunch of crap you don’t understand and none of its related to FOG. That is because the problem isn’t your FOG server at the moment, its your existing network infrastructure.

    You might want to explain what your goal is here so we can help you untwist this configuration.

    The first step is… do you want to integrate FOG into your existing /16 network? If so what are your dhcp servers and

  • Moderator

    @Sebastian-Roth said in No such file or directory (http: //

    @anon01013 Your pfSense (interface em0) and FOG server (intreface eth0) do have the same IP address, why?!?!

    Good catch. I think we have way to many new things in play here TBH. PXE booting is more like a concert with everything needing to work together. I haven’t looked at the pcap at the moment, but I’m going to bet the 2 dhcp servers responding are/is one is pfsense and the second is the home soho router. If this is the case then we can turn of pfsense for now and just install dnsmasq on the fog server to supply the pxe boot info. Its a bit cleaner solution with less parts to go wrong.

  • Moderator

    @anon01013 Your pfSense (interface em0) and FOG server (intreface eth0) do have the same IP address, why?!?!

  • @Sebastian-Roth This is what I have in the VirtualBox

    Fog server:



    Windows 10 image:

  • Moderator

    @anon01013 said:

    The FOG server, Pfsense server and Windows 10 image are all on a Bridge Network Adapter.

    Re-reading your post I just noticed this part. You have pfSense installed in a VM as well but it has two NICs bound to it. What are the VM network settings for those who NICs as well as the VM network settings for the other two VMs?

  • Moderator

    @anon01013 In that PCAP file there is no packet from or to the host we see in the picture (08:00:27:36:0d:ac). What is the network setting for this VM?

    In the PCAP we see two different DHCP servers answering and none of them does provide PXE boot information on the file name which is very important for PXE booting. Bother servers seem to point to different TFTP servers (next server).

  • @george1421

    Sorry, I’m still new to this but here’s the output pcap file.



  • Moderator

    @anon01013 Possibly the VirtualBox VM is set to UEFI but pfSense might not provide PXE boot information for UEFI clients?

    Note for everyone: As far as I see in the picture this output we see here from iPXE is NOT the one delivered from the FOG server but the one build into VirtualBox.

  • Moderator

    @anon01013 The pcap doesn’t match what should have been captured. Its not possible to generate this pcap from the screen shot you provided.

    Hint if you reply to my posts, the forum will ping me when you post.

  • Moderator

    @anon01013 Sorry I didn’t see this til now for some reason. Let me have a look.

  • Hello,

    I followed the process in the link and this is what I got, hopefully I did it right…

    Thanks for the assistance!



  • Moderator

    There are a couple of things here.

    1. By default pfsense sets up the dhcp server on the LAN interface and not the WAN.
    2. Also in the network booting section on pfsense you will need to setup the uefi boot file of ipxe.efi if you want to pxe boot uefi based computers.

    The error in the bios boot screen is a bit telling. Run through the following tutorial and capture a pcap of the pxe booting process. If you want to look at the pcap your self, transfer the pcap from the fog server to a computer with wireshark installed. Look at the second packet the one that has DHCP DISCOVER. In the ethernet header it will list the boot server and boot file name. My bet one of those are wrong. If you don’t know how to read wireshark post the pcap here and I’ll look at it for you.