Will not Join Domain after 1.5.8 Update



  • I updated to 1.5.8 from 1.5.7. All went well. Updated security. All went well. Updated client on test machine to 0.11.19. I now get an error in the fog.log file. unknown username or bad password, code 1326. I have logged into the domain with the account being used so the username and password are correct. I created a new account with the proper credentials and still the same error. The system can be joined to the domain with the account manually. I updated the config on the server both in the config then applied to the group where the system is a member as well as on the system itself. The error stays the same. It seems it is not reading the correct username or something has not been updated. The password does have an ! in it. Would this be causing issues with the latest version?


  • Senior Developer



  • I discovered this bug too when updating. My solution was just to create a group of all computers and then update the default AD credentials under Fog Settings. Then I just cleared it and repopulated the fields in Fog Settings. Then used the group of all and modified it for all computers at once. I even used the same password as I was.

    My speculation is that the new password encryption measure put in are breaking it, the length when the password is shown is way off of what it should be when its updated correctly.



  • @Sebastian-Roth I found a workaround. I was able to clear the “Domain Password Legacy” value and then typed the current password in the “Domain Password” field and that worked. I will work some sql magic and will be good to go. Thanks for responding.


  • Senior Developer

    @NSD_Network_Admin Probably the best way is to wait for 1.5.9. I was planing to have it released already but work and private projects keeps me from doing so over the last weeks. I am hoping to find more time soon.



  • @Sebastian-Roth I updated to 1.5.8 a couple of weeks ago and everything went smoothly until I went to fog a workstation today. Sure enough, it would not auto-join to our domain and I am seeing the username or bad password, code 1326 in the logs. We do have encrypted AD passwords in our DB. Is the only solution to upgrade to the dev-branch or is there another workaround? Will 1.5.9 be released in the near future?


  • Senior Developer

    @FredG If you actually see clients won’t join anymore but did so before (nothing changed beside the FOG update), then you would need to update to the latest development version (dev-branch) to get this fixed.

    Though it’s hard to tell if you really have that issue without seeing any logs or knowing more details.



  • How to Join the domain after 1.5.8 Update ? What solution is there?


  • Senior Developer

    @Goneski said in Will not Join Domain after 1.5.8 Update:

    The password does have an ! in it. Would this be causing issues with the latest version?

    Don’t think it would but we found and fixed an issue in 1.5.8 which would cause the bad password, code 1326 if you have encrypted AD password in your database (used in older versions of FOG). Though this issue would not just fix itself. So I am fairly sure this is the case here.



  • I am not sure exactly how. This has finally worked. I checked the system and it was joined. Nothing changed. Came back after lunch and it was complete. Going to do some more testing.


Log in to reply
 

279
Online

7.4k
Users

14.5k
Topics

136.5k
Posts