FOG Image Tasking "Force Task"



  • Hello,

    Versions of software…
    FOG: 1.5.7
    OS: Centos 7.7 / Latest Updates

    I’m not sure if this is a bug within FOG or if it was resolved in FOG 1.5.8. I haven’t had the time to upgrade FOG yet but will once done imaging multiple systems.

    When tasking a system to ‘capture’ an image I would go to the tasks and select the lightening bolt otherwise known as ‘Force task to start’. When doing so it clears out the ‘Storage Node’ from ‘MAINSTORAGE’ to blank. When done imaging the host spams a message no storage node and returns a “/bin/upload” error.

    Is this a bug yet I’m not sure why I’m using the ‘Force to start’ lightening bolt to begin with when the task initially starts, it was just out of habit.

    If this isn’t supposed to be used for this what is the purpose of that? Is it a wake on LAN function?

    Thanks.


  • Senior Developer

    @alansopro Do you still see the issue happen?


  • Senior Developer

    @alansopro Somehow lost track of this and forgot about it, sorry! Now that I am starting to tackle this I see that it’s not as simple as I’d hoped. In a basic setup (single FOG server, no storage node, clean install, no plugins, unicast deploy) I don’t see the issue as described. So we need some more details of your setup:

    • What does your storage setup look like, what nodes do you have?
    • Any plugins you have enabled?
    • When this happened, did you do a unicast or multicast deploy?

    As well I may ask you to do DB maintenance and try forcing a deploy task again. Just to make sure we are not hunting down a dead rabbit.

    I’ve already looked at the “force task” code and I have to say that I can imagine something can go wrong here if a plugin goes astray.


  • Senior Developer

    @alansopro said in FOG Image Tasking "Force Task":

    I think there is a bug with that function. Not that I need it but just thought I’d report back with my findings and let you guys take it from there.

    Thanks for the feedback. We’ll look into it. Though we won’t backport the fix to 1.5.7. Just so you are aware.



  • @Tom-Elliott said in FOG Image Tasking "Force Task":

    Force task to start is more intended for deploy tasks.

    I’m not quite sure why it would clear the storage node when you click force to start though.

    Tom,

    I did recently try to force the task on a deployment and it did the same thing. It cleared the storage node and threw a bunch of errors. I had to cancel the job and redo it without the ‘Force Task’ so I think there is a bug with that function. Not that I need it but just thought I’d report back with my findings and let you guys take it from there.

    Thank you.



  • I was thinking that was what it was only intended for deploying but wasn’t entirely sure.

    If it could be possible to fix in a future release that would be awesome. Sometimes you click it unintentionally without realizing it and then the cloning process just starts throwing errors and it’s hard to remember what it is sometimes. 🙂


  • Senior Developer

    Force task to start is more intended for deploy tasks.

    I’m not quite sure why it would clear the storage node when you click force to start though.


Log in to reply
 

355
Online

7.4k
Users

14.5k
Topics

136.7k
Posts