Need Guidance Other Than FOG Wiki page.



  • Trying to create a testbed for malware analysis. Boss told me to use FOG in Debian(because ill be working with only terminal later on). Im new to Debian & only knew FOG existed last week. I tried setting up the server but I keep failing and I’m being pressured due to time constraints. Im not sure if Im doing this right. Im stuck in a situation that makes me come back again to the start each time. So, Im going to list down what I’ve done to Install my FOG Server.

    1. I Installed Debian 10.3 in a PC to make it as my server.
    2. I then installed FOG’s latest version 1.5.7 into my Debian.
    3. I already get-update the installer.
    4. I followed the instruction as it is. Since I cannot connect my other PC’s to the internet, I am using a switch to connect them locally with ethernet cables. Therefore, my DHCP server(also my FOG server) is set up to assign IP addresses to other PC’s.
    5. Ive opened up the web page to my localhost FOG.
    6. From here, Im stuck. The Wiki & also other tutorials online have different ways to capture an image and it all seems so easy to do. But, I keep encountering problems.
      Problems that I faced:
      -DHCP server didn’t want to turn on
      -TFTP server didn’t want to turn on
      -Link files from the FOG zip file was outdated therefore, I had to manually input Debian 10.3 links for drivers.
      -pxelinux files were missing
      -tftpboot files missing
      After solving all these problems.
      Im now stuck at my bios with these error:

    params: command not found
    Could not boot: Exec format error (http://ipxe.org/2e22001)

    And yes, I did check my config.h file and I did add the #define PARAM_CMD. I also restarted the TFTP and DHCP services. I even uninstalled, purge and reinstalled the latest versions for he services. Im honestly stuck. I don’t mind starting all over again from scratch. I would be glad to uninstall and purge the entire FOG system and start from scratch if someone gave me proper instructions that are helpful for Debian 10.3. A proper, step-by-step,hassle free installation. Because its very troublesome to install offline versions of file and extracting them then putting it in a usb and transferring it to the server and client. I know connecting to the internet would save me all the trouble but it was strict rules from my supervisor to not connect them to the internet. If anyone would help me, Id be very grateful. Thank you. Im sorry if I sound like a child whining.


  • Senior Developer

    @Reuban1219 said in Need Guidance Other Than FOG Wiki page.:

    Now, I have to figure out how to keep the ports open at all times for the switch.

    It’s either spanning tree or some kind of ethernet energy saving or even a “security” feature.



  • @Sebastian-Roth @george1421 Thank you two so much. Ive managed to successfully upload and deploy an image. You’ve been very patient and helpful throughout. And it wasn’t the spanning tree problem. It was the switch which automatically closed the port. I then decided to connect the PC directly to each other and it immediately booted into FOG image upload. Now, I have to figure out how to keep the ports open at all times for the switch. Thank you again for all the help.


  • Moderator

    @Reuban1219 said in Need Guidance Other Than FOG Wiki page.:

    If i am to use two network interfaces, during installation, which should be my default network interface? The one connected to the internet or to the Local-Switch without the internet

    In this setup, you would have your primary NIC (you pick) configured for your imaging network. To install FOG you will need to know the name of this interface. For your imaging network interface you will NOT define a default gateway. On your business LAN interface you will define a default route to the internet. This is a standard configuration if you have an isolated imaging lan.


  • Senior Developer

    @Reuban1219 For this new error: Do you have spanning tree enabled in your network? Best to use RSTP (rapid spanning tree) as it usually doesn’t cause this problem.



  • @Sebastian-Roth Im sorry. I just realized that the installer was asking for my DHCP server address. Ive got that fixed. Now, currently:

    1. Installed Fog client in Windows 7 in another PC.
    2. Ive created image and host for windows 7 and also created a capture task.
    3. I booted into nic for my client. Everything goes fine now. But, now im getting error saying:

    Either DHCP failed or we were unable to access http://X.X.X.X/fog//index.php for connection testing.
    No DHCP response on interface eth0, skipping it
    Failed to get IP via DHCP! Tried on interface(s): eth0
    Please check your network set up and try again


  • Senior Developer

    @Reuban1219 said in Need Guidance Other Than FOG Wiki page.:

    For the DHCP & TFTP server, Debian 10.3 sources.list file are not reachable. I had this problem during my first time set up for Debian 10.3. I could not get updates. So, i edited the sources.list file with the latest links and sources so that it has DHCP and TFTP capabilities as well.

    Well that’s interesting. Can you post exact error messages or URLs (old and new). I can try to replicate the issue and see if there is something we can take care of in the installer.

    I guess in my understanding, since im already setting a default gateway and server IP addresses, i dont think i need to set router IP as well.

    Where did you set default gateway and server IP? Within the Debian Linux?

    As mentioned before this question on router address you get from the installer is not about the router/default gateway setting on your Linux system but only used for generating the DHCP configuration on your FOG server.



  • @Sebastian-Roth For the DHCP & TFTP server, Debian 10.3 sources.list file are not reachable. I had this problem during my first time set up for Debian 10.3. I could not get updates. So, i edited the sources.list file with the latest links and sources so that it has DHCP and TFTP capabilities as well.

    For the router,I just chose “No”. I guess in my understanding, since im already setting a default gateway and server IP addresses, i dont think i need to set router IP as well.


  • Senior Developer

    @Reuban1219 said in Need Guidance Other Than FOG Wiki page.:

    and updated all necessary files (DHCP & TFTP server)

    What do you mean by that? There is no need to and the installer will overwrite it anyway.

    3.As suggested by @Sebastian-Roth I have set my local network to have a static IP and my other connection is accessible to the internet. Now, When trying to install FOG(1.5.8). I am being prompted to choose my default network interface. I choose the LOCAL interface. Now, its asking for setup router interface. Do i say no or default(yes)?

    This question on router address might be a bit confusing. It has nothing to do with the interfaces or network setup on your FOG server but will only be used withing the DHCP config as router address for the clients.



  • @Sebastian-Roth @george1421 @Tom-Elliott Here is my current update.

    1. I have reinstalled Debian 10.3 into my CPU and installed and updated all necessary files (DHCP & TFTP server)
    2. I have set up two network interfaces. One is to the ethernet port of my office for updates and etc. Another is connected to a dumb switch( this switch is connected to my other CPU’s that I need to upload images from)
      3.As suggested by @Sebastian-Roth I have set my local network to have a static IP and my other connection is accessible to the internet. Now, When trying to install FOG(1.5.8). I am being prompted to choose my default network interface. I choose the LOCAL interface. Now, its asking for setup router interface. Do i say no or default(yes)?

  • Senior Developer

    @Reuban1219 Make sure you use FOG 1.5.8 on Debian 10!!

    There is no need to do the manual fixup you mentioned in your initial post and I am fairly sure this was due to using FOG 1.5.7 on Debian 10.


  • Senior Developer

    @Reuban1219 said in Need Guidance Other Than FOG Wiki page.:

    If i am to use two network interfaces, during installation, which should be my default network interface? The one connected to the internet or to the Local-Switch without the internet?

    Make sure both interfaces are up und configured with IPs before you Run the FOG installer. Use static IP, not DHCP, for the imaging interface. Make sure your internet connection works and then choose the imaging interface name when asked by the FOG installer.





  • @george1421 Okay,thankyou. If i am to use two network interfaces, during installation, which should be my default network interface? The one connected to the internet or to the Local-Switch without the internet?


  • Senior Developer

    @Reuban1219 said in Need Guidance Other Than FOG Wiki page.:

    Yes. I did build it myself based of the Fog Wiki page at the undionly build section.

    Can you please post a link to the exact wiki article you followed. Possibly there is an issue in that…

    Problems that I faced:
    -DHCP server didn’t want to turn on
    -TFTP server didn’t want to turn on
    -Link files from the FOG zip file was outdated therefore, I had to manually input Debian 10.3 links for drivers.
    -pxelinux files were missing
    -tftpboot files missing

    My guess is the installer ended prematurely and we should have looked at this instead of trying to manually fix all that. Probably 1.5.7 was used which came out long before Debian 10 and simply doesn’t work properly. 1.5.8 is out und you might download that und re-run the installer to fix all your issues in one go.


  • Moderator

    @Reuban1219 The fog server doesn’t need the internet access for operation only install and upgrades. But you did mention that you installed 1.5.7. I don’t think 1.5.7 supports installs on Debian 10.X . You should need FOG 1.5.8 for that. That is why I questioned about internet access,

    The second thing is that FOG doesn’t like it when you change the FOG server’s IP address after FOG is installed. There are several hard coded places where the install time FOG server’s IP address is added to the configuration. If you changed the fog server’s IP address after FOG was installed, that might also explain it not working 100%.



  • @george1421 Thank you. But, what if i have already updated and installed Fog to the latest version. Do i still need to be connected to the internet? Because from what I’ve read, FOG server can be run without internet to upload and export images.



  • @Tom-Elliott Yes. I did build it myself based of the Fog Wiki page at the undionly build section. And yes, I also rebuild the ipxe files after commenting them. Yet, i still get the same error.


  • Senior Developer

    @AlexPDX said in Need Guidance Other Than FOG Wiki page.:

    Hy …first of all I advise you to use CentOS 7 … Debian gave me many problems on this side of FOG :
    -web page did not want to start
    -TFTP server did not want to turn on …

    Would you mind sharing more details on this in another topic. We are happy to improve whatever there might be wrong but we really need more details!


  • Moderator

    If you need to setup an isolated imaging network, it is recommended that you use 2 network adapters in your fog server. One network adapter will be dedicated for imaging connected to the imaging network and the second network interface is connected to your business network. The FOG server NEEDS internet access to install and update FOG. If you don’t have internet access while installing fog, the install will fail.

    Without internet access I might think the configuration of your FOG server might be in the state you mentioned above.


Log in to reply
 

287
Online

7.5k
Users

14.6k
Topics

137.6k
Posts