Hard Disk not detecting in Think Station S30 model.



  • Hi,

    Recently we have purchased few machine of Lenovo [B]Think Station S30[/B] model.
    While we try to upload the image, FOG if not detecting the Hard Disk of this machine, gives error as “[COLOR=#ff0000]Hard Disk Not Found[/COLOR]”. Even when we try to register the host for inventory, it says “[COLOR=#ff0000]Hard Disk Not Found[/COLOR]”.

    For troubleshooting this, we found one thread from FOG saying “[I]Try Ubuntu and run one script and post the contents of that script in fog[/I]” so that they will provide a new kernel.

    But at this time we are not able to even install Ubuntu, Linux, fedora for executing that script.

    Finally, what we request is the solution on above error if any else can you please provide the Kernel file which includes the drivers of this new model.


    Chipset (PCH) Patsburg –A (Intel C602)
    Support for SAS HDD enablement module HW module to allow enablement of –B SKU

    Ethernet Intel Lewisville – 82579

    SAS Integrated with Patsburg –A + SAS HDD enablement module

    Processor Support Intel Xeon Quad Core (Sandy Bridge EP)
    Intel Xeon Six Core (Sandy Bridge EP)
    Intel Xeon Eight Core (Sandy Bridge EP)

    SATA/SAS (2) x SATA Connectors, Gen. 2 (AHCI)(2) x SATA Connectors, Gen. 3 (AHCI)
    (3) x SATA/SAS Connectors, Gen. 2 (SCU)
    * SAS drives on SCU require SAS HDD enablement module to function
    (1) x eSATA Connector, Gen. 2 (eSATA bracket)
    •SATA RAID 0,1,5 supported natively via Intel Controller
    •SAS RAID 0,1 and SATA RAID 0,1 supported via SAS HDD enablement module
    •SAS and SATA RAID 0,1,5 supported via LSI 9260-8i adapter
    •SAS and SATA RAID 0,1 supported via LSI 9240-8i adapter
    •SAS and SATA RAID 0,1,5 supported via LSI 9240-8i with key

    Storage – HDD/SSD

    3.5″ SATA Hard Disk Drive (HDD)
    500GB SATA – 7200rpm, 6Gb/s, 3.5″
    1TB SATA – 7200rpm, 6Gb/s, 3.5″

    LSI 9240-8i SATA/SAS RAID adapter
    Description: PCIe x8 adapter card
    Enables: Up to 8 SAS or SATA drives @ SATA3 (6GB/s) speeds, RAID 0,1 (RAID 5 supported with key)
    SAS HDD enablement module (1-3 drives)
    Description: S30 / C30 SAS HDD enablement module
    Enables: Up to 3 SATA or SAS drives at SATA2 (3Gb/s) speeds, RAID 0,1


    [url]http://thinkstation-specs.com/thinkstation-s30/#toc270[/url]


    Please find the attached file.

    Thanks in advance.

    [url="/_imported_xf_attachments/0/214_ThinkStation S30_Specs.zip?:"]ThinkStation S30_Specs.zip[/url]



  • Hello Jian and Chad,

    I am again facing one problem in [B]Think Station S30[/B] machine.
    Below is the scenario…

    SATA0–> 500gb HDD --> Total 2 Partitions ([COLOR=#ff0000]1st Partition Windows XP[/COLOR] and [COLOR=#0000ff]2nd Partition Windows 7[/COLOR])
    SATA1–> 1TB HDD-- Blank Disk

    Now I Uploaded the image by selecting [COLOR=#800080][B]Multiple Partition - All Disks. [/B][COLOR=#141414] Image uploaded successfully.[/COLOR][/COLOR]
    [COLOR=#800080][COLOR=#141414]Now when I deployed the image on same model machine, below is the scenario.[/COLOR][/COLOR]

    SATA0–> 500gb HDD --> Blank Disk
    SATA1–> 1TB HDD-- Total 2 Partitions (1st Partition Windows XP and 2nd Partition Windows 7)

    Not getting why fog had swapped the hard disk while deploying the image.
    I don’t know weather the problem is with Machine or the options I am selecting.
    Can anyone please help me.
    I have a stock of 200 machines pending due to this issue.

    Thanks,



  • Thank you very much Jian and Chad.

    Your efforts are really appreciated.
    The kernel you posted on FOG site is working for our Lenovo [B]Think Station S30[/B] model.

    Regards,
    Babasaheb.


  • Moderator

    Have you tried newer kernel from the kernel updates page on your fog web server? I think Jian just posted a new kernel a few days ago.



  • Hello Chad-bisd,

    Can you please help me in resolving this.



  • Thanks for your reply.

    Actually till yesterday, we were not able to install the Ubuntu OS, today we tried the latest Ubuntu i.e.12.0
    and we are successful in that.

    My problem is that I want to take image of my machine, for that when I try to boot machine and try to
    register a hot, it says [COLOR=#333399][B]Hard Disk not found.[/B][/COLOR]
    Even when I try to manually try to upload the image of my machine, it gives same error as above.

    I found the below mentioned link, and according to that I have upload the details of this machine.
    Can anyone please update me.

    [url]http://www.fogproject.org/wiki/index.php/Troubleshooting_Driver_Issues[/url]
    Thanks a lot.


  • Moderator

    Sorry. This statement in your original post confused me.
    [QUOTE]But at this time we are not able to even install Ubuntu, Linux, fedora for executing that script.[/QUOTE]

    So you have that issue resolved and can try an Ubuntu LiveCD?



  • Hi,

    I am able to install all the operating systems in this machine. ([I][COLOR=#ff0000]This is the latest model in Market[/COLOR][/I])
    Only the problem is that while uploading the image when we enter on “[COLOR=#993366][I]Register Host for inventory[/I][/COLOR]” fog says
    [B][COLOR=#333399]Hard Disk not found[/COLOR][/B].
    It Looks fog kernel is not having the required drivers of this model.
    Please see the attached file of machine configuration.

    Thanks,
    Babasaheb

    [url="/_imported_xf_attachments/0/215_Lenovo_ThinkStation-S30.txt?:"]Lenovo_ThinkStation-S30.txt[/url]


  • Moderator

    [url]http://www.zdnet.com/blog/open-source/linus-torvalds-on-windows-8-uefi-and-fedora/11187[/url]

    UEFI may be a problem. If you can’t even boot a liveCD, I don’t know where to start…


Log in to reply
 

417
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.