Issues with fog server



  • I am currently having an issue I have no idea what the cause could be. I first imaged 2 computer at once and it took about 17 minutes. I restarted the server hooked up another computer and tried to image three computers at once using multicast and it was telling me it would take 3 hours at this point i decided to check the servers transfer rates and it’s only sending 1mb a second where as before it was sending 30+mb a second. I am unsure whats the best way to figure out what the issue is and how to fix it.

    I have done the following so far:

    1. Replaced the switch
    2. Replaced all network cables with new ones.

    I would like to avoid having to reinstall the fog server if possible but it could be an issue with the hard drive in the server as that seems the most likely cause after everything I have done but am asking just in case it isn’t.



  • Well, today I had time to work on the project. First, the hard drive isn’t the issue and single cast deploy worked fine. Second, When I arrived on sight the lab was dismantled so I had to resort to using a Treadnet 10/100mbps 5 port switch connected to a Managed Cisco Switch which was also connected to a Cisco Router. I then proceed to request a managed switch for use however all that was around at the time was some old netgear switches which had been pulled from the active network for being unreliable and the other one was replaced as it only had 10/100 ethernet ports along with 2 10/100/1000 ports. The two gigabyte switches just didn’t want to work correctly so I decided to try the old 10/100 netgear switch and reset the settings but wasn’t able to access the webadmin panel for it as it seems I need to first console in and change some settings even thought I held the reset button on the front. I wasn’t able to find the needed cable in the storage room so I am assuming we know longer have it and doubt i’ll get the budget to replace it. At this time Multicast just seems to be unfeasible with the current equipment.


  • Moderator

    Can you give me a better idea of how you’re connecting the clients to the server? There may be some configurations to check on the switch to make multicasting more efficient.

    Are you connected between the clients and the servers through the same switch? Do you have VLANs configured? etc…



  • Well it seems weird that it worked well with two then all of a sudden it just decided to not work at all and transfer at 1mb a second.


  • group:cid:13:privileges:mods:members

    i’ve had real poor results multicasting as well. Imaging one computer with a 9.8 GB image I can do in less than 4 minutes to any machine via unicast. (10 gig backbone on the servers, 1 gig to the PC’s) If I image two computers with unicast at the same time, it jumps to about 6 minutes. If I multicast the same two computers, it takes about 2 hours. Though, if memory serves me correctly, I think switches need to be setup special to do this. I don’t configure the switches at my job, but I seem to remember multicasting being turned off. I’d check to see if you have a switch that supports this.

    Layer 3 Cisco switches can do this and are setup this way - [url]http://www.fogproject.org/wiki/index.php?title=Cisco_Multi_Cast[/url]
    Layer 2&3 Procurve (HP) can do this as well and need to be setup this way - [url]http://www.fogproject.org/wiki/index.php?title=HPMulticast[/url]



  • It’s on the school’s actual network and isn’t isolated. I’ll try what was suggested on monday.


  • Moderator

    Are you multicasting on a private/isolated network or one connected to your business/campus network?

    I tried multicasting back in Nov 2011, and I was not happy with it. I get better performance out of my setup if I just unicast to all the machines, even if using a private gigabit switch.



  • I will try both of those suggestions and get back to you. I won’t be on site to test this for a few days so expect a delayed response.



  • You can use hdparm to check the performance of your harddrive, try something like “hdparm -t /dev/sda”.
    Have you tried imaging the 3 computers without using multicast at the same time?


Log in to reply
 

385
Online

39.4k
Users

11.1k
Topics

105.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.