Exactly the same mistake.



  • Re: FOG initial images boots but cannot subsequently locate DHCP server

    Olá! Não sei se posso escrever no meu idioma. Se não, me perdoem.

    Pois bem, estou lutando há uma semana exatamente contra esse mesmo erro.
    Inclusive o DHCP utilizado é um PFSENSE, a máquina host um DEL Optiplex 7010 e o sistema servidor Ubuntu 18 e o FOG 1.5 .

    Ao iniciar o boot pela rede esse erro ocorre:

    Configuring (net0 00:1a:a0:xx:xx:xx)...... No configuration methods succeeded
    

    Depois de ocorrer novamente e surgir a opção Shell ‘s’, ao digitar ‘Ifconf’ ou ‘dhcp net0’ a interface ‘net0’ enfim é configurada:

    Configuring (net0 00:1a:a0:xx:xx:xx). . . . OK
    

    Após isso eu saio do Shell ‘exit’ e o host consegue acessar o ‘grub’ do fog. No entanto ao tentar o Full Registration ou o Quick Registration depois de vários ‘dhcp discover’ lançados esse erro ocorre:

    Either DHCP failed or we were unable to access http://192.168.50.15/fog/index.php
    

    Algo que não entendi é que aparentemente ele tenta configurar uma outra interface chamada eno1.

    O FOG Server está sendo executado em uma máquina virtual. Minha rede é toda segmentada em VLANS. A configuração das opções 66 e 67 já foram feitas na VLAN. Em uma determinada VLAN eu trabalho muito bem com o FOG. Não sou das redes mas pelo que me relataram essa VLAN é conectada diretamente nos DATACENTERS, já a VLAN que não consigo trabalhar com o FOG tem Switchs e patch panels. Dessa VLAN consigo acesso a interface web normalmente. Também me disseram que é utilizado o protocolo MVSTP.

    Eu não consegui entender a solução para esse problema. Se puderem me ajudar agradeço muito!


  • Developer

    @Sckendall I am using English to answer as you can probably read it or use a translate service. Usually we prefer English as it’s a common language for all users and others might find this helpful too. I do understand it might be easier and more to the point when using your native language.

    Configuring (net0 00:1a:a0:xx:xx:xx)...... No configuration methods succeeded
    ...
    ipxe> dhcp net0
    Configuring (net0 00:1a:a0:xx:xx:xx).... OK
    

    This is very likely a problem of spanning tree on your switch. Spanning tree is activated on many switches to prevent from loops in a network. That’s usually a good idea but often causing problems with PXE if people don’t know enough about spanning tree. You have three options:

    • Use Rapid Spanning Tree Protocol (RSTP)
    • Enable so called “fast port” option on the ports where you have clients connected to - make sure to only enable it on those and not on every port or spanning tree will be useless
    • Disable spanning tree protocol on the switch - only do this if you really understand the whole situation and made sure this particular switch is never going to be in a loop!

  • Moderator

    @Sckendall Yes start a new topic, they are free and keep problems and solutions together with the subject of the thread.


  • Developer

    @Sckendall Best to create a new topic.



  • @george1421,

    I have another problem on a different subnet. “TFTP open time out …”. I’m searching the forum and there are several topics, but I still don’t understand the solution. I don’t know if you could help me around here or would I need to create another topic?



  • @george1421, well, i think i understand now.


  • Moderator

    @Sckendall said in Exactly the same mistake.:

    So when enabling port fast on a particular port, am I enabling RSTP at the same time?

    Yes, RSTP is an extension of STP. I assume in the web ui its a radio button in that you can select STP or port fast (another name for RSTP). We are saying the same thing, I was just concerned about someone following this thread in the future when you said “turn off STP”. Its not a good idea to ever turn off spanning tree on user facing network ports. Users do dumb things every so often.



  • @george1421

    Well, that’s what the person from the networks told me.

    So when enabling port fast on a particular port, am I enabling RSTP at the same time?

    From what I saw in the management of the Switch, there are two options to check, () STP and just below () Fast Link. From what I was told, the STP option was deselected and Port Link was checked


  • Moderator

    @Sckendall said in Exactly the same mistake.:

    apparently the solution is between disabling STP and enabling port fast.

    Just to be clear because others may get confused. You did not disable STP and enable port fast, but you turned on port-fast features which changed STP to RSTP (rapid spanning tree).

    STP is still enabled, but its using optimistic blocking (hope there is no loop back while checking - rapid spanning tree protocol) instead of pessimistic blocking (assume there is a loop back while checking - standard spanning tree protocol).



  • Thank you guys! It worked here.

    Initially we deactivated STP and activated port fast on a swicht port and it worked very quickly.

    Apparently the solution is between disabling STP and enabling port fast. We will do more tests later to see which solution is most ideal.

    I believe that this issue can now be marked as resolved!



  • @george1421, Thank you! I will try this now.


  • Moderator

    @Sckendall MSTP should be an extension to RTP with the option of having multiple STP zones. BUT not all switch manufacturer implement it the same way. Some when you turn on MSTP, RTP features are enabled other MSTP is just a multizone extension to STP, where the fast spanning tree needs to be enabled separately.

    Or to say it with less words MSTP !(always)= Multizone RTP. Check with your switch manufacture if you need to enable the port_fast equivalent with MSTP.


  • Developer

    @Sckendall While I have worked with STP and RSTP I don’t know too much about MSTP. Searching the web I found this: https://www.arubanetworks.com/techdocs/ArubaOS_74_Web_Help/Content/mas_guides/mstp/Portfast.htm

    When the link on a bridge port goes up, MSTP runs its algorithm on that port. If the port is connected to a host that does not “speak” MSTP, it takes approximately 30 seconds for the port to transition to the forwarding state. During this time, no user data passes through this bridge port and some user applications may timeout.



  • @Sebastian-Roth

    Thank you very much for the quick response. Well, I will try to use the google translator to comment.

    As reported to me, our network makes use of the MSTP. I thought that with this protocol, no port fast configuration would be necessary. Although I don’t understand how to implement it on my network.

    However on Monday when I get back to work I will try this as a network person.

    Thank you!


  • Developer

    @Sckendall I am using English to answer as you can probably read it or use a translate service. Usually we prefer English as it’s a common language for all users and others might find this helpful too. I do understand it might be easier and more to the point when using your native language.

    Configuring (net0 00:1a:a0:xx:xx:xx)...... No configuration methods succeeded
    ...
    ipxe> dhcp net0
    Configuring (net0 00:1a:a0:xx:xx:xx).... OK
    

    This is very likely a problem of spanning tree on your switch. Spanning tree is activated on many switches to prevent from loops in a network. That’s usually a good idea but often causing problems with PXE if people don’t know enough about spanning tree. You have three options:

    • Use Rapid Spanning Tree Protocol (RSTP)
    • Enable so called “fast port” option on the ports where you have clients connected to - make sure to only enable it on those and not on every port or spanning tree will be useless
    • Disable spanning tree protocol on the switch - only do this if you really understand the whole situation and made sure this particular switch is never going to be in a loop!

Log in to reply
 

369
Online

6.6k
Users

14.0k
Topics

132.3k
Posts