Task not starting



  • Hi all,

    I set up a fog server on a LAN with a DHCP already present.
    (the fog server - where I installed the webUI - keeps the tftp server, but not the dhcp nor the dns server)
    To the existend DHCP I added the following entry:

    host inst2 {
    option host-name “inst2”;
    hardware ethernet 00:12:14:1A:44:d3; #inst2
    next-server 1.2.3.4;
    filename “pxelinux.0”;
    fixed-address 1.2.3.5;
    }
    where 1.2.3.4 is the static IP of my fog server and 1.2.3.5 the IP assigned via DHCP to the client.
    Now, when powering on the client, it boots the "FOG Computer Cloning Solution’, which
    by default boots from the existing OS installed (a Windows 7 I want use to get the image).
    From the FOG WebUI Hot Management - List all hosts - inst2 - basic task I set up a basic task
    “Upload” to upload an image (I already defined an image) and Fog puts the task on queue.
    (Task management - Active task show the upload task requested for inst2)
    When I reboot inst2 I keep seeing the “FOG computer cloning solution” windows, which
    as default boot the local OS: what am I doing wrong?
    It seems the active task cannot be activated on my client :-(
    any idea?


  • Moderator

    There are a few things I would look at here.

    1. pxelinux.0 is not used for FOG for almost 8 years. pxelinux.0 is typically a boot loader for syslinux and not iPXE (what fog uses). The default bios ipxe boot loader is undionly.kpxe, for uefi its ipxe.efi.
    2. FOG is not your dhcp server and that is OK. It does appear that you are using isc dhcp server. If you were to pick FOG as your dhcp server it also would use iscp dhcp. An example configuration file for isc-dhcp is here: https://wiki.fogproject.org/wiki/index.php/BIOS_and_UEFI_Co-Existence#Example_1
    3. Another option is to not have your dhcp server issue boot file names, but install and configure dnsmasq onto your FOG server. Let your main dhcp server issue the ip and network configurations, and let dnsmasq supply only the pxe boot information. There is a tutorial here on how to set it up: https://forums.fogproject.org/topic/12796/installing-dnsmasq-on-your-fog-server

    So to your problem. Did you pick register the host when you first went to the iPXE FOG menu? That will create a host management page. You will next need to create an image definition page to describe the image you want to capture. Then go back to the host definition page and link the image to the host. Once you save the setting then from the host definition page you can pick capture image. On the next pxe boot FOS Linux (the engine that runs on the target computer that captures and deploys images) and your target computer’s hard drive should be uploaded to the FOG server. If the task can not be activated on the fog server, is there an error message displayed when you schedule the task?


Log in to reply
 

369
Online

6.5k
Users

13.9k
Topics

131.3k
Posts