Web Gui



  • I cannot get Fog to display the web gui using the IP address. I get the following message.
    [SIZE=6][B][FONT=Times New Roman][COLOR=#000000]It works![/COLOR][/FONT][/B][/SIZE]

    [SIZE=4][FONT=Times New Roman][COLOR=#000000]This is the default web page for this server.[/COLOR][/FONT][/SIZE]
    [SIZE=4][FONT=Times New Roman][COLOR=#000000]The web server software is running but no content has been added, yet.[/COLOR][/FONT][/SIZE]


  • Senior Developer

    Or go to the proper link displayed at the bottom of the installer:

    [url]http://10.0.0.10/fog/management[/url] for example.


  • Developer

    You can also edit your apache settings to prefer the php file over the html file.



  • alternately change /var/www/index.html to /var/www/index.old.html.

    FOG adds the index.php to the /var/www folder but doesn’t remove the index.html. Unfortunately Apache’s default page entry looks for index.html before it looks for index.php. If index.html (the “It works!” page) exists it shows that regardless if the index.php (the fog redirector) exists or not. renaming it causes the index.php to be shown and for the redirection to happen properly.

    Stephen.



  • Great Thanks. Worked Perfectly.


  • Developer

    change /var/www/index.html to:

    <html>
    <head>
    <meta http-equiv=“Refresh” content=“0; URL=fog/index.php”> </head> </html>
    otherwise just add /fog in the address bar


Log in to reply
 

460
Online

39010
Users

10725
Topics

101896
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.