Setting FOG in ESXi 6.7u2



  • Hello,

    I am trying setup fog in a VM nested in my ESXi.
    after installing fog and trying PXE a vm running the windows i want to capture… i get booted into VM Bios constantly. Looked like i have misconfigured somewhere.

    I read somewhere home routers are not able to to PXE redirection (unless on merlin or DDWRT). So i ended up enabling DHCP server on my FOG vm.

    Do bear with me as my network knowlage is not strong.



  • posting an update that it worked in the end. (somehow the VM i created as test used another SCSI adaptor and it didn’t play well)

    The settings that are default for a Win10 x64 still needed secure boot to be turned off.

    For those who might venture, here’s my settings for my clients.
    c6256d12-e5ba-4d91-b883-b1e54550e56a-image.png
    ed58e765-7d34-451a-a128-f5a13a30a316-image.png

    Time for some NAC + Jumpcloud + Chocolatey fun



  • @george1421 said in Setting FOG in ESXi 6.7u2:

    DNSMASQ

    Just to update i managed to do BIOs boot and capture the image. (would do more self digging and see why my ESXi VMs refuse to PXE in EFI bios)



  • @george1421 thank you for the advise. My home router is a Asus AC88u (stock FW).
    I’ll give it a go, and update if it works or not.


  • Moderator

    @felix_fx2 What I would do is remove dhcp from your FOG server and install dnsmasq on your fog server. DNSMASQ configured correctly will only provide pxe boot information with the rest of your settings coming from your soho router. The instructions for dnsmasq setup can be found here: https://forums.fogproject.org/topic/12796/installing-dnsmasq-on-your-fog-server

    I use dnsmasq on my home raspberry Pi3 FOG server because my home router doesn’t support pxe booting at all.


Log in to reply
 

397
Online

7.4k
Users

14.5k
Topics

136.7k
Posts