Unable to update database after capture



  • Hi

    Having an issue when i try and capture an image, it goes through the whole process ok but at the end when it tries to update the database it fails, saying login incorrect. I have attached some photos of the error.

    I recently migrated my fog server to another server and it all seemed to be working fine, well in terms on pushing out an image to PCs, i think this is the first time i have tried to capture an image since, so im thinking there maybe be conflict of settings for the database, from the old server to the new server but i dont know where to look.

    Anyone got any ideas why this is happening?

    Thanks!

    IMG_0435.JPG IMG_0434.JPG IMG_0433.JPG


  • Moderator

    @Peter365 I’ve got a different tutorial, lets run through this and see if we can resync the passwords. Something has gone astray with the service account: https://forums.fogproject.org/topic/11203/resyncing-fog-s-service-account-password

    When you complete the process, you should be able to log into the FOG server using command line FTP from a windows computer (Filezilla should work too, but I’ve only tested with command line ftp). Use the user id of fogproject and the password found in the /opt/fog/.fogsettings file. If you can get logged in via FTP with that account and you have all of the spots in the web ui matching, the capture should work well.



  • @george1421 Hey George, sorry for the late reply, work has been closed for Christmas, first day back now.

    That has worked, followed those instructions and reran the fog setup and now i can upload images without any issues.

    Many thanks,
    Pete


  • Moderator

    @Peter365 I’ve got a different tutorial, lets run through this and see if we can resync the passwords. Something has gone astray with the service account: https://forums.fogproject.org/topic/11203/resyncing-fog-s-service-account-password

    When you complete the process, you should be able to log into the FOG server using command line FTP from a windows computer (Filezilla should work too, but I’ve only tested with command line ftp). Use the user id of fogproject and the password found in the /opt/fog/.fogsettings file. If you can get logged in via FTP with that account and you have all of the spots in the web ui matching, the capture should work well.



  • @Sebastian-Roth Tried logging in with filezilla and just get the same, login incorrect


  • Senior Developer

    @Peter365 Have you tried to login via FTP e.g. using FileZilla from another machine? Does it work?



  • Thanks for that.

    I have changed all the usernames and passwords for these so that they match:

    There are a few places where all the credentials (on a standard install) should match exactly.
    
    Web Interface -> Storage Management -> [Your storage node] -> Management Username & Management Password
    Web Interface -> FOG Configuration -> FOG Settings -> TFTP Server -> FOG_TFTP_FTP_USERNAME & FOG_TFTP_FTP_PASSWORD
    The local 'fog' user's password on the Linux FOG server
    Server file: /opt/fog/.fogsettings -> password (For recent FOG Trunk versions only. 1.2.0 does not have this setting. 1.3.0 will though.)
    Server file: /opt/fog/.fogsettings -> username (For recent FOG Trunk versions only. 1.2.0 does not have this setting. 1.3.0 will though.)
    All of those should match (again, on a standard installation).
    

    but im still getting an error saying login Incorrect, is there anywhere else that may need changing?


  • Senior Developer


Log in to reply
 

410
Online

7.4k
Users

14.5k
Topics

136.5k
Posts