Unable to boot to pxe server



  • For some reason I time out at my tftp server not reaching the fog pxe boot screen. I had to use these custom options on my dhcp server and am not sure if i have the right path or file here are two options.

    option bootfile-name “pxelinux.0”; <-------------------- ?
    option tftp-server-name “192.168.0.3”;

    option tftp-server-name “[url]http://$192.168.0.3[/url]”;
    option bootfile-name “download/snom/{mac}.html”; <-----------------?

    Also when ever im on the fog web interface and try to upload an image from a host it just says its queued
    Server: Ubuntu 12.10 with fog v0.32
    Dhcp server: Endian Firewall



  • Right now have successful tftp get pxelinux.0 on my remote machine but when I try to boot it the dhcp the request times out, I did not set the IP for the dhcp server during the fog set up how can I change it?


  • Moderator

    From a windows machine, you can test tftp if you add the tftp client windows features from add/remove programs.

    something along the lines of: tftp get [IP of FOG server] pxelinux.0.

    You may also try the help forums for Endian Firewall for your version to see if they can help configure a PXE boot server. Also, there may be an upgrade to the firewall software version that fixes or adds the features you need.



  • How can i confirm that its working correctly, when i try to scheduled a task on a host it says unable to connect to the tftp server, im wondering if there is any other configuration needed for this program.

    im gona try [url]https://help.ubuntu.com/community/Dnsmasq[/url] this tutorial for the installation this time and see if I get better results



  • Step 5 is editing the file /etc/exports, to do this from the console/command line:
    sudo nano /etc/exports
    (or if you’re logged in as root: nano /etc/exports )
    You will then be prompted for your password (unless you’re logged in as root)
    Copy/write the lines given in step 5 into the editor, press CTRL+X to exit then Y to save.



  • [LIST=1]
    []First get your desired linux flavor installed
    [
    ]Install FOG (use instructions on wiki user manual)
    []Make sure you do a normal server installation, don’t setup a DHCP router address or a DNS server address, also don’t use FOG as a DHCP server.
    [
    ]If you set a MySQL password make sure you change it in /var/www/fog/commons/config.php and also in /opt/fog/service/etc/config.php
    [*]Edit /etc/exports to look like this:
    /images *(ro,async,no_wdelay,insecure_locks,no_root_squash,insecure)
    /images/dev (rw,async,no_wdelay,no_root_squash,insecure)
    [
    ]Install dnsmasq using:
    sudo apt-get install dnsmasq
    [/LIST]
    Im confused with step 5 could some one clarify what exactly it means?


  • Moderator

    [url]http://askubuntu.com/questions/140126/how-do-i-configure-a-dhcp-server[/url]

    You can use [CODE]sudo service isc-dhcp-server stop[/CODE] to stop the dhcp server on FOG. Check that your DHCP config on the endian firewall is working by passing the bootfile name and next server ip address properly. If it is, then just uninstall the DHCP server on FOG. If it’s not and you can’t figure out how to make the endian firewall work, you can use ProxyDHCP, or you can swap DHCP functionality over to your FOG server and disable DHCP server on the endian firewall.

    Depending on who controls your network, how complex the setup is, and your DHCP needs, it may be easier just to let the FOG server handle DHCP and disable it on the firewall.


  • Moderator

    Right. you can’t have two DHCP servers that serve the same subnet without some advanced configurations. If it’s working, just turn off DHCP server on your FOG server temporarily. Depending on the OS distribution and version, the DHCP server will have different names.

    You do have a fallback plan if you just can’t get your existing DHCP server to direct clients to FOG and you can’t use FOG as a DHCP server. It’s called ProxyDHCP and isn’t all that complicated to setup. There is an excellent article on the wiki I helped create based on my experiences with ubuntu 10.04 LTS Server.



  • so just an update re installed fog and enabled its dhcp, it worked but then I believe it conflicted with my already existing dhcp and stoped working.


  • Moderator

    generally you just tell the DHCP server to point clients to “pxelinux.0” since the tftp root directory is /tftpboot/, that is the default folder it will look in.



  • So should i just point it at /tftpboot or /tftpboot/pxelinux.0 or just /pxelinux.0.
    Also should I have the fog server set up as a dhcp server even though its not used for primary use, just for pxe? and off the top of your head can you remember the commands to start/restart the tftp service?


  • Moderator

    the bootfile name is pxelinux.0 that is a ZERO not capital o.
    tftp-server-name should be the IP address of the FOG server.

    If you’ve done this, make sure TFTP is running on the server, as 12.04 has a bug where it tries to start tftpd before the NIC interface has an IP address and it can’t bind properly. Stopping and starting the tftpd fixes it.



  • This post is deleted!

Log in to reply
 

349
Online

39.5k
Users

11.1k
Topics

105.7k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.