Xps15 Fail to deploy image - Ipxe / Uefi



  • I’ve changed on my dhcp server the options 67 to ipxe.efi
    Only the Dell xps 15 fail to deploy, all other laptops work perfectly

    I’m using a belkin and dell usb-c adapters and the kernel 5.1.16 Fog version 1.5.7.5
    Installed also the dnsmasq, the service is up, but apparently during a boot use only the dhcp options from my router(peplink 780)

    This error occur after boot and set deploy image, what can i do?

    IMG_20191212_183428.jpg

    DnsMas config

    # Don't function as a DNS server:
    port=0
    
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    listen-address=127.0.0.1
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,,172.16.200.90
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    dhcp-match=set:bios,60,PXEClient:Arch:00000
    dhcp-boot=tag:bios,undionly.kpxe,,172.16.200.90
    
    dhcp-match=set:efi32,60,PXEClient:Arch:00006
    dhcp-boot=tag:efi32,i386-efi/ipxe.efi,,172.16.200.90
    
    dhcp-match=set:efibc,60,PXEClient:Arch:00007
    dhcp-boot=tag:efibc,ipxe.efi,,172.16.200.90
    
    dhcp-match=set:efi64,60,PXEClient:Arch:00009
    dhcp-boot=tag:efi64,ipxe.efi,,172.16.200.90
    
    # inspect the vendor class string and match the text to set the tag
    dhcp-vendorclass=BIOS,PXEClient:Arch:00000
    dhcp-vendorclass=UEFI32,PXEClient:Arch:00006
    dhcp-vendorclass=UEFI,PXEClient:Arch:00007
    dhcp-vendorclass=UEFI64,PXEClient:Arch:00009
    
    # Set the boot file name based on the matching tag from the vendor class (above)
    dhcp-boot=net:UEFI32,i386-efi/ipxe.efi,,172.16.200.90
    dhcp-boot=net:UEFI,ipxe.efi,,172.16.200.90
    dhcp-boot=net:UEFI64,ipxe.efi,,172.16.200.90
    
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client", 1
    
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi
    
    dhcp-range=172.16.200.90,proxy```

  • Moderator

    @Schuede said in Xps15 Fail to deploy image - Ipxe / Uefi:

    listen-address=127.0.0.1

    Sebastian, good point I skipped right over that. In this case that command is telling dnsmasq to bind to the loopback interface. So only DHCP DISCOVERS on the loopback interface would get a response. Probably not what the OP wants. While that’s not the issue in the picture it would be the cause of the other issues reported.


  • Senior Developer

    @Schuede said in Xps15 Fail to deploy image - Ipxe / Uefi:

    listen-address=127.0.0.1

    Why listen to localhost only?

    You need to decide if you want your router to serve PXE booting information to your clients or if dnsmasq should be doing it. Using both might cause some trouble.


  • Moderator

    I guess a couple of questions to start off with.

    1. In regards to dnsmasq, is the fog server on the same IP subnet as your pxe booting computer? If they are on different subnets then you will need to add the fog server’s IP address as the last address in your vlan router’s dhcp-helper/relay service.
    2. What chipset is in that USB NIC? If you don’t know go into the windows device manager and pots here the hardware ID we’ll need the vendor and device IDs.

    While its not as clean of an answer, if you were to manually register that target computer with the fog server. Then schedule a deploy task to that computer, but before you hit the schedule button, tick the debug check box. Now pxe boot the target computer. After a few screens of text on the target computer that you will need to clear with the enter key, you will be dropped to the FOS Linux command prompt. At the FOS Linux command prompt key in lsusb and post the results here (picture). That will give us the codes if FOS Linux sees the network adapter. I guess the output of this command would be handy too ip addr show


Log in to reply
 

222
Online

7.2k
Users

14.4k
Topics

135.6k
Posts