SOLVED Can't get image uploaded

  • IMG_4605.jpg Fails out at moving the image over from /image/dev/macaddress to wherever. Fresh install on Fedora 30(or whatever latest flavor is).

    Have checked username and password for storage node, tftp, .fogsettings

    see attached error message. ![alt text](![0_1575320281111_IMG_4605.HEIC](Uploading 98%) image url)

  • Moderator

    @amc123 If this is a relatively fresh install of FOG I’d start from scratch (really by re-installing the OS).

    Then use the latest version from github dev-branch which has the fix for VSFTPd on Fedora 30 already.

  • @Sebastian-Roth

    I messed with the password to set it in all places. Would you recommend starting all over with a fresh install from git?

  • Moderator

    @amc123 said in Can't get image uploaded:

    connection failed, OOPS, TCP_wrappers is set to yes, but no tcp wrapper support compiled in.

    Ahh right, forgot about this issue i Fedora 30, sorry. Edit /etc/vsftpd/vsftpd.conf and set the line tcp_wrappers=no. After that run systemctl restart vsftpd.service.

    Password is password, if that matters

    That should NOT be the case unless you have messed with the fogproject account. This is a service account and you are not meant to mess with it!!! Take a look at /opt/fog/.fogsettings file to see what password the account should have (line password=).

  • [02-Dec-2019 20:50:32 UTC] PHP Notice: FTP connection failed in /var/www/html/fog/lib/fog/fogftp.class.php on line 219

    error message changed in log file

    did the tutorial to sync up the passwords and chown fogproject

  • Password is password, if that matters.

  • using winscp

    sftp to ip address of fog server, port 22 error is recieved too large sftp packet.
    plain ftp, no encryption, port 21: connection failed, OOPS, TCP_wrappers is set to yes, but no tcp wrapper support compiled in.

    Opening browser brings up nothing.

    Getenforce: permissive

    systemctl status vsftpd.service:
    Green Active (running)

  • Moderator

    @amc123 Run chown -R fogproject:fogproject /images (as root) on your FOG server. That might help.

    If it doesn’t solve the problem I may ask you to run the following commands and post output here:

    ls -alR /images
  • Moderator

    @amc123 There may be some value in having you run through this tutorial:

    Just to make sure all of the passwords are in a sane state.

    Also you should test to see if you can log into your fog server using a microsoft windows ftp client. Login using fogproject and the password found in the .fogsettings file. If you can do that and the permissions are set correctly on the /images director it should work.

    here is a test script to confirm if the directory permissions are right.,

    Login using the ftp client to the fog server. Once logged in using ftp key in

    cd /images
    mkdir test

    if the test directory is created in /images then the permissions are right, finish by cleaning up

    rmdir test

    It may be quit instead of exit. I don’t remember which.

  • php log file error:

    Screen Shot 2019-12-03 at 11.13.32 AM.png

  • I changed the username to match up everywhere and set write rights.

    Latest version of everything, FEdora server and Fog.

    Just reinstalled fog with fogproject and password set in settings file and changed in storage node and tftp. Same error. Creates image on /dev with mac address, but can’t get it copied over at the end.

  • Moderator

    @amc123 Not exactly sure which version of FOG you run. The init version and ramdisk_size make me think this should be 1.5.7 but Username: fog tells me it’s 1.5.6 or older. If you really use FOG 1.5.7 then something went wrong and you need to manually set the username (web UI -> Storage node settings -> Management Username) to fogproject. This was changed from version 1.5.6 to 1.5.7…

    Usually not something you should have to mess around yourself. The installer should take care of this. But seems like it didn’t or someone messed with it.