Fog waits for command on Deploy



  • Hi there everyone.

    I’ve got fog installed and running perfectly on 5 laptops at home. Each laptop has its own image and for a while, all was well. However, one of my laptops has started to not deploy properly.

    What happens once a deploy is scheduled and the machine is turned on appears normal. It boots from PXE, displays the FOG TFTP prefix: screen where it lists a few errors (that have always been there and there on the other 4 laptops) … then stops.

    It reads;

    [quote]
    FOG FOG FOG FOG
    TFTP prefix:
    Trying to load : pxelinux.cfg/00bf56fe-550a-df81-2f6f-e0cb4e88a7bb
    Trying to load : pxelinux.cfg/01-e0-cb-4e-88-a7-bb
    Loading fog/kernel/bzImage…


    Loading fog/imags/init.gz…
    …ready.
    [ 0.504051] tps65010 : no chip?
    [ 0.896509] acpiphp_ibm : ibm_acpiphp_init : acpi_walk_namespace_failed
    [ 0.504051] tps65010 : no chip?
    [ 0.896509] acpiphp_ibm : ibm_acpiphp_init : acpi_walk_namespace_failed
    [ 0.898344] nvidiafb: unknown NV_ARCH
    [ 0.899360] Could not find Carillo Ranch MCH device.
    [ 0.899675] uvesafb : failed to execute /sbin/v86d
    [ 0.899745] uvesafb : make sure that the v86d helper is installed and executable
    [ 0.899827] uvesafb : Getting VBE info block failed (eax=0x4f00, err=-2)
    [ 0.899898] uvesafb : vbe_init() failed with -Z2
    [ 1.9689771] dr./i810 does not support SMP
    [ 2.075008] [drm] nouvea 000:01:00.0: Pointer to BIT loadval table invalid
    [ 5.248408] Error: Driver ‘mdio-gpio’ is already registered, aborting…
    [ 5.255162] cs89x0: request_region(0x320, 0x10) failed
    [ 5.256990] LocalTalk card not found; 220 = ff, 240 =ff.
    [ 5.344055] wistro_btns: system unknown
    [ 5.346386] acer_wmiL bno or unsupported WMI inferface, unable to load
    [ 5.346400] acerhdf: unknown (unsupported) BIOS version TOSHIBA/Satellite U500/1.90, please report, aborting!

    [/quote]

    then it sits there waiting for me to type something.

    The strange thing is - I can make more ‘backups’, just not deploy to this machine.

    Any help would be extremely grateful. The other 4 still work a treat… :-z



  • Hi there. Sorry for the massive late reply - this hasn’t fixed the issue. There were no processes waiting or clogging up the system. :-z

    When i type ‘fog’ and hit enter whilst on that screen, it loads for a second then reads;

    "Cannot read "/proc/partitions". (No suck file or directory). Then, you must use the command line to run Partition Image. Type 'partimage--help' for help."  
    

    then;

     You haven't accss to /proc/mounts.
    

    Any ideas?

    The youtube video above is still happening (even when I’ve tried reformatting the laptop, re-uploading it to a new image/host - and when i try using an existing image that works on other laptops of the same make/model).



  • This post is deleted!


  • Thanks for the reply - I will try that this afternoon and let you know how it goes.


  • Moderator

    It looks like you have a task scheduled still. If you can see it under active tasks, then “kill” it using the web interface. If you don’t see it listed, then remove the file from the fog server in /tftpboot/pxelinux.cfg/01-[mac-address-of-machine]



  • Can anyone throw any ideas my way? Need to get this laptop back in the game asap.



  • Strange update – I deleted both the image and host from fog, reformatted the laptop again installed drivers/programs and went to start it to do a host import. This time, even though there was no scheduled task, or even host registered via FOG for that address, instead of displaying the fog menu, it did the same as my OP.

    Here’s a video of it doing its thing. I get typing commands so I did a ‘dir’ to see where it was stopping or starting from…

    [media=youtube]NU59YXyRl60[/media]

    help?



  • I’ve tried reformatting the toshia manually and making a new image for it - but i still can’t deploy on to it.

    Bios has been reset (and PXE put as first load point), there are no logs that I can find that display anything either.

    bit of a strange one. :s


  • Moderator

    I don’t know for certain, but you may want to see if the host record in fog has any kernel settings or arguments that are different. Make sure the image id and OS id are set. If that doesn’t help, I’d chkdsk /f and defrag and try again.


Log in to reply
 

423
Online

38715
Users

10543
Topics

99813
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.