UEFI PXE boot works, but asks for tftp address



  • I have option 66 and 67 set, and previously remember using rom-o-matic site to make a few changes that fixed this. Now that the site is down, how do I go about fixing this issue?

    Most of my machines are still using legacy boot, but I want to get ready for when that changes soon.



  • Just in case anyone finds this later, ended up using dnsmasq to make my configuration work using @george1421 's tutorial here: https://forums.fogproject.org/topic/12796/installing-dnsmasq-on-your-fog-server

    Mine was a bit more complicated because I’m running an older version on ubuntu, but @george1421 's tutorial is spot once I got all the other weird things I had to do done lol.



  • Just in case anyone finds this later, ended up using dnsmasq to make my configuration work using @george1421 's tutorial here: https://forums.fogproject.org/topic/12796/installing-dnsmasq-on-your-fog-server

    Mine was a bit more complicated because I’m running an older version on ubuntu, but @george1421 's tutorial is spot once I got all the other weird things I had to do done lol.


  • Moderator

    @jcook OK here is the tutorial you can use: https://forums.fogproject.org/topic/9673/when-dhcp-pxe-booting-process-goes-bad-and-you-have-no-clue

    Now if the fog server and target computer are on the same subnet then you can use tcpdump on the fog server. Or you can use wireshark with this capture filter udp port 67 or udp port 68 using a witness computer on the same subnet/vlan as the target computer.

    What you are looking for is this.

    1. There should be a DISCOVER dhcp packet from the target computer.
    2. There should be one OFFER packet. That should come from your dhcp server. If you have more than one OFFER packet, that means you have a second dhcp server, or a proxydhcp server running that is supplying supplemental boot information that we’ll need to dig into.

    In the OFFER packet from the dhcp server look into it there should be fields for next server and boot file in the ethernet header. Down in the dhcp options these will be dhcp options 66 and 67.

    If you get lost, upload the pcap file to a file share site and IM me the link and I’ll take a look at it for you.



  • I am OK at wireshark, I’ll give it a shot! Thanks


  • Moderator

    @jcook If you can navigate with wireshark I can give you a tutorial that will help you debug this pretty quickly if you need it.



  • I can do a capture, but I’m guessing it might have to do with vlans, and each having its own DHCP? I can add the option 66 to the others and see if it helps maybe?


  • Senior Developer

    Typically when people get this, there’s usually a rogue dhcp server sitting on the network. This causes the TFTP gathering of the boot information to fail and become blank, hence why it’s asking you for the address.

    Can you verify your network indeed only has one DHCP server? This may require getting pcap information from wireshark and allowing one of our great people to look at it to help figure out the cause of the problem.

    Thank you,


Log in to reply
 

329
Online

7.4k
Users

14.5k
Topics

136.5k
Posts