WOL on Ubuntu 18.04 with 2 nics



  • Hi,

    My fogserver is on Ubuntu 18.04 with two nics. One is for the fog server (eth0:10.100.20.x) and the second is for internet access for the machine (eth1: 10.100.10.x).

    I have tried Wake-up a client machine on Basic Tasks and on Power management to schedule the task, it goes green but it doesnt do anything.

    I’ve read that it might have something to do with /etc/hosts/ but Im not sure what to do there. Does anyone know how to do this?

    Thank you




  • Developer

    @chasosnature This has nothing to do with this topic on WOL as far as I see. Please open you own topic and post all your details: FOG version, OS version, steps you took, errors and so on.



  • This post is deleted!

  • Developer

    @chasosnature Which scripts do you mean??



  • do you mind me asking how did you get FOG to work on ubuntu 18?
    all my scripts are empty, should it still image with the post, download and other script empty…it was empty by default after installation

    please advice



  • Hi guys,

    Thanks for all the help. I think I’ve figured out what the problem is.
    I’ve tried WOL on another type of computer “Lenovo”, it it works perfectly.

    The computer I was trying wake on lan before was a SuperMicro. I think the nic needs pcie power and that certain computer doesnt have any.



  • @jdriz
    Have you attempted to manually wake the machines? It isn’t installed as part of FOG, but wakeonlan should be available for installation through your distribution’s package management system. I believe the syntax is wakeonlan <mac address>
    What model machines are the clients? Some manufacturers (notably Dell) have other settings besides wake on lan that need to change for wake on lan to function correctly.

    Edit: You may need to add the -i <ip address> argument if your default route is to eth1. The IP address in this case could be 10.100.20.255 (directed broadcast address for your client network).


  • Moderator

    @jdriz Does WOL work correctly if the computers are unplugged, wait 10 seconds then plug back in. Then issue the WOL command?



  • Are the nics in the server on different networks they are both on 255.255.255.0

    In which network are your clients? My clients are in the eth0 network (10.100.20.x)

    Do the clients actually wake up when the task is scheduled The task can be scheduled but the client does not wake up. I have to manually turn them on for the task to run. wake on lan is configured on the clients nic



  • Are the nics in the server on different networks (i.e. is the subnet mask more than 16 bits / 255.255.0.0)?
    In which network are your clients?
    Do the clients actually wake up when the task is scheduled?

    Keep in mind that wakeonlan sends its packets to the broadcast address (255.255.255.255). Traffic to the broadcast address is not routed beyond the network in which it is generated.

    /etc/hosts is used for storing local hostname to IP address mappings. It is unlikely to be involved in the wakeonlan process.


Log in to reply
 

468
Online

6.4k
Users

13.8k
Topics

130.2k
Posts