Backing up database Failed on install



  • Everything thing else seems to be working fine during the install however it always fails at the step of backing up the database. Is there anyway to skip this step?Fog install.png


  • Senior Developer

    @Tom-Elliott said in Backing up database Failed on install:

    git checkout dev-branch

    @Rogsninja As Tom said, you need to use the latest dev-branch version as there were issues due to the CentOS 8 release that came out after we had published 1.5.7 (latest official FOG version).

    About install errors in general: The installer creates logs. Please take a look at /root/fogproject/bin/error_logs/fog_error_1.5.7.log and post the full content or a least the last 10 lines of that file here in the forums.



  • @Tom-Elliott this is what I have been using.
    sudo -i
    cd /root
    git clone https://github.com/FOGProject/fogproject.git
    cd /root/fogproject/bin
    ./installfog.sh
    however I just checked and it says the firewall is off but it when I just installed it was still detected as on. Can you tell me how to disable selinux because I think I missed that one.
    fog intall firewall.png


  • Senior Developer

    @Rogsninja What is the “latest version of fog”?

    Did you pull from master? If so then you’re running a version that isn’t going to install properly on CentOS 8 as it was released before CentOS 8 was released, and some things changed between CentOS 7 and 8 that required changes.

    As you are installing from git, you can change the branch to dev-branch by running:

    cd /your/path/to/git/fogproject
    git checkout dev-branch
    git pull
    cd bin
    ./installfog.sh -y
    


  • This time I didn’t disable the firewall however I have before and got this same error. I’m running CentOS 8.0 and I’m using the most recent version of fog I downloaded it using git so i’m not sure of the exact version. If you want I can run the install again with the firewall off.


  • Senior Developer

    Did you disable selinux and firewall?

    What version of FOG are you installing?

    What version of CentOS are you running off of?


Log in to reply
 

304
Online

7.4k
Users

14.5k
Topics

136.5k
Posts