SOLVED FOG installation errors

  • Hello All,

    I’m getting some issues with installation FOG on RHEL7.7 (I have a working box with Debian but we have to migrate it to RHEL due to some policy reason). The installation stop at Installing now everything is updated ........Failed…Upon inspecting fog_error_1.5.7.50.log, I saw a bunch of errors like this:

    Update notice FEDORA-EPEL-2014-4398 (from epel) is broken, or a bad duplicate, skipping.
    Update notice FEDORA-EPEL-2019-4e237c3a93 (from epel) is broken, or a bad duplicate, skipping.
    Update notice FEDORA-EPEL-2016-b072b4c9c7 (from epel) is broken, or a bad duplicate, skipping.


    Package mariadb-server is obsoleted by mysql-community-server, trying to install mysql-community-server-5.7.26-1.el7.x86_64 instead
    Resolving Dependencies
    --> Running transaction check
    ---> Package mysql-community-server.x86_64 0:5.7.26-1.el7 will be installed
    --> Processing Conflict: 1:mariadb101u-config-10.1.35-1.ius.el7.x86_64 conflicts mysql-community-server
    --> Finished Dependency Resolution
    Error: mariadb101u-config conflicts with mysql-community-server-5.7.26-1.el7.x86_64
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest

    Does anyone have any experience or has anyone encountered this similar issues?

    Thanks in advance for any assistance.

  • @Daniel-Miller Thanks Daniel. They use puppet. I’ll shoot them an email.

    Thanks again everyone for all the help.

  • @TaTa You mentioned early on that this machine is managed by an external entity. You may want to check with them to see if they are using some tool to enforce a desired state, such as Ansible, Puppet, or Chef.

  • @Sebastian-Roth You are right. vsftpd service wasn’t running. I have noticed vsftpd service gets disabled/deleted after a period of time or on reboot. xinetd and tftp service turns of by itself. I followed instructions on wiki page to disable selinux but it keeps on coming back. Any idea why?

  • Moderator

    @TaTa Can you please take a picture of the actual error(s) and post here. From the sound of things it’s caused by a messed up Linux account fogproject. This is a service account used by the FOG server and you shouldn’t use it to login or even change it’s password.

    Please take a look at the config in /var/www/html/fog/lib/fog/config.class.php (TFTP_FTP_PASSWORD) to see what password it should be set to. As well check /opt/fog/.fogsettings to make sure it’s the same in there. Then use an FTP client (like WinSCP, FileZilla, …) and try to connect to your FOG server via FTP using those credentials.

    It’s interesting you say that it works after re-running the installer but has issues when restarting the server. Please try rebooting your server and check for vsftpd process/service running after it booted up.

  • @Sebastian-Roth Storage Node unable to connect and create a new image in Images/Create new images

  • Moderator

    @TaTa said in FOG installation errors:

    the same issues came back.

    Which exact issue do you mean. Since starting the topic we ran into half a dozen issues and I am not sure which one you see now.

  • I re-ran the installation. Everything was working properly. I rebooted the server. the same issues came back. Re-ran installation, issue fixed. How do I make sure all of the required services are running?

  • @TaTa said in FOG installation errors:

    But Storage node and creating new image still don’t work.

    What message(s) appear when accessing the storage node or attempting to create a new image? Can you post the Apache error (/var/log/httpd/error_log), php error (/var/log/php*-fpm.log), and mysql error logs (/var/log/mysql/error)? It may also be helpful to verify your error log verbosity is at least 2 in your my.cnf.

  • @Daniel-Miller I was able to update database schema. I have to created the account with localhost and altered fogstorage account and set the host to ‘%’ but storage node and create new image still didn’t work. Then I deleted fogstorage and fog database and uninstalled fog and then reinstalled FOG and was able to update database schema without issue. But Storage node and creating new image still don’t work. I’m pretty sure there are some settings in mysql that is causing this.

  • @TaTa What is the result of select vvalue from fog.schemaVersion;?

  • @Daniel-Miller I did flush privileges a few times before reporting it. I even restarted the server a few times/ stopped/started mysql but no go.

  • @TaTa each username-host pairing is considered a distinct user, so there is no need to drop fogstorage@localhost before adding fogstorage@’%’. That being said, if the user fogstorage@’%’ has existed in the MySQL instance at any time since either A) the MySQL service has been restarted or B) the privilege table has been reloaded, the user you are attempting to add likely still exists in memory which would result in error 1396 if you attempt to add the same user again. Try restarting the mysql service or performing a flush privileges; in mysql and try again.

  • @Sebastian-Roth No more. Just that single line.

  • Moderator

    @TaTa said in FOG installation errors:

    ERROR 1396 (HY000): Operation CREATE USER failed for ‘fogstorage’@’%’

    No more error message???

  • @Daniel-Miller You are right. I checked my other fog server and it does have a wildcard but this one is localhost.

    i’m getting this error when creating one using the wildcard (after dropping fogstorage user).
    ERROR 1396 (HY000): Operation CREATE USER failed for ‘fogstorage’@’%’

    | user | host |
    | root | [myserverIP |
    | fogstorage | localhost |
    | mysql.session | localhost |
    | mysql.sys | localhost |
    | root | localhost |

  • @TaTa What indicates to you that the wildcard is not allowed? See MySQL’s documentation on creating accounts. It would be helpful to see both the error message encountered as well as the output of select user,host from mysql.user;

  • @Daniel-Miller mysql does not allow using the wildcard. How do i get around it? This might be related to freezing screen when clicking on “Create New Image” and “No master nodes available” when listing all images?

  • @TaTa The % in the host attribute is the mysql wildcard. This indicates that the user account is allowed to login from any machine. Changing this to localhost means you can only log in from a connection mysql / mariadb explicitly identifies as localhost. Unfortunately, localhost isn’t the only possible identifier possible for a local connection, for example it could use, so it is possible that this configuration would deny connections initiated on the same machine, which would result in that storage node warning.

  • I was able to go pass that stage by changing ‘%’ to localhost. I’m not sure if it does any harm. I’m getting “Storage Node Update Warning Unable to connect using ip, user, and/or password provided!” I confirmed that fogproject account has proper access to /images folder. Any thoughts?