Blank Install Page


  • Senior Developer

    @dsoden Please run: dnf -y install php-json



  • @Tom-Elliott said in Blank Install Page:

    /var/log/php-fpm/www-error.log

    [root@fogserver ~]# cat /var/log/php-fpm/www-error.log
    [01-Nov-2019 18:33:34 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function json_encode() in /var/www/html/fog/lib/db/pdodb.class.php:427
    Stack trace:
    #0 /var/www/html/fog/lib/db/pdodb.class.php(230): PDODB->sqlerror()
    #1 /var/www/html/fog/lib/db/pdodb.class.php(171): PDODB::currentDb(Object(PDODB))
    #2 /var/www/html/fog/lib/db/pdodb.class.php(180): PDODB->_connect(false)
    #3 /var/www/html/fog/lib/db/pdodb.class.php(103): PDODB->_connect()
    #4 /var/www/html/fog/lib/db/databasemanager.class.php(61): PDODB->__construct()
    #5 /var/www/html/fog/lib/fog/loadglobals.class.php(43): DatabaseManager::establish()
    #6 /var/www/html/fog/lib/fog/loadglobals.class.php(81): LoadGlobals::_init()
    #7 /var/www/html/fog/commons/base.inc.php(49): LoadGlobals->__construct()
    #8 /var/www/html/fog/management/index.php(22): require('/var/www/html/f...')
    #9 {main}
      thrown in /var/www/html/fog/lib/db/pdodb.class.php on line 427
    [root@fogserver ~]#
    

    worse because I assumed the question about changing the hostname… well changed the hostname of the system and app somehow, odd question if one does not have the context you provided above. That makes sense. Also I had not used that question till the last install round (like on #10 now) and when I did not see it work I figured more bugs.


  • Senior Developer

    @dsoden @Sebastian-Roth @george1421

    Please provide the error log from : /var/log/php-fpm/www-error.log

    This will provide the error causing your White Screen.

    The issue with CentOS 8 is being addressed, but we need information.

    You’re right that opensource works when it works, and believe me, we want to help and get this fixed.

    Changing the hostname, for fog, does not change the hostname for the machine. This is more related to updating the SSL certificates based on the DNS Server.

    The installer tries to do everything it can for you, but there are areas we try not to change, such as the physical machine hostname as there could be any number of reasons this is setup as such.

    Can you explain how it’s things are worse?

    I want to help, and I’m 100% sure we can get this fixed and running for you. I just need information to be able to do that. I actually have a CentOS 8 server running for testing at work.

    No amount of bickering, backtalk, or anything (from anyone) is going to help that.



  • @Sebastian-Roth said in Blank Install Page:

    latest developer source

    latest developer source -> no go same outcome - and worse

    LOG

    [root@fogserver ~]# cat /var/log/httpd/error_log
    [Fri Nov 01 14:31:11.907383 2019] [core:notice] [pid 5797:tid 139840572270848] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
    [Fri Nov 01 14:31:11.909722 2019] [suexec:notice] [pid 5797:tid 139840572270848] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using fe80::378d:ceba:514a:c75c. Set the 'ServerName' directive globally to suppress this message
    [Fri Nov 01 14:31:12.012179 2019] [lbmethod_heartbeat:notice] [pid 5797:tid 139840572270848] AH02282: No slotmem from mod_heartmonitor
    [Fri Nov 01 14:31:12.016303 2019] [mpm_event:notice] [pid 5797:tid 139840572270848] AH00489: Apache/2.4.37 (centos) OpenSSL/1.1.1 configured -- resuming normal operations
    [Fri Nov 01 14:31:12.016340 2019] [core:notice] [pid 5797:tid 139840572270848] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
    [root@fogserver ~]#
    
    
    [root@fogserver ~]# sestatus
    SELinux status:                 enabled
    SELinuxfs mount:                /sys/fs/selinux
    SELinux root directory:         /etc/selinux
    Loaded policy name:             targeted
    Current mode:                   permissive
    Mode from config file:          permissive
    Policy MLS status:              enabled
    Policy deny_unknown status:     allowed
    Memory protection checking:     actual (secure)
    Max kernel policy version:      31
    [root@fogserver ~]#
    
    

    -**** NEW ****
    one of the questions installer askes if you want to change host name - I said YES
    changed to fogserver.local
    never took…

    [root@fogserver ~]# hostname
    fogserver
    [root@fogserver ~]# cat /etc/hosts
    127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
    ::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
    [root@fogserver ~]#
    
    


  • @Sebastian-Roth wow - calm down man… apparently your one of those hyper sensitive folks with a massive ego made of glass! Your right its not your problem, it’s mine.



  • @dsoden I just happen to see your mention of cent in the signature bock =) I saw debian/unbuntu: and stopped reading as I thought the rest was code for that platform. facepalm my bad… Debian is however IMO the most accepted and preferable platform for this system


  • Developer

    @dsoden Please re-read what you write…

    I see 99% of most youtube videos on this app all using Debian and look at your own signature bloc where you say… Web GUI issue? Please check apache error (debian/ubuntu: /var/log/apache2/error.log, centos/fedora/rhel: /var/log/httpd/error_log) and php-fpm log (/var/log/php*-fpm.log) an there is no mention of CentOS.

    Just wrong!

    My point here is I would not have spent so much time fighting something that is likely a bug and report it much sooner.

    Not my problem.



  • @Sebastian-Roth I appreciate the community and open-source in general. Been using community driven products like CentOS and webmin/virtualmin for many years now. I’ve also come to expect a certain level of reliability in using them. not being able to install a product is usually a bad sign that things are not stable. Open source products work for folks when they work. I don’t want to debate or questions ones or a teams commitment or even diminish efforts, for that I am grateful. There is however a sense of reality in that one cant use and count on something if unstable. I get your all are now working on it. May I please make a valid suggestion based on the observation of a newcomer? Great thanks, perhaps say here… that Debin is (Recommended). I see 99% of most youtube videos on this app all using Debian and look at your own signature bloc where you say… Web GUI issue? Please check apache error (debian/ubuntu: /var/log/apache2/error.log, centos/fedora/rhel: /var/log/httpd/error_log) and php-fpm log (/var/log/php*-fpm.log) an there is no mention of CentOS. This confirms this community is in favor of Debian - which is totally fine. It sets expectations that Debian takes priority as its where most folks are at - hell I’d do the same too. My point here is I would not have spent so much time fighting something that is likely a bug and report it much sooner.

    Ill try the latest developer source. I don’t mind helping with testing at all and would be happy to. just trying to wrap my head around all of if. Plus I’m not a Linux admin normally - windows yes - for the record even with this bug herein ANYTHING has to be better than windows 10 stability. More and more I’m turning to Linux these days.



  • @george1421 no clue, I did not install it and virturalbox only assigned one. I assume CentOS detected something on the base install and added it. Not even sure if this is an issue. I see @Sebastian-Roth reply too and apparently there is a bug in the IO selection. using nmcli I downed and deleted.


  • Moderator

    @dsoden On your centos 8 install why is the virtual bridge 0 installed? While I’m sure there are other issues with the install, if you could hide that adapter from the installer, I fell you should get past this error.


  • Developer

    @dsoden You seem to be a bit disappointed, which I understand as things don’t work as expected. But see, this is a community driven open source software and we work hard to try and make things work as well as help people solve problems.

    CentOS 8 was released 5-6 weeks ago and I am aware we are behind. But as long as people don’t ask about it we usually don’t find the time to adjust the installer to meet new OS versions beforehand.

    As you see in this topic I have tried to replicate an issue reported by another using related to PHP but I couldn’t! The install simply worked for me, no problem.

    Not saying that the installer is perfect but please be patient and help us find and fix this. First I may ask you to use the latest developer source and try with that:

    sudo -i
    git clone https://github.com/FOGProject/fogproject/
    cd fogproject/bin
    ./installfog.sh
    

    By the way, that network interface selection BUG should be fixed in the developers version already.


  • Moderator

    @dsoden Why not centos 7 until rhel 8 is fully supports. Centos 7 should be very close and in the RHEL family. Centos 7 works out of the box. Personally I would not move over to the Debian camp just for FOG support. I’ve been a RHEL guy for 16 years (it feels) and I always feels lost moving to the other side.



  • This application definitely not comparable with CentOS 8, and I have not tried 7.x.

    All the youtube videos I watched was Debian based installs not RHL.
    So, I downloaded ubuntu-18.04.3-server (no experience with it) and it installed immediately as expected.

    Unfortunately I can not really use FOG till it properly supports CentOS. It is too complicated to learn both a new deployment system and OS for me and my folks. We standardized on RHL. Trouble shooting anything will take exponentially much longer on Debian. We spend 96% of our time on Windows.

    DANG! disappointing about this bug =(



  • also not sure if this is related but it seams like a BUG to me. The installer says

     Would you like to change the default network interface from enp0s3 virbr0?
      If you are not sure, select No. [y/N]
    
       * The network interface named enp0s3 virbr0 does not exist.
    
      We found the following interfaces on your system:
          * enp0s3 - 192.168.254.51/24
          * virbr0 - 192.168.122.1/24
    
      Would you like to change the default network interface from enp0s3 virbr0?
      If you are not sure, select No. [y/N]
    

    if I say N it goes in an endless loop I want enp0s3 - saying NO should move on, it does not. I have to say YES then explicitly retype in enp0s3 and then and only then does it move on. The fact is says it does not exist seams to me like it concatenated both interfaces names as a entity selection or a single object and well ya that in that context does not exist. Then it make sense why I have to explicitly name out the enp0s3 interface. but with that chosen one would think all is fine and that enp0s3 is the IO.

    I do not want to confuse my issue with a possible new or other bug unless they are all related directly.



  • the installer temp disables setting to permissive however sestatus says SELinux is enabled.
    I then once again reset my snapshot on the VM to the beginning and explicitly edited /etc/sysconfig/selinux and set SELinux=disabled then rebooted and reran the installer FRESH (due to snapshot rollback) and no joy same blank screen. httpd and php cat /var/log/httpd/error_log

    [root@fogserver ~]# cat /var/log/httpd/error_log
    [Fri Nov 01 10:06:59.700976 2019] [suexec:notice] [pid 5645:tid 139996773067008] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Fri Nov 01 10:06:59.758671 2019] [lbmethod_heartbeat:notice] [pid 5645:tid 139996773067008] AH02282: No slotmem from mod_heartmonitor
    [Fri Nov 01 10:06:59.760379 2019] [mpm_event:notice] [pid 5645:tid 139996773067008] AH00489: Apache/2.4.37 (centos) OpenSSL/1.1.1 configured -- resuming normal operations
    [Fri Nov 01 10:06:59.760393 2019] [core:notice] [pid 5645:tid 139996773067008] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
    [root@fogserver ~]#
    

    no clue if this suEXEC entry in the error log is causing issues here (appears to just be a notice) - I use CentOS mainly for specific use cases or products like web with virtualmin, past that for learning so I dont get too much time trouble shooting as things typically work well and are quite stable. The rest of the time I’m in windows and was looking at this solution for deployments hence FOG.

    mysql is good with blank password and I can see schema’s

    [root@fogserver ~]# mysql -u root
    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 16
    Server version: 8.0.17 Source distribution
    
    Copyright (c) 2000, 2019, Oracle and/or its affiliates. All rights reserved.
    
    Oracle is a registered trademark of Oracle Corporation and/or its
    affiliates. Other names may be trademarks of their respective
    owners.
    
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    
    mysql> show databases;
    +--------------------+
    | Database           |
    +--------------------+
    | information_schema |
    | mysql              |
    | performance_schema |
    | sys                |
    +--------------------+
    4 rows in set (0.01 sec)
    
    mysql>
    [2]+  Stopped                 mysql -u root
    [root@fogserver ~]#
    

    This is maddening - is this a problem with CentOS 8 and incompatibility with the installer?


  • Developer

    @dsoden Is SELinux disabled?

    Please check the Apache and PHP logs to see the actual error message. See my signature on where to find the logs. Post it here.


Log in to reply
 

298
Online

7.0k
Users

14.2k
Topics

134.4k
Posts