Blank Install Page



  • Did this like 5 times today and am about to give up.
    Fresh CentOS 8 install every time on VirtualBox, then installing Fog v1.5.7.

    All is well till I get to the page that tells me to go to the website to install the DB.
    The webpage is blank on the system and external to it hitting it from another chrome browser is a 500 error.

    Why is this so hard to install?


  • Moderator

    @dsoden said in Blank Install Page:

    firewall still not being detected after detection of SELinux and prompt to disable, which later causes problems non locally.

    I ran into the same issue the second time I setup a centos 8 server, but I know from the fog install prerequisites that selinux needs to be set to permissive and firewalld needs to be stopped before FOG is installed. So when it got to that point in the installer I noted it, but it continued without complaints. When I have time I was going to reverse engineer why the firewall’s state wasn’t being detected in centos 8, but decided to spend my weekend not hovering around my computer (til now).


  • Senior Developer

    @dsoden the dev-branch and working-1.6 already adds PHP-Json for OSVersion > 7. May need a bit more refining to ensure all is well with our fedora users. The error you presented was due to CentOS 8 moving to have php-json as a module separate from php-common as was done in the past. (The json error you saw.). Once that was fixed I knew you pulled master as the GRANT ALL in dev-branch and working-1.6 does not have the IDENTIFIED BY in the same line anymore, specifically because of there error you saw in trying to install it.

    I haven’t nailed down the firewalld issue as we do have a command trying to disable this already, but it seems to be failing.



  • @george1421 restored base install snap and red-ownloaded then switched to the dev-branch. confirmed by

    cat .git/HEAD
    ref: refs/heads/dev-branch
    

    re-ran installer

    • firewall still not being detected after detection of SELinux and prompt to disable, which later causes problems non locally.
    • install seams to be taking considerably longer (~double the original time - not that I care as it’s working) just bring it up in case there is value in it.

    I tried to hit the page and could not but once I stopped the firewall it works externally as expected and the install finished as expected - no need to manually run the below either - YEA!

    dnf -y install php-json
    

  • Moderator

    @dsoden With the error you received you missed a command in both Tom’s and my post to switch from the main branch (that came out before centos 8 was released) to the 1.6. dev branch (which was last updated just a few days ago) by issuing this command between the git clone and the installfog.sh

    git checkout dev-branch

    With out that command the fog installer will in stall 1.5.7 and that error will be generated. That is the same mistake I made when I setup the test install of Centos 8 in my environment.



  • @Tom-Elliott als for got to mention before I ran wget on the server to get to the install web page I ran

    dnf -y install php-json
    

    I was not sure if this fix was in the release from git - when I saw no change I then went on to realize it was a firewall issue. however it could still have needed this command too I do not know as I did not know about the firewall issue. Ideally I would have dissabled and only run the above if it was still failing or there was errors in the log - which never got a chance to log anything due to the firewall (chicken and the egg ;)



  • @Tom-Elliott - sorry it took so long to get back to you.

    I did a new fresh install of centos server no gui (my default) - up till now for installing this product I used server the GUI just in case I needed it.

    here are my observations and steps.

    obs: the reason my previous install had installed a bridge is because when installed the OS I forgot in virturalbox to change the network to bridged from NAT. I assume when set to NAT CentOS installs the bridge. With that being said I no longer had 2 interfaces to choose from. The installer still asked but when I said NO it went on as expected. not sure if something is actually fixed here or if simply eliminating 2 potential IO choices fixed the issue meaning there could still be issues here.

    Rest of install went smooth - however a new issue and here is how I found it. I reached the point for the schema web based install and the page never loaded - same 500 error, so ran the command you posted earlier

    ls: cannot access '/var/log/php-fpm/www-error.log': No such file or directory
    [root@fogserver ~]# ls  /var/log/php-fpm
    error.log
    [root@fogserver ~]# cat /var/log/php-fpm/error.log
    [02-Nov-2019 10:48:03] NOTICE: fpm is running, pid 17409
    [02-Nov-2019 10:48:03] NOTICE: ready to handle connections
    [02-Nov-2019 10:48:03] NOTICE: systemd monitor interval set to 10000ms
    

    the error log file name changed - however no error - happy about that but baffled too.
    next I ran on the server (remember no GUI) wget and the URL and I got the index.html page and ran cat on it. Looks promising so why in the hell can I not see it on my PC?

    Then it dawned on me the installer detected and asked to dissable SELinux but never asked about the firewall and systemctl status firewalld showed Active: active (running). systemctl stop firewalld and re ran the status and it off. BAM! now I can hit the web page to run the installation.

    back to the same issues (not knowing what code was fixed or tweaked - was not sure what to expect)

    Install / Update Failed!
    
    The following errors occurred
    Update ID: 16
    
    Database Error:
    
    Failed to query: Error: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IDENTIFIED BY 'fs19920677548'' at line 1 Error Message: Error Code: "42000", Error Message: ["42000",1064,"You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IDENTIFIED BY 'fs19920677548'' at line 1"], Debug: SQL: [70] GRANT ALL ON `fog`.* TO 'fogstorage'@'%' IDENTIFIED BY 'fs19920677548'
    Params: 0
    Variable contains:
    
    Array
    ( [0] => ALTER TABLE `tasks` ADD COLUMN `taskBPM` varchar(250) NOT NULL AFTER `taskPCT`, ADD COLUMN `taskTimeElapsed` varchar(250) NOT NULL AFTER `taskBPM`, ADD COLUMN `taskTimeRemaining` varchar(250) NOT NULL AFTER `taskTimeElapsed`, ADD COLUMN `taskDataCopied` varchar(250) NOT NULL AFTER `taskTimeRemaining`, ADD COLUMN `taskPercentText` varchar(250) NOT NULL AFTER `taskDataCopied`, ADD COLUMN `taskDataTotal` VARCHAR(250) NOT NULL AFTER `taskPercentText` [1] => CREATE TABLE `nfsGroups` (`ngID` integer NOT NULL AUTO_INCREMENT,`ngName` varchar(250) NOT NULL,`ngDesc` longtext NOT NULL,PRIMARY KEY (`ngID`)) ENGINE=MyISAM AUTO_INCREMENT=1 DEFAULT CHARSET=utf8 ROW_FORMAT=DYNAMIC [2] => CREATE TABLE `nfsGroupMembers` (`ngmID` integer NOT NULL AUTO_INCREMENT,`ngmMemberName` varchar(250) NOT NULL,`ngmMemberDescription` longtext NOT NULL,`ngmIsMasterNode` char NOT NULL,`ngmGroupID` integer NOT NULL,`ngmRootPath` longtext NOT NULL,`ngmIsEnabled` char NOT NULL,`ngmHostname` varchar(250) NOT NULL,`ngmMaxClients` integer NOT NULL,`ngmUser` varchar(250) NOT NULL,`ngmPass` varchar(250) NOT NULL,`ngmKey` varchar(250) NOT NULL, PRIMARY KEY (`ngmID`),INDEX `new_index`(`ngmMemberName`),INDEX `new_index2`(`ngmIsMasterNode`),INDEX `new_index3`(`ngmGroupID`),INDEX `new_index4`(`ngmIsEnabled`)) ENGINE=MyISAM AUTO_INCREMENT=1 DEFAULT CHARSET=utf8 ROW_FORMAT=DYNAMIC [3] => ALTER TABLE `images` ADD COLUMN `imageNFSGroupID` integer NOT NULL AFTER `imageDD`,ADD INDEX `new_index3`(`imageNFSGroupID`) [4] => ALTER TABLE `tasks` ADD COLUMN `taskNFSGroupID` integer NOT NULL AFTER `taskDataTotal`,ADD COLUMN `taskNFSMemberID` integer NOT NULL AFTER `taskNFSGroupID`,ADD COLUMN `taskNFSFailures` char NOT NULL AFTER `taskNFSMemberID`,ADD COLUMN `taskLastMemberID` integer NOT NULL AFTER `taskNFSFailures`,ADD INDEX `new_index5`(`taskNFSGroupID`),ADD INDEX `new_index6`(`taskNFSMemberID`),ADD INDEX `new_index7`(`taskNFSFailures`),ADD INDEX `new_index8`(`taskLastMemberID`) [5] => CREATE TABLE `nfsFailures` (`nfID` integer NOT NULL AUTO_INCREMENT,`nfNodeID` integer NOT NULL,`nfTaskID` integer NOT NULL,`nfHostID` integer NOT NULL,`nfGroupID` integer NOT NULL,`nfDateTime` integer NOT NULL,PRIMARY KEY (`nfID`),INDEX `new_index`(`nfNodeID`),INDEX `new_index1`(`nfTaskID`),INDEX `new_index2`(`nfHostID`),INDEX `new_index3`(`nfGroupID`)) ENGINE=MyISAM AUTO_INCREMENT=1 DEFAULT CHARSET=utf8 ROW_FORMAT=DYNAMIC [6] => ALTER TABLE `nfsFailures` MODIFY COLUMN `nfDateTime` datetime NOT NULL,ADD INDEX `new_index4`(`nfDateTime`) [7] => ALTER TABLE `multicastSessions` CHANGE `msAnon2` `msNFSGroupID` integer NOT NULL, ADD INDEX `new_index`(`msNFSGroupID`) [8] => INSERT IGNORE INTO `nfsGroups` (`ngName`,`ngDesc`) VALUES ('default','Auto generated fog nfs group') [9] => INSERT IGNORE INTO `nfsGroupMembers` (`ngmMemberName`,`ngmMemberDescription`,`ngmIsMasterNode`,`ngmGroupID`,`ngmRootPath`,`ngmIsEnabled`,`ngmHostname`,`ngmMaxClients`,`ngmUser`,`ngmPass`) VALUES ('DefaultMember','Auto generated fog nfs group member','1','1','/images','1','192.168.254.51','10','fogproject','=3cEyv}E') [10] => UPDATE `images` set imageNFSGroupID = '1' [11] => DELETE FROM `globalSettings` WHERE `settingKey` IN ('FOG_NFS_HOST','FOG_NFS_FTP_USERNAME','FOG_NFS_FTP_PASSWORD','FOG_NFS_DATADIR','FOG_NFS_DATADIR_CAPTURE') [12] => INSERT IGNORE INTO `globalSettings` (`settingKey`,`settingDesc`,`settingValue`,`settingCategory`) VALUES ('FOG_STORAGENODE_MYSQLUSER','This setting defines the username the storage nodes should use to connect to the fog server.','fogstorage','FOG Storage Nodes'),('FOG_STORAGENODE_MYSQLPASS','This setting defines the password the storage nodes should use to connect to the fog server.','fs19920677548','FOG Storage Nodes') [13] => GRANT ALL ON `fog`.* TO 'fogstorage'@'%' IDENTIFIED BY 'fs19920677548' [14] => UPDATE `schemaVersion` set `vValue`='16'
    )
    Database SQL:
    
    GRANT ALL ON `fog`.* TO 'fogstorage'@'%' IDENTIFIED BY 'fs19920677548'
    
    

    I than ran this on the database to see any additional info.

    [root@fogserver ~]# mysql
    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 1947
    Server version: 8.0.17 Source distribution
    
    Copyright (c) 2000, 2019, Oracle and/or its affiliates. All rights reserved.
    
    Oracle is a registered trademark of Oracle Corporation and/or its
    affiliates. Other names may be trademarks of their respective
    owners.
    
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    
    mysql> show databases
        -> ;
    +--------------------+
    | Database           |
    +--------------------+
    | fog                |
    | information_schema |
    | mysql              |
    | performance_schema |
    | sys                |
    +--------------------+
    5 rows in set (0.01 sec)
    
    mysql> use fog
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A
    
    Database changed
    mysql> GRANT ALL ON `fog`.* TO 'fogstorage'@'%' IDENTIFIED BY 'fs19920677548'
        -> ;
    ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IDENTIFIED BY 'fs19920677548'' at line 1
    

    So that’s where I am at and whats happened - not sure what else I was suppose to do or test.


  • Senior Developer

    The public download is meant to be stable, but please remember that 1.5.7 was released a few months ago (before CentOS 8|RH 8) was even available.

    If you can do git please run:

    git clone https://github.com/fogproject/fogproject.git /opt/fogprojectgit
    cd fogprojectgit
    git checkout dev-branch
    git pull
    cd bin
    ./installfog.sh
    

    You will be able to pull the fixes we put in by simply:

    cd /opt/fogprojectgit
    git pull # this pulls in any updates pushed out
    cd bin
    ./installfog.sh -y
    

  • Moderator

    @dsoden Where you are at right now exit out of the installer and open mysql -u root -p

    Then clean up the residue.

    DROP USER IF EXISTS 'fogstorage'@'%';
    DROP DATABASE fog;
    

    Then switch back to the root of the fogproject that was downloaded.
    and issue this command git checkout working-1.6

    then change back to bin
    and rerun the fog installer. You will see an error message about the firewall, but just go past that for the moment.



  • @Tom-Elliott @george1421 all good then Ill check back after a period of time.
    I’m using the public download version again because nothing was working.
    kinda getting lost where I’m suppose to be. Once you have things sorted let me know and Ill run a full clean test on my side - thanks!


  • Senior Developer

    @dsoden Mind ensuring your running on dev-branch?

    The IDENTIFIED BY line has been moved from the GRANT line to it’s own line due to CentOS 8 having a version of Mysql that’s’ newer. We have to separate the generation of the user.

    @george1421 and I are chatting in the background, we haven’t just left things alone, just need realtime assist.


  • Moderator

    @dsoden hold on, we found something and fixed something else. Tom and I are chatting at the moment. The 1.6 beta installs (almost) correctly on centos 8 1905



  • @Tom-Elliott said in Blank Install Page:

    SHOW GRANTS FOR fogstorage;

    in catching up I got the same SQL errors

    Running the show grants does this

    mysql> SHOW GRANTS FOR fogstorage;
    ERROR 1141 (42000): There is no such grant defined for user 'fogstorage' on host '%'
    

    in trying to re run the command in the browser
    GRANT ALL ON `fog`.* TO 'fogstorage'@'%' IDENTIFIED BY 'fs94543688031'

    I get this

    
    mysql> GRANT ALL ON `fog`.* TO 'fogstorage'@'%' IDENTIFIED BY 'fs94543688031'
        -> ;
    ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IDENTIFIED BY 'fs94543688031'' at line 1
    mysql>
    

    My version is

    mysql> select @@version
        -> ;
    +-----------+
    | @@version |
    +-----------+
    | 8.0.17    |
    +-----------+
    1 row in set (0.00 sec)
    

  • Senior Developer

    @george1421 working-1.6 or dev-branch are the branches you should be on. I don’t think we have a branch named just working anymore.


  • Moderator

    @Tom-Elliott I switched to working is that not the right one?


  • Senior Developer

    @george1421 Probably need to delete the user entirely.


  • Moderator

    @Tom-Elliott I’m still pecking at it. But this is what I know so far.
    This is failing

    GRANT USAGE ON 'fog'.* TO 'fogstorage'@'%' IDENTIFIED BY 'fs55548845957';
    

    But I can get the same results with.

    create user 'fogstorage'@'%' IDENTIFIED BY 'fs55548845957';
    grant all on fog.* to 'fogstorage'@'%';
    

    It was throwing an error on the grant all with single quotes around fog in fog.*


  • Senior Developer

    @george1421 And this is from Master branch I take it? As this is what shows up, now, for the dev-branch and working-1.6

    "DELETE FROM mysql.user WHERE user='$fogstoragenodeuser'",
    "CREATE USER '$fogstoragenodeuser'@'%' IDENTIFIED BY '$fogstoragenodepass'",
    "GRANT ALL PRIVILEGES ON `" . DATABASE_NAME . "`.* TO '$fogstoragenodeuser'@'%'",
    

    Master is not as far forward as dev-branch is.


  • Senior Developer

    @george1421 Can you run from MYSQL root user:

    SHOW GRANTS FOR fogstorage;
    

  • Moderator

    @Tom-Elliott said in Blank Install Page:

    install php-json

    I did a standard install and found a few things in the install script. I got to installing the schema and got the white screen of the OP. I went and check php-fpm error log and found the same error as the OP.

    Installing php-json pushed the install forward. Then went back to web ui and installed the schema and the following error was thrown in the web ui.

    Update ID: 16
    
    Database Error:
    
    Failed to query: Error: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IDENTIFIED BY 'fs55548845957'' at line 1 Error Message: Error Code: "42000", Error Message: ["42000",1064,"You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IDENTIFIED BY 'fs55548845957'' at line 1"], Debug: SQL: [70] GRANT ALL ON `fog`.* TO 'fogstorage'@'%' IDENTIFIED BY 'fs55548845957'
    Params: 0
    
    Variable contains:
    
    Array
    ( [0] => ALTER TABLE `tasks` ADD COLUMN `taskBPM` varchar(250) NOT NULL AFTER `taskPCT`, ADD COLUMN `taskTimeElapsed` varchar(250) NOT NULL AFTER `taskBPM`, ADD COLUMN `taskTimeRemaining` varchar(250) NOT NULL AFTER `taskTimeElapsed`, ADD COLUMN `taskDataCopied` varchar(250) NOT NULL AFTER `taskTimeRemaining`, ADD COLUMN `taskPercentText` varchar(250) NOT NULL AFTER `taskDataCopied`, ADD COLUMN `taskDataTotal` VARCHAR(250) NOT NULL AFTER `taskPercentText` [1] => CREATE TABLE `nfsGroups` (`ngID` integer NOT NULL AUTO_INCREMENT,`ngName` varchar(250) NOT NULL,`ngDesc` longtext NOT NULL,PRIMARY KEY (`ngID`)) ENGINE=MyISAM AUTO_INCREMENT=1 DEFAULT CHARSET=utf8 ROW_FORMAT=DYNAMIC [2] => CREATE TABLE `nfsGroupMembers` (`ngmID` integer NOT NULL AUTO_INCREMENT,`ngmMemberName` varchar(250) NOT NULL,`ngmMemberDescription` longtext NOT NULL,`ngmIsMasterNode` char NOT NULL,`ngmGroupID` integer NOT NULL,`ngmRootPath` longtext NOT NULL,`ngmIsEnabled` char NOT NULL,`ngmHostname` varchar(250) NOT NULL,`ngmMaxClients` integer NOT NULL,`ngmUser` varchar(250) NOT NULL,`ngmPass` varchar(250) NOT NULL,`ngmKey` varchar(250) NOT NULL, PRIMARY KEY (`ngmID`),INDEX `new_index`(`ngmMemberName`),INDEX `new_index2`(`ngmIsMasterNode`),INDEX `new_index3`(`ngmGroupID`),INDEX `new_index4`(`ngmIsEnabled`)) ENGINE=MyISAM AUTO_INCREMENT=1 DEFAULT CHARSET=utf8 ROW_FORMAT=DYNAMIC [3] => ALTER TABLE `images` ADD COLUMN `imageNFSGroupID` integer NOT NULL AFTER `imageDD`,ADD INDEX `new_index3`(`imageNFSGroupID`) [4] => ALTER TABLE `tasks` ADD COLUMN `taskNFSGroupID` integer NOT NULL AFTER `taskDataTotal`,ADD COLUMN `taskNFSMemberID` integer NOT NULL AFTER `taskNFSGroupID`,ADD COLUMN `taskNFSFailures` char NOT NULL AFTER `taskNFSMemberID`,ADD COLUMN `taskLastMemberID` integer NOT NULL AFTER `taskNFSFailures`,ADD INDEX `new_index5`(`taskNFSGroupID`),ADD INDEX `new_index6`(`taskNFSMemberID`),ADD INDEX `new_index7`(`taskNFSFailures`),ADD INDEX `new_index8`(`taskLastMemberID`) [5] => CREATE TABLE `nfsFailures` (`nfID` integer NOT NULL AUTO_INCREMENT,`nfNodeID` integer NOT NULL,`nfTaskID` integer NOT NULL,`nfHostID` integer NOT NULL,`nfGroupID` integer NOT NULL,`nfDateTime` integer NOT NULL,PRIMARY KEY (`nfID`),INDEX `new_index`(`nfNodeID`),INDEX `new_index1`(`nfTaskID`),INDEX `new_index2`(`nfHostID`),INDEX `new_index3`(`nfGroupID`)) ENGINE=MyISAM AUTO_INCREMENT=1 DEFAULT CHARSET=utf8 ROW_FORMAT=DYNAMIC [6] => ALTER TABLE `nfsFailures` MODIFY COLUMN `nfDateTime` datetime NOT NULL,ADD INDEX `new_index4`(`nfDateTime`) [7] => ALTER TABLE `multicastSessions` CHANGE `msAnon2` `msNFSGroupID` integer NOT NULL, ADD INDEX `new_index`(`msNFSGroupID`) [8] => INSERT IGNORE INTO `nfsGroups` (`ngName`,`ngDesc`) VALUES ('default','Auto generated fog nfs group') [9] => INSERT IGNORE INTO `nfsGroupMembers` (`ngmMemberName`,`ngmMemberDescription`,`ngmIsMasterNode`,`ngmGroupID`,`ngmRootPath`,`ngmIsEnabled`,`ngmHostname`,`ngmMaxClients`,`ngmUser`,`ngmPass`) VALUES ('DefaultMember','Auto generated fog nfs group member','1','1','/images/','1','10.96.151.182','10','fog','Jq2ddrAigb4iMEAjsg0Ez6U0nb5n52nZRBY5RyJ5CC0=') [10] => UPDATE `images` set imageNFSGroupID = '1' [11] => DELETE FROM `globalSettings` WHERE `settingKey` IN ('FOG_NFS_HOST','FOG_NFS_FTP_USERNAME','FOG_NFS_FTP_PASSWORD','FOG_NFS_DATADIR','FOG_NFS_DATADIR_CAPTURE') [12] => INSERT IGNORE INTO `globalSettings` (`settingKey`,`settingDesc`,`settingValue`,`settingCategory`) VALUES ('FOG_STORAGENODE_MYSQLUSER','This setting defines the username the storage nodes should use to connect to the fog server.','fogstorage','FOG Storage Nodes'),('FOG_STORAGENODE_MYSQLPASS','This setting defines the password the storage nodes should use to connect to the fog server.','fs55548845957','FOG Storage Nodes') [13] => GRANT ALL ON `fog`.* TO 'fogstorage'@'%' IDENTIFIED BY 'fs55548845957' [14] => UPDATE `schemaVersion` set `vValue`='16'
    )
    
    Database SQL:
    
    GRANT ALL ON `fog`.* TO 'fogstorage'@'%' IDENTIFIED BY 'fs55548845957'
    

    I’m currently working through this error.


Log in to reply
 

430
Online

6.3k
Users

13.7k
Topics

128.9k
Posts