PHP install error



  • Try to install Fog1.5.7
    OS Ubuntu 14.04.6 LTS (Trusty)
    Changed the static ip adress so i tought that the best thing to do was to uninstall and start a Fresh intall of FOG.
    I am getting a error that says that my PHP files does not exist under installastion

    Here is the Error log.

    Reading package lists…
    Building dependency tree…
    Reading state information…
    E: Unable to locate package php
    dpkg-query: no packages found matching php-bcmath
    dpkg-query: no packages found matching php-cli
    php-google-api-php-client
    Reading package lists…
    Building dependency tree…
    Reading state information…
    E: Unable to locate package php-cli
    dpkg-query: no packages found matching php-curl
    dpkg-query: no packages found matching php-fpm
    dpkg-query: no packages found matching php-gd
    ii php-gettext 1.0.11-1 all read gettext MO files directly, without requiring anything other than PHP
    suphp-common
    dpkg-query: no packages found matching php-common
    suphp-common
    Reading package lists…
    Building dependency tree…
    Reading state information…
    E: Unable to locate package php-common
    dpkg-query: no packages found matching php-mbstring
    dpkg-query: no packages found matching php-mysql
    dpkg-query: no packages found matching php-mysqlnd
    sysv-rc-conf
    Reading package lists…
    Building dependency tree…
    Reading state information…
    The following packages were automatically installed and are no longer required:
    libbrotli1 libdbusmenu-gtk4 libjansson4 libnghttp2-14
    Use ‘apt-get autoremove’ to remove them.
    The following NEW packages will be installed:
    sysv-rc-conf
    0 upgraded, 1 newly installed, 0 to remove and 8 not upgraded.
    Need to get 0 B/22,7 kB of archives.
    After this operation, 85,0 kB of additional disk space will be used.
    Selecting previously unselected package sysv-rc-conf.
    (Reading database … 176033 files and directories currently installed.)
    Preparing to unpack …/sysv-rc-conf_0.99-7_all.deb …
    Unpacking sysv-rc-conf (0.99-7) …
    Processing triggers for man-db (2.6.7.1-1ubuntu1) …
    Setting up sysv-rc-conf (0.99-7) …
    ii tar 1.27.1-1ubuntu0.1 i386 GNU version of the tar archiving utility
    ii tftpd-hpa 5.2-7ubuntu3.1 i386 HPA’s tftp server
    ii tftp-hpa 5.2-7ubuntu3.1 i386 HPA’s tftp client
    ii unzip 6.0-9ubuntu1.5 i386 De-archiver for .zip files
    ii vsftpd 3.0.2-1ubuntu2.14.04.1 i386 lightweight, efficient FTP server written for security
    ii wget 1.15-1ubuntu1.14.04.5 i386 retrieves files from the web
    ii xinetd 1:2.3.15-3ubuntu1 i386 replacement for inetd with many enhancements
    ii zlib1g:i386 1:1.2.8.dfsg-1ubuntu1.1 i386 compression library - runtime
    Reading package lists…
    Building dependency tree…
    Reading state information…
    E: Unable to locate package libapache2-mod-php
    E: Unable to locate package php
    E: Unable to locate package php-cli
    E: Unable to locate package php-common
    Reading package lists…
    Building dependency tree…
    Reading state information…
    E: Unable to locate package libapache2-mod-php
    E: Unable to locate package php
    E: Unable to locate package php-cli
    E: Unable to locate package php-common


  • Senior Developer

    @viggo While you are right that my answer might not be of much help I don’t see why I should put in effort to help you sort this issue on a Linux OS FOG simply doesn’t support anymore.



  • The only reason is because i am lasy, i was just trying to find out what is wrong. I can of course reinstall the server with a newer version of Uuntu. … This reply did not help me much…


  • Senior Developer

    @viggo said in PHP install error:

    OS Ubuntu 14.04.6 LTS (Trusty)

    Is there a good reason you still use a Linux version that is end of life?


Log in to reply
 

347
Online

7.4k
Users

14.5k
Topics

136.7k
Posts