Avoid shrinking non-selected partitions during capture?

  • My settings below. I’m trying to only capture my /root partition that is 20 GB but FOG goes through “shrinking” each partition which takes forever because it is a 1 TB drive.


  • Doh - I actually didn’t realize the “Multiple Partition Image - Single Disk” could do a single partition! I just tried a capture using this and it seems to work fine - haven’t had a chance for a deploy yet. I guess since I foresee only rarely changing partition sizes, this option would work fine.

  • Moderator

    @humoss233 Why not set it to non-resizable? You need to know that resizing was one of the key features in FOG since the early days. Imaging only one partition was added way later. Because of that the resize logic is still very much tied around the view if resizing partitions to match a different disk size. It’s not well equipped to resize and capture/deploy one single partition.

    Not saying we cannot change this but it needs a lot of work and testing which we don’t have at the moment.

    So I suggest you try non-resizable image type (guess you already have) and explain why this is not working in your situation. Maybe even post pictures of errors you run into so we can look into fixing this.